NEW Repo for Remote files (Thanks to Betatester)

FYI, the remote you have is a WeChip G20S which is intended as a replacement remote for NVIDIA Shield.


I repeat that it worked earlier and when I bought it it gave compatibility with Linux. If it never worked then I would understand. But first he worked and that’s what I don’t understand.

I stopped using the original remote control because the aiming had to be very precise and directed towards the box otherwise it didn’t work. But I would have continued to use that.

well I was able to interpret the IR command set by the original remote random to the G20 and I got:

69.300319: event type EV_MSC (0x04): scancode = 0x140
69.300319: event type EV_SYN (0x00).

This is the event that turns on the device from off. Now I would like to understand why if it works from off to on it cannot work in reverse ie from on to off. The original remote does this. Anyone know?

Odroid C4 : CoreELEC 9.2.5

IR Remote Controller:

Setup IR Remote Controller as per:



# table 0X4DB2, type: NEC
0xb2dc KEY_POWER
0xb288 KEY_MUTE
0xb282 KEY_HOME
0xb2ce KEY_ENTER
0xb2ca KEY_UP
0xb299 KEY_LEFT
0xb2d2 KEY_DOWN
0xb2c1 KEY_RIGHT
0xb2c5 KEY_MENU
0xb29a KEY_BACK


# Keymaps table
# This table creates an association between a keycode file and a kernel
# driver. It can be used to automatically override a keycode definition.
# Format:
#       driver - name of the driver provided via uevent - use * for any driver
#       table -  RC keymap table, provided via uevent - use * for any table
#       file - file name. If directory is not specified, it is first looked up
#               in /storage/.config/rc_keymaps, then /usr/lib/udev/rc_keymaps
# For example:
# driver        table           file
# gpio-rc-recv  rc-streamzap    streamzap
# gpio-rc-recv  *               justboom
# *             rc-rc6-mce      rc6_mce_new
# *             *               hauppauge_new
meson-ir * 0X4DB2

I have the A95X Max as well, but I can’t get the remote to work with the conf file provided bij @thecook
Am I missing something?
Put the conf file in the /storage/.config/rc_keymaps folder and edited the rc_maps.cfg file in the /storage/.config to point to the condig file.
No response on the remote buttons after reboot.
Any ideas?

copy remote.conf to /storage/.config

1 Like

Thanks, that did it!
Remote is working with the conf at that location

Hello, good and first of all thank you, reading in the forum I have been able to configure my remote and add a button to wake up my tv box vontar x3, only one thing that I can not get, is that when I turn on the television it wakes me up the tv box, any suggestions on how I can solve that when I turn on my tv the tvbox does not wake me up ??? thank you first of all.

Sounds like a CEC issue.

Thanks for your answer, I don’t understand what the problem is in the CCA, what I will have to try is on another TV, let’s see if it’s a TV thing that is Android and that’s why the tvbox wakes me up, it’s not a big problem, but in case you know someone who has happened to you and could have an easy solution.
thanks :grinning:

1 Like

Thank you. They work for me also. (X99max+ -s905x3)

1 Like

created and shared.

remote.conf (3.0 KB) .

You haven’t told anyone what device this is used with. If you can’t find it in the repo, then you will need to make your own, using the instructions, also in the repo.

@OliXel Please go to the repository and find the config for the NexBox A95X remote. I believe that one might work.

I have the TV box A95X F3 4/32. Is there a remote conf for Coreelec?
Thanks a lot!

It’s there

Not sure if anyone uses it, but i have made an remote conf. for the eminent 7680 streamer.

em7680.txt (833 Bytes) rc_maps.cfg (18 Bytes)

Designed for TV BOX Mecool without DVB tuner and is universal (3.8 KB)