NEW Repo for Remote files (Thanks to Betatester)

Can you send me a picture of Kodi Settings / System Information / Summary

It’s only supported on NG releases. You can use NG with your S905X device.

Quad-core is 905X and Octa-core is 912.

@TheCoolest can I install NG version in both chipset?

Only S905X.

Any suggestion to resolve also in S912 (Mecool BB2 not Pro)? I seen exist specific image for BB2. I attached the photo of the S905X device. Name M96X.

A post was merged into an existing topic: CoreELEC Amlogic-ng(4.9 kernel) for S905X/S905D/S905W - Getting Started

This is the remote no longer work. Can you say me which cfg file works with this? Keed in mind he have external usb adapter to work. In this case the command “ir-keytable -t” does not work and i can’t read the code on cmd!.

The repo has pictures for comparison. Maybe start there.

It should work out of the box.
All my USB receiver type remotes work OTB.

Did this previously work with a previous CE image ?
You say “No longer works”

Let’s make order. The remote control initially worked without any problem both in power on and power off. Then one day it stopped working as a power off. This will probably happen when the image of 905x and 912 has been merged. Now even if I program the power on from the original remote control it doesn’t work anymore. That is, the original remote control programs the ir button but does not work on the 905x. I have two identical remotes. On the 912 it works in power on but does not work in power off. On the 905x after reinstalling it does not work either on or off even when inserting the previous configuration files. The secondary remote works everything except the power button via ir. I hope I have clarified the problem.

FYI, the remote you have is a WeChip G20S which is intended as a replacement remote for NVIDIA Shield.


I repeat that it worked earlier and when I bought it it gave compatibility with Linux. If it never worked then I would understand. But first he worked and that’s what I don’t understand.

I stopped using the original remote control because the aiming had to be very precise and directed towards the box otherwise it didn’t work. But I would have continued to use that.

well I was able to interpret the IR command set by the original remote random to the G20 and I got:

69.300319: event type EV_MSC (0x04): scancode = 0x140
69.300319: event type EV_SYN (0x00).

This is the event that turns on the device from off. Now I would like to understand why if it works from off to on it cannot work in reverse ie from on to off. The original remote does this. Anyone know?

Odroid C4 : CoreELEC 9.2.5

IR Remote Controller:

Setup IR Remote Controller as per:



# table 0X4DB2, type: NEC
0xb2dc KEY_POWER
0xb288 KEY_MUTE
0xb282 KEY_HOME
0xb2ce KEY_ENTER
0xb2ca KEY_UP
0xb299 KEY_LEFT
0xb2d2 KEY_DOWN
0xb2c1 KEY_RIGHT
0xb2c5 KEY_MENU
0xb29a KEY_BACK


# Keymaps table
# This table creates an association between a keycode file and a kernel
# driver. It can be used to automatically override a keycode definition.
# Format:
#       driver - name of the driver provided via uevent - use * for any driver
#       table -  RC keymap table, provided via uevent - use * for any table
#       file - file name. If directory is not specified, it is first looked up
#               in /storage/.config/rc_keymaps, then /usr/lib/udev/rc_keymaps
# For example:
# driver        table           file
# gpio-rc-recv  rc-streamzap    streamzap
# gpio-rc-recv  *               justboom
# *             rc-rc6-mce      rc6_mce_new
# *             *               hauppauge_new
meson-ir * 0X4DB2

I have the A95X Max as well, but I can’t get the remote to work with the conf file provided bij @thecook
Am I missing something?
Put the conf file in the /storage/.config/rc_keymaps folder and edited the rc_maps.cfg file in the /storage/.config to point to the condig file.
No response on the remote buttons after reboot.
Any ideas?

copy remote.conf to /storage/.config

1 Like

Thanks, that did it!
Remote is working with the conf at that location

Hello, good and first of all thank you, reading in the forum I have been able to configure my remote and add a button to wake up my tv box vontar x3, only one thing that I can not get, is that when I turn on the television it wakes me up the tv box, any suggestions on how I can solve that when I turn on my tv the tvbox does not wake me up ??? thank you first of all.

Sounds like a CEC issue.