NEW Repo for Remote files (Thanks to Betatester)

Well thanks for that, but honestly, how do you expect anyone to help you with just that statement.

If you have a file that works & you just want to edit it, why ssh? Use notepad++

I am with permission error. I can’t access the device.


is there another way to access the terminal? putty is not compatible with this system.

I use coreftp lite

***I now have access to folders through SSH.

How do I access the terminal to enter commands to disable kodi and eventlircd?

Firstly you must SSH into your device and then Kodi and eventlircd services must be stopped.

systemctl stop kodi
systemctl stop eventlircd

Next you need to run ir-keytable to scan for remote codes.

ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t

Use putty, perhaps you used the wrong password when you used it before.

I changed the door to 22 and managed to start only with the message below. Does not open the command lineimg1


I think that you are using wrong IP address, and wrong Putty version. My version 0.70 looks like this:

really. Thanks @Sholander
I have a lower version that doesn’t even have the ssh option.img3

something wrong with “ir-keytable”.


sorted out. I forgot to convert both files to UNIX using notepad ++


I am very grateful for the support of this spectacular Coreelec team !!! Congratulations!!

If you are successful in creating a working remote, please follow the instruction on how to upload with pictures etc.

sorted out. I managed to configure my RC10 dreambox control with coreelec. Attached pdf with instructions that helped me. Thank you!

Please could you add your remote to the repo using the instructions in this link.


I just wanted to make everyone aware that the tools and tutorials used by @ultra_signal are available in the Library section of the repository.

I would like to take the opportunity to stress once more that the repository is a centralized resource solution for remote controller related issues, not only hosting remote configuration files, but also the tools, tutorials and documentation required to create a configuration file.

Any Info which remote.conf works for the X99MAX (S922x) ?

X99 Max:

Did you check the repo? If there isn’t one, then read the instructions on how to create one, also in the repo.
Your remote looks exactly like the one I have for my X96 Max+, I used a X96 mini one, I think

The X92 and X96 both use the same remote. Both are available from the repository both as AmRemote and Meson_IR. Please let me know if it works for the X99 so I can add this information to the repository. Thanks.

1 Like

Thank you already, but sadly…

Tried all three:

  • AMremote\X96_Air
  • MESEN_IR\X96_Air
  • MESEN_IR\X92

and folled these intructions:
copy X92_remote to /storage/.config/rc_keymaps/
copy rc_maps.cfg to /storage/.config/
copy remote.xml to /storage/.kodi/userdata/keymaps/

Also tried: the Remote.conf from my X96 Max+ (s905x3, same remote).

All 4 are NOT working - any more ideas. ?? :frowning:

Yes create your own from the instructions also in the repo