New UGOOS X4Q (new form factor)

While waiting for information from Ugoos regarding device tree and not working ethernet port:

There is a display issue with some video formats:

  • H.264 / 720 HD works fine
  • H.264 / 1080 HD and MPEG-2 / 576 SD have permanent artefacts:


Note:
The black area on the top right corner of the screenshot can be ignored. This is a bug in screenshot utility.

See also attached journals:

h264-720hd.log (10,8 KB)
h264-1080hd.log (15,2 KB)
mpeg2-576sd.log (14,7 KB)

kodi.log (66,2 KB)

1 Like

May share a short sample were you can replicate the issue? A few seconds are enough.

smartphone video:

I’m glad someone else got onto this before mine arrived. Thanks for doing the work to get partial support working.

I’m using the Amlogic-ne builds, currently the 20.1 nightly from 2023-01-29.

One question I had was, which is the closest device tree to use? I picked sc2_s905x4_ugoos_x4 because it sounded like the closest, but I wasn’t sure…

can anyone tell me the current status of this platform?

have these issues been resolved?

can CoreELEC be installed to emmc?

Nothing new, no. As Ugoos is from Russia there is right now a Problem to communicate with the rest of the world, except China.

Hi,
I have this box, so i have done some tests.

  • CoreELEC 20.0-Nexus amlogic ng:
    Gigabit LAN port - working
    WiFi - working
    Bluetooth - working
    Spdif digital port - working DD and DTS

  • CoreELEC 20.0-Nexus amlogic ne:
    Gigabit LAN port - not working
    WiFi - working
    Bluetooth - working
    Spdif digital port - not tested yet

The dtb used on both releases: sc2_s905x4_ugoos_x4.

So far on NG, the only problem i found was after shutdown the led remains white lit.
I’m going to do more tests, i’ll give feedback of the results.

Regards

1 Like

I’ve been using the ne nightly releases for a little while - the box mostly works fine with wifi and bluetooth. The CEC parts don’t seem to work quite right though.
Originally, the TV remote worked to control Kodi, but the TV would also put the box into suspend or shutdown whenever I turned the TV off… but not turn it back on again.

I tweaked the CEC settings in Kodi, to stop it suspending – but it still continues to suspend when the TV goes off. However the TV remote no longer controls Kodi.

If gigabit port is working on NG, is it possible to make it work on NE?

I think this device do have the Maxio PHY assembled.
There is currently a PR ongoing about this driver and will be hopefully merged soon.

I’ve followed the forum for years, but this is the first time I’m writing here.

I just got an Ugoos X4Q and I thought I could share my findings. I installed CoreELEC 20.1-Nexus amlogic-ne and used sc2_s905x4_4g_1gbit as dtb. Everything is working as expected (ethernet, wifi, bluetooth, cec, …). The only issue I found was the led, which wouldn’t turn off when I powered off the box, but luckily I found the fix after checking the android dtb.img.

mount -o remount,rw /flash
fdtput -t x /flash/dtb.img /gpioleds/sys_led gpios 17 1c 0
sync
mount -o remount,ro /flash

The middle number in gpio was 28 and I changed it for 1c. Now the led settings in CoreElec hardware menu work, and when I power off the box the led also goes off. I also tested sc2_s905x4_ugoos_x4 dtb, but the led was white (instead of green) and I couldn’t find the green led settings in dtb (only red and blue).

Last thing, the IR remote was not working out of the box, but I paired it (as bluetooth) pressing the volume buttons together and then it started working. Since the menu button was not doing anything, I mapped it creating the file /etc/udev/hwdb.d/UR01_BLE.hwdb with this content:

# Ugoos UR01-BLE Consumer Control
evdev:input:b0005v005Dp0001*
 KEYBOARD_KEY_c0040=c	# Contextual menu

I followed the instructions here if anyone is interested.

2 Likes

@fefifofum : thanks for report. Did you install on eMMC as well?

I’ ve tried the dtb sc2_s905x4_4g_1gbit, but usb ports didn’t work, so i returned to ugoos x4 dtb.

@tasinofan : no, I didn’t, I want to keep Android for a bit longer.

@jnchester : you are right, I didn’t notice when testing sc2_s905x4_4g_1gbit.dtb

Anyway, I made a new dtb based on ugoos x4 but with the led fix for x4q, I attach it to this message.

sc2_s905x4_ugoos_x4q.dtb (64,2 KB)

In case anyone can add a initial ugoos x4q dtb in github repo, these are the led gpios:

Green = <0x17 0x1c 0x00>
Red = <0x17 0x25 0x00>
Blue = <0x17 0x26 0x00>

Thanks for the dtb, but it doesn’t work.
It just appear the logo and then reboot. Remains on loop and doesn’t boot.

@fefifofum

about ceemmc, I should not have asked … I read in wiki that it is unavailable for s905x4.

Today I set up a TV box Ugoos X4Q Pro.
LAN does not work on version 20.1ng.
On version 20.1ne LAN - ok, but image defects, as described above.
I tested with dtb: sc2_s905x4_ugoos_x4 and sc2_s905x4_4g_1gbit.
How to solve this problem ?

Update to nightly.

21.0-Omega_alpha1 NG: LAN-ok, image with defects :((

sorry to bring up an old topic, please redirect if this isn’t the right place.

also, please forgive this noob question: how are you all getting this to boot? I have an X4Q Plus.

I dd’d the coreelec image to a microsd card, copied the dtb to root (tried both logical images, in turn). then, attempted to boot using the instructions in the wiki (hold in reset pin while inserting the power cable). But… it gets caught in a boot loop, apparently.

what am i missing? thanks

edit: just tried the nightly and it boots fine. now i’m stuck at the “missing partition ‘super’ on emmc”. since i’m just testing this out before nuking the android install, i’m not sure if I can get past this step to test it. i’m open to suggestions, though. thank you!