New UGOOS X4Q (new form factor)

I have the same missing super partition message after ROM update to 1.1.7. Try previous ROM 1.1.4.

Thanks, I’ll try this. I don’t have a windows machine to use their burn tool exe, but I see the firmware 7z (from their website) has an img inside… so, theoretically, I could just boot into coreelec from a microsd and use dd, right?

No, the image must be flashed with the burn tool under Windows.

Meanwhile I had the same “missing super partition” message with the old firmware as well.
But after an update of corelec nightly, the message disappeared.

Might be a coreelec problem.

Just for info : latest nightly CoreELEC-Amlogic-ne.aarch64-20.3-Nexus_nightly_20230830-Generic :
Lan is working, Wifi ok, display issue with some video formats are gone…i am happy atm…testing forward…picture on this player is better then on N2 and LG Oled…and btw : use Android ROM 1.1.4. in ROM 1.1.7 wont work (message missing partition ‘super’ on emmc”).

2 Likes

just curious : how many CPU cores does the X4Q have?

If I remember well, it has 4 CPU cores…

1 Like

@humaxboy : So would you conclude Ugoos X4Q works well (i.e. nothing obvious does not work)? Which device tree did you use? I guess: sc2_s905x4_ugoos_x4.dtb? Also did you try to install on eMMC? I ask because I have a Ugoos X4 Pro and I would next want to try newer Ugoos X4Q Pro or Plus.

Still testing…looking pretty good…using ugoos_x4.dtb. eMMC and Ugoos X4Q doesn’t work. I have to solve problem with ROM 1.1.7 and message missing partition ‘super’ on emmc”

3 Likes

I found the way…install Coreelec on Android ROM 1.1.4, then do the upgrade in Android on 1.1.7…atm I am testing CoreELEC-Amlogic-ne.aarch64-20.3-Nexus_nightly_20230911-Generic and first tests are promising.

1 Like

i just tried that same path, and no luck. still get the same error about the missing super partition, and no playback is possible.

for now, i can use it fine with the ugoos android image, i’d just rather use coreelec. i’m not that bothered so far though because i know that sooner or later the coreelec team will get it working.

Start CE and enable terminal sharing so I can look around what is going on.

https://wiki.coreelec.org/coreelec:term_share

@vpeter sorry for the delayed reply. it’s enabled. connection name is my user handle here.

From what I see vendor partition can’t be mounted. And the error looks similar from what I saw on some other device where ceemmc was used and looks like something bad happen. Is this virgin Android install or you also used ceemmc? And did you even boot to android at least once?

i’ve never used ceemmc yet - i want to verify coreelec functionality before making that leap. so, it’s virgin android with CE installed only on a micro-sd. my latest attempt was like this:

  • downgraded ugoos to 1.1.4, then rebooted to ugoos;
  • installed latest CE nightly (waited until full boot in CE, saw the error message);
  • rebooted into ugoos and performed system upgrade to 1.1.7 (hoping it’d recreate whatever partition setup it’s supposed to),
  • rebooted and checked that its version was correct.
  • rebooted into CE to enable terminal sharing.

edit: spelling

Hi everyone,

I have the same bug that @ast261, it is a hardware acceleration bug on 1080 videos +MPEG-2.

I have fixed this shadow image switching off Hardware CE acceleration option, but now appear cleary image with delay, to fix delay deactivate option “deinterlacing method” during watching video options.

Someone knows another solution more easily to avoid switching these options on every watching?

hey @vpeter i got it working… somehow. i did two things at once, and am totally unsure which one was the actual ‘fix’: installed the latest v21 generic nightly… AND just before i did, i had toggled the setting within the android settings to enable root/magisk (didn’t reboot back into android after doing that, though).

since there’s nothing related in the CE changelog, i’m guessing rooting the device was the actual fix. but, all playback is working, there’s no error window. hevc and av1 both work flawlessly. i don’t know if this will survive a reboot, but i’m hopeful. and i can finally re-use my odroid c4 for other projects.

i left the term share open if you want to poke around and see if there’s anything helpful.

1 Like