Nexbox A95X-B7N

Hello, currently im running the above mentioned box with S905X and 1 GB of RAM on the 9.2.8 build, which was working fine till i needed some unsupported Python 3 Updates.

Im trying to get the new build to work, but after the box does some loading and rebooting, i see the coreelec logo and after that only black screen. i tried 2 usb sticks and sd cards already. nothing works.

im trying to run exactly this, with the device tree. it does not work for me…
The legacy build on internal emmc is running good. What is going on here?

The problem is on your end.

CoreELEC 19.5 RC2 boots successfully from 32 Gb μSD Card on NexBox A95X-B7N (1/8).

My test box has 9.2.8 on eMMC.

No issues noted, all hardware detected. See: http://ix.io/47LH

Troubleshooting CoreELEC

Host CPU: Amlogic S905X rev b, 4 cores available

→ I have S905X rev A as what my internal corelec installation says.

Ive read through forums and people said i would need Android 7 and dual boot?

Now i tried to update from 9.2.8 to 19.5 which the instruction of this thread:

So i put the tar file in the .update directory and created the .nocompat file. This result in a sucessful update at least.

Nexbox restarted and everyting is brickend now on internal emmc. Im stuck at the nexbox logo.

The old 9.2.8 build ( non ng!) is working through sd tho…

Where can i find the latest android nougat 7.1 installation? Ive downloaded this file 472.35 MB file on MEGA and followed this instructions: https://androidpctv.com/amlogic-firmware-update-guide-tvbox/

Even holding the reset button im stuck at the nexbox logo somehow.

You’ll have to re-flash the firmware with USB Burning Tool or Boot Card Maker.

Nexbox Firmware Archive

1 Like

Two things. First: you can’t upgrade CE from Leia to Matrix installed on emmc. You have to install Android prior and then run ceemmc -x to install CE in emmc. If you have the 8gig ROM Version, you might better off running CE from SD card. Second: you have to upgrade your bootloader to at least 7.1.x in order to run Matrix.

That is incorrect. Leia can be upgraded to Matrix, however, it breaks python compatibility (Leia = python 2 / Matrix = python 3), meaning all addons have to be upgraded also.

Therefore Team CoreELEC recommends a clean install instead of an upgrade.

You’ll have to re-flash the firmware with USB Burning Tool or Boot Card Maker.

BurnCard-Tool is exactly what i did. Now i did it again, im hard stuck in NEXBOX logo, even tho im holding the reset key. my last option is to buy a patch cable… maybe usb tool will do it.

Be aware Nexbox had 2 editions of the A95X which look exaclty alike, however, they have a different SoC.

Are you 100% sure you have the B7N and not the “standard” model?

image

Hey, yes im sure it’s the same picture on the back as you posted.

I got a patch cable and will try to fix that in 2 hours. Ill post updates :slight_smile: but im not sure which android was on emmc before i wiped it like 5 or more years ago. Maye that caused all that mistakes?

I dont really understand why this android version is relevant tho.

Because the bootloader from Android 7.1 or higher.is required to boot Matrix.

See: requirements

Ok next problems here

Newest version of Amlogic USB Burning Tool throws an error after importing the img from mega drive…
So i am using 2.2.0. I put the file in and it looks like this.

After i click start and put the usb cable into my pc nothing happens even. (Different usb ports, do i need the power supply? it isnt mentioned in the guide, but i tried everything.

What can i do now?

You could follow the guide to the letter. Also ensure you are using the correct Android firmware. In a previous post I linked to the Nexbox firmware archive.

Many thanks it only worked exactly like this for me:

  1. USB Port closest to DC Port
  2. Reset Button clicked in
  3. Version 2.2.4
  4. No DC Cable
  5. Cable after clicking Start

Do i have to startup the box or can i directly continue with matrix on sd/usb card?

Interesting. Maybe that’s because you have a different revision?

On my box:

  1. load the firmware into USB Burning Tool
  2. hit start
  3. connect the Nexbox via the patch cable to PC (USB port closest to the DC)

and the firmware starts flashing.

Follow install instructions as for a new device:

  1. boot to Android
  2. insert external media
  3. reboot from external

Thanks, it is working :wink: But the system is much slower then 9.2.8. Are there some tweaks which can help? The RC seems very slow.

Well right now im running from a class 10 sd card but 1 GB RAM version of neebox seems bad for matrix on internal memory right?

Edit: Yatse works good, but my remote control is not very rensponsive (lg cx tv)

Matrix consumes more resources than Leia, while the A95X-B7N is pretty much the lowest hardware configuration that can run Matrix. The results will be accordingly, as explained in our Wiki.

The class of the SD card doesn’t make that big of a difference from a speed/user experience perspective. You want a card with a high random r/w speed when an OS is on it. I suggest testing your cards with crystal disk mark, and use the one with the highest random speeds. It can make a huge difference depending on what speeds you are coming from/going to.
Here are a few card test results that were done on Raspberry PIs, but every batch of cards (even the same model) will have variance.
https://www.pidramble.com/wiki/benchmarks/microsd-cards

Oh well, i understand. So far so good. I’ll look forward to get a new box. Is there some thread for this topic, which decision to pick in the future (or now)?

Using a Class 10 SD Card is a minimum requirement.

To run CoreELEC on the A95X-B7N, I use a Sandisk Cruzer Fit USB 2.0 Flash Drive. While any USB Flash Drive will do, I prefer the Cruzer Fit because of it’s small physical size. I find the performance aduquate.

image

USB 2.0 Flash Drives offers transfer rates upto 480 Mbps whereas class 10 SD Cards max out at 10 Mbps, while the eMMC module of the device reaches about 50 Mbps (which is comparable to a V60 SD Card).

If you want to go for a new device, I’d suggest at minium SoC S905X3 or S922X.