Nightly builds (NEW)

Hi Portisch. To be clear, I have never copied COREELEC and STORAGE partions from one SD card to another. The new install I tried was burnt to the SD card using etcher from the CoreELEC .img.gz file. The most I’ve done is to subsequently copy SYSTEM, KERNEL and dtb.img files to the SD card in an attempt to get things working.

What I have done, and may have done before, is to restore an image of the entire SD card that was made using the Disks utility in Ubuntu. The restored SD card boots without problem and is of the 9.2.1 stable version. Could this be the reason for the mount flash UUID error? In my simpleton world, I wouldn’t think so but I’d welcome your thoughts on this.

Is there a way to force the GUI (and playback) resolution always to 2160p? The setting is sometimes lost after a reboot and it drops back to 1080p, which is annoying because the 720p stuff I play, is first upscaled to 1080p and then upscaled again by my TV to 2160p.

Anyway, you have something done that the UUID changed. When the message appear on screen there is a small console on screen. Type blkid and write down your UUID. Then move the media to pc and edit your boot.ini and change the UUID.

Thanks Portisch. I think you’ve pointed me in the right direction.

I have new KM9 with Voice control, but when i use Coreelec I must use my remote I have to keep it straight at the receiver but when I use stock Android i can use my remote at any direction with much more distance

Jump over to users of the KM9 thread

Can someone help me? I did:

Settings->System->Power saving->Shutdown function to “suspend”

However, I can’t turn on my N2 anymore with my infrared remote after that.

I changed back to “shutdown”, however, it seems still suspends because I can’t turn on the N2 anymore.

I just tried to reconfigure my remote but ir-keytable -u doesn’t show any code anymore. Is there something broken? I remember it worked when I set it up half a year ago.

Help is appreciated.

Applied sm1_s905x3_4g_1gbit_slowsdio.dtb works well.
adamg Thanks.

Settings->CE Settings->Hardware->Power

I tried this however when running inject_Bl301 I get the following error:

Device serial number: 290a4000010514020015308254524d51
Using CPU type G12B (29): S922X, A311D
System is not supported by BL301.bin injection: g12b_s922x_odroid_n2

Why is that?

Also I followed the guide but when entering

ir-keytable -u

It doesn’t find any code. Could someone confirm that this is still working. I did it like 1 year ago and it showed me my IR code.

You don’t need BL301 on an N2 because it’s already running our own uboot, which has all the issues that BL301 fixes in generic boxes implemented.

Thanks for clarifying. However, my remote doesn’t work anymore. Before I obtained these from it…


but it doesn’t work anymore.

Follow the link @Portisch posted above.
If it still doesn’t work, maybe he can help.

I did. This is what I wanted to tell you, suprisingly it doesn’t work anymore. I don’t see a remote code anymore.

This is what I get in dmesg after running echo 2 > /sys/module/rc_core/parameters/debug

[ 1149.769232@5] sample: (00000us space)
[ 1149.769255@0] delivering reset sync space to lirc_dev
[ 1149.769264@0] IRMP decode 0us (0us): space
[ 1149.771442@5] sample: (02213us pulse)
[ 1149.771463@0] delivering 2213us pulse to lirc_dev
[ 1149.771468@0] IRMP decode 2213us (2213us): pulse
[ 1149.832008@5] sample: (60573us space)
[ 1149.832033@0] delivering 60573us space to lirc_dev
[ 1149.832040@0] IRMP decode 0us (60573us): space
[ 1149.833868@5] sample: (01861us pulse)
[ 1149.833886@0] delivering 1861us pulse to lirc_dev
[ 1149.833890@0] IRMP decode 1861us (1861us): pulse
[ 1149.894441@5] sample: (60581us space)
[ 1149.894466@0] delivering 60581us space to lirc_dev
[ 1149.894472@0] IRMP decode 0us (60581us): space
[ 1149.896220@5] sample: (01780us pulse)
[ 1149.896241@0] delivering 1780us pulse to lirc_dev
[ 1149.896246@0] IRMP decode 1780us (1780us): pulse
[ 1150.022171@5] sample: (125000us space)
[ 1150.022434@0] IRMP decode 0us (125000us): space

What is the exact output of ir-keytable -u?
Did you stop Kodi and eventlirc before?

In my, case (S905X2, nightly, dual boot on eMMC), bl301 inject installed i use remote for TV using CEC (box has no built in IR).
Wake up only works using stock remote (Ugoos with external IR with jack plug) but this remote is not user friendly. Unfortunatelly wake up is not working using CEC.
Is it possible to use TV remote via CEC to have wake up working?

@rosenrot do you have a remote.conf on your system, either in /flash or /storage/.config?

I have updated to nightly! I did it by disconnecting my SSD before doing the update, as suggested by Sholander earlier. No idea why stable doesn’t complain but nightly does, but I don’t care. The SSD can be plugged in after the update and connects again on subsequent reboots.

Thanks again to all contributors.

Glad you finally solved your problem, and learned something useful on the way… :wink:

I followed the manual. The output is this:

CoreELEC:~ # ir-keytable -u
Protocols changed to irmp
Waiting for IRMP decode event. Please, press CTRL-C to abort.

Nothing more. It doesn’t show any keycode there.