Nightly builds (NEW)

I’m talking about who can tell in which file on github I can change this by default?

Are the nightlies on a bit of a break? Latest is working well, no issues, just an observation.

No break, just hasn’t been a lot of development recently. Between things being in a pretty good state, and remaining problem, possibly needing a lot more time to sort out then some of the developers have at the moment. I know for my self that I have had some major upheavals in my offline life, that have been keeping me away from doing as much as I would like.

Fair enough, I think most things have shut down, in my part of the World anyway, so no surprises there. Take care.

Hi, which nigthlies are for S905X2 (Ugoos X2 Cube)?

You are asking for the dtb.img ??

I ask which file from here is proper one:

Your Hardware has an S905X2 Chip which uses ng CE images.

New install CoreELEC-Amlogic-ng.arm-9.2-nightly_20201006-Generic.img.gz

If you already had previous CE installed you would manually update using

1 Like

Thank You!

Hi, how to set custom resolution properly?
tried to change paarameter config.ini 1680x1050p60hz and modeline= (copy from xrandr info), I’d activate vesa mode setting coreElec, but still no luck.

I installed to emmc the Generic version of the new NG build on my old S905X box and everything work fine except performing a hard or soft reset to clean the CE storage :slight_smile: When trying to reset, the box just reboot without removing anything from storage.

After digging a little bit I guess the issue is related to get_target() function from /usr/lib/coreelec/factory-reset file failing to find the target device parsing /proc/cmdline
The get_target() function expect disk= in command line to start with either LABEL=, UUID= or / but in the failing case it is starting with FOLDER= (full disk for failing case is disk=FOLDER=/dev/CE_STORAGE)

I tried both build as well as 20201011 nightly build and both show same failing result when trying to reset.

Full /proc/cmdline used for is here and for nightly build here

JakeTri, thanks for this complete analysis. You are right, the script doesn’t cover installation to eMMC. I have solution ready but first attempt failed with wiped Android :frowning: I have to recover it and test again to confirm that solution is correct.

Thank you for looking into this…
Sorry for being lazy and provide only the analysis but I not have time right now to work on a potential patch / solution as well…

1 Like


I am unable to replicate this on a NexBox A95X-B7N (S905X) 1/8 running CE-ng stable from eMMC

Betatester: Do you have dual boot with Android? I think the issue happens only in this case.
Can you check /proc/cmdline if you have disk=FOLDER=/dev/CE_STORAGE.


Yes, dual boot.

Created full system and Kodi backup to external USB with CE backup tool.

Performed soft reset. System restarted and went through its soft reset cycle. System restarted again and I was greeted with the red Welcome to CoreELEC screen. My media were untouched.

Restored from backup, rebooted and found my previous configuration restored.

Performed hard reset. System restarted and went through its hard reset cycle. System restarted again and I was greeted with the red Welcome to CoreELEC screen. My media were gone.

Restored from backup, rebooted and found my previous configuration and media restored.

System: NexBox A95X-B7N 1/8 running CoreELEC-ng stable in dual boot with Android 7.1 (Nougat) from eMMC.

Unable to replicate following error during 5 consecutive attempts:

Conclusion: CoreELEC-ng Stable works as intended on a NexBox A95X-B7N (S905X) 1/8 when performing a hard and/or soft reset via the CoreELEC configuration addon.


I’m using single boot configuration and installed CE-ng via ceemmc -x on top of Android 7.1 rom on A95X 2/16 box.
The /proc/cmdline generated for booting from eMMC used disk=FOLDER=/dev/CE_STORAGE vs the one for booting from USB / SD disk=LABEL=STORAGE ( there is special case in the cfgload script for this )
The script that perform soft/hard reset does not handle the FOLDER case so it is just restarting the box without performing the reset operation as it does not find the reset target.

Check with file explorer if you have CE_STORAGE mounted. If yes, unmount. See if that makes a difference.

Anyway, the fix is send:

Tested on Beelink GT King Pro.

1 Like

@vpeter, just tested a local build with your fix on my A95X box and confirm fixing the issue.

Thank you!

1 Like