Nightly builds (NEW)

As of tonight’s(20200716) nightly build owners of GXL(S905X/S905D/S905W) based devices will have the option of using either the amlogic build with the 3.14 kernel that they were already using, or they can now try using their device with an amlogic-ng install.

NOTE: there was a change that was made after the GXL stuff was merged that didn’t take into account the LePotato. It’s recommended that with the 20200716 nightly build that you don’t set your gui resolution to 4k, and that you also change your gui resolution to 1080p before updating to this build. This will be fixed in the 20200717 nightly build.

After months of doing seperate funhouse(experimental) builds and working on support for these devices to the amlogic-ng builds, we now feel like we are at the point that this is working well enoug that we can move this work into the main builds for more people to try.

While many people have helped test on different devices so far, there may still be some unkown issues and bugs. So try at own risk. One area that has not been tested is the random assortment of unsupported install to internal setups some people may be using.

To get started using an amlogic-ng build on a GXL(S905X/S905D/S905W) based device. The device tree names are the same as they were on the old amlogic builds. So if you used the gxl_p212_2g.dtb before it’s will be the gxl_p212_2g.dtb for these builds as well. Do make sure that you use dtb from the device_trees directory on the amlogic-ng install image, since if you use the dtb from another source it will not work!

New installs, if your device required you to hold the reset button on your first boot of CoreELEC before you will need to do so again on first boot of an amlogic-ng install. There are some differences between the boot scripts.

Upgrading from an amlogic to an amlogic-ng install. While moving between the amlogic and amlogic-ng has been done succesfully by a few people testing with gxl based devices, I would suggest doing a backup before doing this. Switching between amlogic and amlogic-ng needs to be done by a manual update.

Step #1 place the amlogic-ng update tar file into the .update folder.
Step #2 create an empty .nocompat file in the .update folder.
(you can not switch to a amlogic-ng build without this step)
Step #3 reboot your device. it should proced the same as a normal update at this point.

This is only for GXL(S905X/S905D/S905W) devices. If your device is a GXBB(S905) or GXM(S912) based device or you don’t know what soc is in your device then do not try to update to an amlogic-ng install. Your device is not supported by amlogic-ng! and will stop booting if you try!

10 Likes

I started a list of GXL(S905X/S905D/S905W) devices that people who have tested with the amlogic-ng images have found to work well.

https://discourse.coreelec.org/t/do-amlogic-ng-builds-work-well-on-gxl-s905x-s905d-s905w-devices/12179/2

3 Likes

I’ve been getting quite a lot of crashes when resuming playback, i.e. the screen just dims as if the playback would resume but then Kodi returns to the main menu after some time. In the crash log, there are a lot of items like this prior to the crash, basically the whole file list of the folder in question is there. I have not tried to playback those files, maybe it’s Kodi just scanning for thumbnails to display or something like that? It seems to try opening also non video files like Avisynth scripts.

2020-07-16 01:18:43.862 T:3206992768 ERROR: Open - Unhandled exception
2020-07-16 01:18:43.862 T:3206992768 ERROR: Open - Error opening nfs://192.168.0.50/c/Share/x264/The Walking Dead - S03E02.mkv
2020-07-16 01:18:43.862 T:3206992768 ERROR: InputStream: Error opening, nfs://192.168.0.50/c/Share/x264/The Walking Dead - S03E02.mkv

Does this point to a problem in my NFS server on the PC or something else? The libraries in Kodi get their files using SMB shares. I never got SMB shares working properly on the PC so NFS was an easy way out.

And another question regarding the info in the crash log… why does Kodi set the refresh rate to 59.94 fps and not 50 fps (or 25)? Disp_cap has those available.

2020-07-16 01:42:38.636 T:4064632256 NOTICE: Whitelist search for: width: 640, height: 480, fps: 25.000, 3D: false
2020-07-16 01:42:38.637 T:4064632256 NOTICE: Display resolution ADJUST : 3840x2160 @ 59.94 - Full Screen (16) (weight: 0.000)

Which build do you use on which box?

Any plans for GXBB(S905) or GXM(S912) funhouse builds?

1 Like

The latest nightly on Odroid N2. That crash log is from July 14th nightly build.

Gxbb is EOL by Amlogic. GXM is problematic because there is no mali driver and the hack added by Kszaq is no longer working. Gxbb would take a lot of work but compared to gxm it looks more probable. Help for both is wanted.

On the Odroid N2 the 07-16 nightly was real issue. It was extremely laggy on 3 different skins (amber. Aeon Silvio, Estuary) to the point of being unusable, and it did not address the 4k GUI issues. Will try it on my VIM3L and see if it fairs differently.

Will ceemmc work? And bl301 injection?
Does not load, hangs on the Corelec logo. x96 s905x 100mb p212_1g.dtb.
I wanted to restore Android from a backup made in TWRP doesn’t load, and the stock recovery doesn’t load either.

Note: This thread is meant as an informative list of what users feel currently works well. This is not a support thread. If you need help with or want to report a specific issue please either start a new thread in the appropriate location or post in the nightly thread if the issue is with a nightly build.

The whitelist options seem to be missing from the latest nightly. Did I miss something or is this on purpose?

Can you elaborate. N2 here with native 4K GUI. All good.

I have a CEC problem with the nightly image. The system gets very heavy when the CEC is active.The system works well when CEC is turned off.My TV Unit Full HD, Box Beelink GT Pro and USB Tuner TBS 5520.

1 Like

HDMI CEC OF

HDMI CEC ON

I cannot use the new image with the HDMI CEC error.The device crashes.

1 Like

I wanted to restore Android from a backup made in TWRP, doesn’t load TWRP, and the stock recovery doesn’t load either.???
P.S. Amlogic Burncardmaker doesn’t work, doesn’t load.

What about the USB burning tool?

I don’t have access to WIN OS.

Before I begin I should mention that I have not actually tried to do the following. but it should work in theory.

You can try to update to the older amlogic build https://github.com/CoreELEC/CoreELEC/releases/download/9.2.3/CoreELEC-Amlogic.arm-9.2.3.tar which will replace the boot script with the older one, which I would assume doesn’t present the same issue. Just place the tar in the .update folder and create an empty .nocompat file in the same folder.

Thank you, I know I wanted to try the new version.