Nightly builds (NEW)

I observe the same behavior. Hoping Nexus wasn’t affected, I switched to Nexus alpha. I got rid of the quarter-size viewport issue by deleting all resolution-related entries in guisettings.xml.

But if I remember correctly, the fuzzy font was already visible in the last few versonss of 19.4 during the update process (text information when updating the kernel on the left side of the screen), thus before Kodi started and only linux was running in the background. I’ll wait until the next Nexus update and try to take a picture of it when the update is in progress

Unfortunately, I can only describe it as well as google translate makes possible

To correct the 1/4 screen problem please delete all resolution related entries in guisettings.xml located at /storage/.kodi/userdata/.

Thanks! I deleted the whole < resolutions >…< /resolutions > section and rebooted, but I’m afraid it doesn’t make a difference for me. The section reappears with the default entries and apparently wrong(?) values for < subtitles > and < overscan > sub-tags for all resolutions above 1080p.
Will leave things as-is for now and wait for a fix for the original fuzziness problem.

Do you use the default estuary skin?

Overscan should be disabled on TV and not configured on box.
You could set it to original in HDMI port settings on TV.
It could have different names or places on your TV.
But below are some samples:

Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
Sharp TV - hit View Mode button, select "Dot by Dot" or "Full screen"

The fuzzy font during the update process. 4K GUI and scaling on.


You have to stop Kodi before making changes to guisetting.xml otherwise they’ll reappear.

from ssh

systemctl stop kodi

then make changes to guisetting.xml and either reboot or restart kodi using:-

systemctl start kodi

1 Like

Yes, I jumped that part…

OK, after stopping kodi I could modify guisettings.xml easily. The fuzziness is fixed/worked around for the moment and I have a much crisper UI now, too. Thanks! :slight_smile:

Overscan is of course disabled on my TV. The <overscan> sections had seemingly bogus values, however, like {0, 0, 1920, 1080} for 4K resolution entries. That may have caused the quarter-size display(?).

Audio still out of sync after leaving movie paused for few minutes. Video shutters as well. All from external 2.5" HDD, CE from EMMC.
X96 Max Plus 4/64 latest nightly, dtb updated from previous mega link . Failed to paste log file to ix.io from menu.
Box connected directly to Panasonic TV. Only skin changed to Confluence.

I removed the dtbs, use nightly build only.

And include debug logs next time.

Will do next time. I see it is shift+control+D - that’s the log you are looking for?
Will flash it again using latest build.

@licentia, @kmhofmann
4k GUI scaling fixed in current nightly.

Many thanks

2 posts were merged into an existing topic: CoreELEC 20.0-Nexus_alpha1 (pre-release)

http://ix.io/3ONN - audio out of sync from very beginning of the movie file. File on USB HDD.
Only thing to add is that box was on all the time since last nighlty build no reboot/restart etc.

I hope this file is ok now and will help.

Also check same thing after reboot. To compare the result.

No, after reboot it is ok but it occurs even then at some stages but hard to log that and reproduce straight away.

Netflix woes are back!

Haven’t used my MINIMXIII s905X in a week or so, when I got back to it, the 19.4 Nightly 20220205 was waiting for reboot. Then I tried watching Netflix, there was a Widevine CDM update available (2007.something) so installed that as well, and now anything I play in Netflix slightly stutters and audio gets out of sync. When I press pause, video continues to run for some time before it stops…usually playing a video from the beginning starts OK but audio sync progressively drifts away. If resume, audio is already de-+synced and picture stutters…

Anyone experiencing the same thing, any ideas? Did the latest Widevine break something?

Have you tried to replicate the issue with a clean install (CE and Netflix only) from sdcard or usb flash drive?