Nightly builds

Thanks. Now i successful upgrade to 0912:)

This worked!

If you are having issues updating from the 20190911 nightly build see this post Nightly builds

<<<<-UPDATE ERROR ->>>>>>>>> I have installed the VIM3 CoreElec Nigthly _ 20190911 Amlogic-ng.arm and in the last update it crashes when starting on the red home page that COREELEC says, I had to reset 3 times so that it ended up starting.
Has it happened to someone else? I have disabled the updates but the “pending updates” message still appears.

There was a problem with the 20190911 nightly image that makes the update system fail.

If you can ssh into the device the following will update you to the 20190912 nightly image that doesn’t have this problem.

wget -O /storage/
sh /storage/

then reboot

Same 2 me. how to solve the boot problem issue? (Emmc)

I have the 09/11 update instaled to emmc on vim3 and it seems to be running ok. Will the problem occur when I try to update? If so what steps do I need to take to update to the “fixed” build?

Yes, follow this post.

1 Like

Thankyou, worked perfectly. Will auto update take care of the next nightly updates again from now on still?

Yes, 20190911 build had a missing configuration that made it break during an update. All builds prior or after this one shouldn’t have any issues.
We removed this build from the archive to make sure it’s not used anymore by anyone.


ok. my VIM3 is update 0912.


Updating from 20190912 to 20190913 on my S912 produced the same issue as going from 20190911 to 20190912.

As was still present in /storage I modified it to replace all references to 20190912 to 20190913, ran chmod +x /storage/ and then /storage/, rebooted and I now have 20190913.

I will check that and if I have same problem, i will change it to update to the nightly from the 13th as well.

So I just checked. On the device that I used to test my script to update from the broken 20190911, I can run my script to update to 20190912, then shortly after rebooting into 20190912, I get an update notification for 20190913. I reboot to allow the new update to take place and it has no issue updating to 20190913.

edit: one thing to note about my script, is that it was only meant to update from the 20190911 build, so it leaves out several parts of the update process that just where just not needed between those two releases. If you modify it to update to other builds that may require these extra parts of the update process you may cause yourself problems.

when auto or putting file in .update folder wont update just sits on coreelec splash screen with no words in top left corner just sits and does nothing

See my post above regarding updates from 20190911 nightly build Post #1362

OK, thanks for the info.

What I will try now then is to copy the latest .tar file to the box and see if it fully updates when booted.

Update: No that didn’t work.

Looking at your script though, it seems to replicate the original advice, which was to replace system and kernel.

I’m struggling to know what will be the way forward to enable automatic updating to work, short of starting from scratch.

The only thing that does sit in my mind is that the original advice talked of going back to a build earlier than 11, so maybe that is the change required.

Can’t hurt to try.


I thought that I would try to be clever (but failed).

I modified the script to pull down the normal nightly tar, starting with 10, rebooting and then with 12.

After 12 had been applied and the reboot complete I went through the process to do the automatic update to 13 via the prompt but things stuck again at the splash screen,

Modifying the script to point at 13 worked and it says I have 13, so for the time being I’ll pull updates down this way. It seems to do what a normal update does and can easily live with it.

How do u ssh

After last update, on 905x before show boot splash i see /init: line 986 tee not found and stack on splash

UPD: use resolve this trouble.