Nightly builds

The 0911 is the one broken so it’s best to follow the instructions and move on. There’s nothing wrong with 0912 nightly.

If you’re still in 0910 you can safely upgrade to 0912.

Restored a backup successfully and now downloading 0912.


If you are having problems updating from the 20190911 nightly build.

ssh into the device and enter the following two commands for quick and dirty upgrade to 20190912.

wget -O /storage/
sh /storage/

and then reboot.



I do get this error though.

Clipboard01 is copied to /storage succsessfully but after a reboot, 0911 still remains.

You missed command

I ran chmod +x /storage/ and then /storage/ and it ran successfully.

Thanks to all.


Thanks. Now i successful upgrade to 0912:)

This worked!

If you are having issues updating from the 20190911 nightly build see this post Nightly builds

<<<<-UPDATE ERROR ->>>>>>>>> I have installed the VIM3 CoreElec Nigthly _ 20190911 Amlogic-ng.arm and in the last update it crashes when starting on the red home page that COREELEC says, I had to reset 3 times so that it ended up starting.
Has it happened to someone else? I have disabled the updates but the “pending updates” message still appears.

There was a problem with the 20190911 nightly image that makes the update system fail.

If you can ssh into the device the following will update you to the 20190912 nightly image that doesn’t have this problem.

wget -O /storage/
sh /storage/

then reboot

Same 2 me. how to solve the boot problem issue? (Emmc)

I have the 09/11 update instaled to emmc on vim3 and it seems to be running ok. Will the problem occur when I try to update? If so what steps do I need to take to update to the “fixed” build?

Yes, follow this post.

1 Like

Thankyou, worked perfectly. Will auto update take care of the next nightly updates again from now on still?

Yes, 20190911 build had a missing configuration that made it break during an update. All builds prior or after this one shouldn’t have any issues.
We removed this build from the archive to make sure it’s not used anymore by anyone.


ok. my VIM3 is update 0912.


Updating from 20190912 to 20190913 on my S912 produced the same issue as going from 20190911 to 20190912.

As was still present in /storage I modified it to replace all references to 20190912 to 20190913, ran chmod +x /storage/ and then /storage/, rebooted and I now have 20190913.