Nightly builds

hope you can figure something out!
i just cant believe everything ran smooth and that an update would brick the board

When you power on N2 does the red led go on first, and then the blue led blinks?
I read on N2 Android forum that a developer had an N2 with power fault, his red led does not light up any more, only blue blinks. He tried it with a different power adapter but same result…

The right led doesn’t go on at all, starts from both blank to the blue one solid for a second or 2 and then just starts blinking, I never have a red one.
Will look in to that topic!
edit: might be the same thing then… will do the power test and see if the distributor is willing to fix/replace it.

Red led is for power. So either your psu or some hw failure. @tobetter got an idea/tip?

If anyone has an issue that the red LED does not lit at all on power cycle, please check the voltage at the pin #2 of GPIO pin header…and if it does not measuered around DC 5V. If this is not work because you do not have a DMM then attching an USB keyboard or mouse to see if they work with ODROID-N2.

In order to sort out the issue and to proceed RMA in case, please post your issue to the ODROID forum then I or someone else will help you out.

EDIT: Since DC 5V is controlles by a GPIO, I will check if the pin is not being controllable somehow and will try to prepare a patch if it works or not.

Can you do me a favor?
If you can access a shell command, please do these commands and let me know the output whether it’s in or out.

Thank you.

I’ve just tried the 2017.07.03 and mce usb works but only with crazycat drivers (so same as before). When I disabled crazycat drivers and rebooted I had no response… re-enabled, rebooted and it’s working again. Is that the expected behaviour? If it is that’s fine and I’ve misunderstood what adding support to kernel means.

What do you means with disabled crayzcat? You can only switch dvb drivers addons to default kernel drivers. Don’t use disable in addons settings. Anyway, I need kernel logs. Without logs I can’t fix anything.

I think what threw me originally (months ago) with the mce usb is that it was in a package called dvb drivers. Not having a box with satellite / aerial inputs running CE that just looked like something for other people. And this time around (‘mce usb has been added to kernel’ or wtte) I thought the same. So not finding the setting for dvb drivers (looked in settings and coreelec settings but not program addons) I imagined that the mce usb should now work without a dvb addon.
Having now found the place to select driver modules, the mce usb still works with ‘DVB drivers for TBS’ (crazycat). It also works with ‘DVB drivers from the latest kernel’(media build). It doesn’t work with ‘CoreELEC default drivers’.
If that’s how it’s supposed to be then great - although it’s still confusing the hell out of me (as to why I need dvb drivers).
If it isn’t then if you tell me what you want in terms of logs I’ll have a go at posting them.

The DVB drivers addons are based on linuxTV media_tree. There are the latest media drivers for linux. Addons uses only subset of drivers focused on dvb and also rc as a lot of usb adapters contain IR RC. Most likely in 3.14 kernel is missing USB device detection support for your device version.

Sorry, this is as clear as mud.
Should the mce usb be showing up with ‘CoreELEC default drivers’ on nightlies?
At the moment it’s working with the other 2 options (crazycat and media build) but not that one.
I can try on a couple of different boxes but at the moment I have no idea what the expected outcome is.

Possibly, but it seems odd that the mce receiver worked in LE on my S905’s (and everything else for that matter) without issues.

Hi! Autoupdate it’s working? Because I have installed manually the latest nightlies, I don’t have updates notifications and if I go to update manually from the menu, it doesn’t find anything.

Auto updates are currently disabled.
Just copy the newest tar file to your /storage/.update/ folder and reboot to manually update.


Ok, just like I am doing till now.

Sorry, I haven’t seen that autoupdate was disabled.


The 20190710 nightly files are only in the archive subdir present {but no older files). In is only the changelog visible.

All old nightlys including 20190710 can be found here

Updated from nightly 20190706 to 20190710 and had a safe mode reboot crash.
Logs linked below. Using NexboxA1 S912 without too many fancy changes other than some skins and a few addons for weather and Kayo/InputstreamAdaptive.

EDIT: Rebooting (using reboot option) did not take me back to the old install. Neither did poweroff. I can see the .kodi.FAILED in storage though. Aside from just deleting .kodi contents and moving data from .kodi.FAILED back to .kodi, any suggestions which may help you guys?

Updated from nightly 20190706 to 20190710 and noticed that there was no Bluetooth option available in Kodi audio settings.

Bluetooth is present in CE and I am able to connect there.



I took a look at the logs and the only diffrence at boot time is the presence of this section in 20190706 that is missing in 20190710

2019-07-11 01:12:05.319 T:4065325872 NOTICE: Enumerated PULSE devices:
2019-07-11 01:12:05.319 T:4065325872 NOTICE: Device 1
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_deviceName : Default
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_displayName : Default
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_displayNameExtra: Bluetooth Audio (PULSEAUDIO)
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_deviceType : AE_DEVTYPE_PCM
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_channels : FL, FR
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_sampleRates : 5512,8000,11025,16000,22050,32000,44100,48000,64000,88200,96000,176400,192000,384000
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_dataFormats : AE_FMT_U8,AE_FMT_S16NE,AE_FMT_S24NE3,AE_FMT_S24NE4,AE_FMT_S32NE,AE_FMT_FLOAT
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_streamTypes : No passthrough capabilities

Box is an S912 R-TV Box S10

The WiFi/BT module is an FN-Link 8223A-SR

1 Like


10-07-19 build with TVHeadend 4.3 has stopped working, so i went back to build 06-07-19.

How can I solve this?

Because I can’t go back to TVH 4.2, the channel list doesn’t match.

Best regards…

1 Like

I had an issue with my PVR guide after this update. Re-building the guide fixed it.

[in Kodi] Settings->TV->Guide->Clear Data

Nightlies have changed to a new branch so I will look into this, thanks.

1 Like