Nightly builds

I’m a nerd, I read changelogs of patches in my free time :slight_smile:
However, the last nightly has me somewhat confused as to the host of old patches that appear. What’s up with that?

1 Like

Might be because of a source code rebase.

The nightlies were switched to another branch, and therefore all included patches are listed as new ones.
The good thing is, that you have a lot to read, now. :wink:


Well I used the same SD Card to restore it for my RPI3B+ (cause my N2 won’t do much) and there it works fine.
The switch is set to MMC (not SPI) so should also be fine.

When I plug in the card the blue led just blinks and thats about it…

I wonder whether a power cut during an update could damage the hardware? seems a bit illogical no?

Don’t see where power loss at any time could brick the board. File corruption can happen from that, but you can always restore. Sounds like a hardware problem with the board.

If you just bought it maybe you can contact the vendor for exchange. I would rule out the media though, try another SD card. Try burning the image to eMMC with a PC USB writer.

Writing to the eMMC with a usb writer was actually my first try.
But the eMMC isn’t even properly recognized by my lapto anymore. (microsd adapter -> emmc adapter) which worked fine on the initial install.
I agree I can’t see how this could damage the card/board in any way… it worked perfectly just untill i did the auto update.

I’ll give it a try with another SD card but I’m not holding much hope.

Well best of luck, I’d probably seek a replacement at that point.

i’m leaning towards it too but it’s sad cause I just got this one just over 2 weeks ago …sigh…
i’ve tried it on a different pc now and I can read the eMMC module!
was able to reflash it but same behavior from the N2…

When you power on N2 does the red led go on first, and then the blue led blinks?
I read on N2 Android forum that a developer had an N2 with power fault, his red led does not light up any more, only blue blinks. He tried it with a different power adapter but same result…

Hi. It happened the same with my lepotato with 20190627 nightly. I force the update after the prompt and it didn’t boot up anymore. Red led on and green led blinking. Tried to flash the stable with emmc timeout option. No luck. The same green led blinking. I will try soon with usb burning tool some android image to see if emmc is ok

1 Like

hope you can figure something out!
i just cant believe everything ran smooth and that an update would brick the board

When you power on N2 does the red led go on first, and then the blue led blinks?
I read on N2 Android forum that a developer had an N2 with power fault, his red led does not light up any more, only blue blinks. He tried it with a different power adapter but same result…

The right led doesn’t go on at all, starts from both blank to the blue one solid for a second or 2 and then just starts blinking, I never have a red one.
Will look in to that topic!
edit: might be the same thing then… will do the power test and see if the distributor is willing to fix/replace it.

Red led is for power. So either your psu or some hw failure. @tobetter got an idea/tip?

If anyone has an issue that the red LED does not lit at all on power cycle, please check the voltage at the pin #2 of GPIO pin header…and if it does not measuered around DC 5V. If this is not work because you do not have a DMM then attching an USB keyboard or mouse to see if they work with ODROID-N2.

In order to sort out the issue and to proceed RMA in case, please post your issue to the ODROID forum then I or someone else will help you out.

EDIT: Since DC 5V is controlles by a GPIO, I will check if the pin is not being controllable somehow and will try to prepare a patch if it works or not.

Can you do me a favor?
If you can access a shell command, please do these commands and let me know the output whether it’s in or out.

Thank you.

I’ve just tried the 2017.07.03 and mce usb works but only with crazycat drivers (so same as before). When I disabled crazycat drivers and rebooted I had no response… re-enabled, rebooted and it’s working again. Is that the expected behaviour? If it is that’s fine and I’ve misunderstood what adding support to kernel means.

What do you means with disabled crayzcat? You can only switch dvb drivers addons to default kernel drivers. Don’t use disable in addons settings. Anyway, I need kernel logs. Without logs I can’t fix anything.

I think what threw me originally (months ago) with the mce usb is that it was in a package called dvb drivers. Not having a box with satellite / aerial inputs running CE that just looked like something for other people. And this time around (‘mce usb has been added to kernel’ or wtte) I thought the same. So not finding the setting for dvb drivers (looked in settings and coreelec settings but not program addons) I imagined that the mce usb should now work without a dvb addon.
Having now found the place to select driver modules, the mce usb still works with ‘DVB drivers for TBS’ (crazycat). It also works with ‘DVB drivers from the latest kernel’(media build). It doesn’t work with ‘CoreELEC default drivers’.
If that’s how it’s supposed to be then great - although it’s still confusing the hell out of me (as to why I need dvb drivers).
If it isn’t then if you tell me what you want in terms of logs I’ll have a go at posting them.

The DVB drivers addons are based on linuxTV media_tree. There are the latest media drivers for linux. Addons uses only subset of drivers focused on dvb and also rc as a lot of usb adapters contain IR RC. Most likely in 3.14 kernel is missing USB device detection support for your device version.

Sorry, this is as clear as mud.
Should the mce usb be showing up with ‘CoreELEC default drivers’ on nightlies?
At the moment it’s working with the other 2 options (crazycat and media build) but not that one.
I can try on a couple of different boxes but at the moment I have no idea what the expected outcome is.

Possibly, but it seems odd that the mce receiver worked in LE on my S905’s (and everything else for that matter) without issues.