Nightly builds


#201

I gave yours a try. It does boot, but I am getting an error when I try to install the confluence skin. ‘The dependency on xbmc.gui version 5.14.0 could not be satisfied.’ I don’t suppose there are any workarounds for that?


#202

I did try your inkernel, on a Mecool K1 Pro. Immediately noticed pressing on Enter on the remote activates arrow right. Inconvenient… Unless solved this problem is a showstopper I’m afraid. Any ideas?


#203

Maybe this is something related to the other patch related to IR-Keys unify on latest commit … did had a chance to try on K2 this weekend. But i noticed mecool, a95x tanix minix_neo are missing from OOTB support on Remote_KeyMaps …

This is How it used to be

IR_REMOTE_KEYMAPS="$IR_REMOTE_KEYMAPS odroid wetek_hub wetek_play_2 tanix kvim kvim2 minix_neo tanix mecool a95x"

This is how its now

IR_REMOTE_KEYMAPS="$IR_REMOTE_KEYMAPS odroid wetek_hub wetek_play_2 tanix kvim kvim2"

#204

That’s because the skin version was bumped, but the kodi in our nightly wasn’t yet.


#205

Your device vendor is using a cheap remote which ir-kecodes are clashing with another vendors cheap remote. Long story short yours was removed from the out of the box support.
You have to manually activate yours through ssh:
https://wiki.libreelec.tv/infrared_remotes#ir_remote_configuration

Create:
/storage/.config/rc_maps.cfg

With:
* * mecool


#206

Ah OK. Will do that when I have some time today. Thx for looking into it. Much appreciated. Cheers.


#207

Good friend will get tell how! @Nanouk
Because I’m days trying to make control of my KI Pro work
Unsuccessfully!
If you can make data available thank you
Thank you
:santa:


#208

@Ray please apologize the delay

Tested, it uncompress, install, update dtb… And get past boot logo. Sorry I wasn’t fast enought to make a capture. Thanks!

I’ve seen the commit too :slight_smile:

For IR maps would be nice to have some mechanism to detect which box model we are running and create rc_maps acordingly. Kinda of “dynamic keymaps”. Meanwhile creating an rc_map file manually works.

CEC is acting weird for a while (duplicated keypresses, intermitent non-working). I thought it was related to a dirty install, but I believe is a subject being discussed in another thread.

Now waiting for the repo to test lastest version on top of this.

Quick question, is there any script to generate a “release.json” archive like Relkai’s repo, or the repo itself with the artifacts of the build? I have a local Jenkins to compile coreelec from master and would be great to have a local coreelec repo to quickly build, update the box and test commits like this one (git patch, or branch), related to a particular device (also would mean less work for our beloved developers!)


#209

This is just not possible because of the myriad of devices that exist, there is no routine we can execute to identify boxes to implement a feature like this, we are always looking for ways to try and make things easier for users but the only devices that we can give full out-of-the-box support for are developer boards ie Odroid C2/LePotato/Khadas VIM 1/2.

Some manual configuration will always be required if you decide to save a few $$ and buy a cheaper device.


#210

Only option would be to detect the dtb but there is no specific mecool dtb or is there?
If you find a way to read the vendor and device id from inside linux let me know and I happily implement such a feature.

About CEC. I’ve noticed that recent KODI is kinda lacky sometimes. I don’t think it is a CEC issue. The changes made were purely to disable CEC kernel input mode you can enable it back with:

fw_setenv cecconfig cec3f

As for release.json. There is a python script from libreelec I edited a little bit to work for relkai’s releasesreleases.py (8.7 KB)

You have to edit the url and the path at the bottom of the script.


#211

@adamg understood, I was thinking on dmidecode and then realized this devices does not have any bios to get data from :man_facepalming: But I think this one it’s one of the well-known boxes, For generic boxes I totally agree with you, but as Ray suggested, we could read dtb info, this box it’s own dtb. However, I understand that maybe it does not worth the effort just for a few boxes.

@Ray indeed it has, gxbb_p200_k2_pro.dtb. I’ll keep looking around /proc and /sys looking for some identifier. Thanks for the script! This is super-helpful, I’ll put it on the pipeline tonight.

The only reason to run this box is that it’s one of the few that comes with a DVB S2/T2 tuner (I can also help testing TVheadend plugin, BTW). I got tired of USB dongles for TV and tons of cables, but I’ll be more than happy to run from this cheap box (cannot get hyperion v4l grabber working here too…) as soon as I find a good one with TV tuner.

Thanks again for the hard work guys.


#212

Tried that, but no luck. It’s weird because the remote works for a few seconds between Kodi loads and the CEC plugin shows the initial notification. Frron there, most of the keys work, but Arrow keys are always detected as two presses. I’ll collect some logs later.


#213

Looks to me like your TV remotes IR is picked up by the IR receiver.

If all mecool boxes are using gxbb_p200_k2_pro.dtb then I can make them load the mecool IR config with systemd reading le-dt-id:


#214

@relkai:
the file https://relkai.coreelec.org/releases.json
is stuck with build 20181123:

{“CoreELEC-9.0”: {“url”: “https://relkai.coreelec.org/”, “prettyname_regex”: “^CoreELEC-.*-[0-9]+\.0-nightly_([0-9]{8})”, “project”: {“S905.arm”: {“displayName”: “Amlogic S905”, “releases”: {“0”: {“image”: {“sha256”: “daaf1a1691de271448430789e3ffaa7ba4363c5b83a009b24a40542de44ea924”, “name”: “CoreELEC-S905.arm-9.0-nightly_20181123-KVIM.img.gz”, “size”: “148076398”}, “file”: {“sha256”: “6c75faba61303260ed90e294f6b669c663252f9319f215d2c66169ba7ca579f5”, “name”: “CoreELEC-S905.arm-9.0-nightly_20181123-KVIM.tar”, “size”: “167649280”}}, “1”: {“image”: {“sha256”: “892401a47549ce37d8d722ca16c431ff94a0ee3fe9f72707dec08f58ffb848c4”, “name”: “CoreELEC-S905.arm-9.0-nightly_20181123-LePotato.img.gz”, “size”: “148168303”}, “file”: {“sha256”: “6c75faba61303260ed90e294f6b669c663252f9319f215d2c66169ba7ca579f5”, “name”: “CoreELEC-S905.arm-9.0-nightly_20181123-LePotato.tar”, “size”: “167649280”}}, “2”: {“image”: {“sha256”: “cf60aeaf3add8abd706cc565de9e96878ae824ecb77bedc3366761e3a9d92068”, “name”: “CoreELEC-S905.arm-9.0-nightly_20181123-Odroid_C2.img.gz”, “size”: “147821349”}, “file”: {“sha256”: “6c75faba61303260ed90e294f6b669c663252f9319f215d2c66169ba7ca579f5”, “name”: “CoreELEC-S905.arm-9.0-nightly_20181123-Odroid_C2.tar”, “size”: “167649280”}}, “3”: {“image”: {“sha256”: “”, “name”: “”, “size”: “”}, “file”: {“sha256”: “6c75faba61303260ed90e294f6b669c663252f9319f215d2c66169ba7ca579f5”, “name”: “CoreELEC-S905.arm-9.0-nightly_20181123.tar”, “size”: “167649280”}}}}, “S912.arm”: {“displayName”: “Amlogic S912”, “releases”: {“0”: {“image”: {“sha256”: “6d729d367996c53515fe6c8720032826b15e353edb8c9aec45d2df6a4f32fbb6”, “name”: “CoreELEC-S912.arm-9.0-nightly_20181123-KVIM2.img.gz”, “size”: “150185804”}, “file”: {“sha256”: “0fb2b423997d04c5f828a658c51ef784dd1e81d4e8e6f132185215eb056efb3b”, “name”: “CoreELEC-S912.arm-9.0-nightly_20181123-KVIM2.tar”, “size”: “167874560”}}, “1”: {“image”: {“sha256”: “”, “name”: “”, “size”: “”}, “file”: {“sha256”: “0fb2b423997d04c5f828a658c51ef784dd1e81d4e8e6f132185215eb056efb3b”, “name”: “CoreELEC-S912.arm-9.0-nightly_20181123.tar”, “size”: “167874560”}}}}}}}


#215

Edited, you nailed it. Stopped kodi and lircd and I can see it’s receiving input from the TV remote

CoreELEC:~/.config # ir-keytable -t
487.280080: event type EV_MSC(0x04): scancode = 0x70762
487.280080: event type EV_SYN(0x00).
487.390034: lirc protocol(necx): scancode = 0x70762
487.390065: event type EV_MSC(0x04): scancode = 0x70762
487.390065: event type EV_SYN(0x00).
487.500034: lirc protocol(necx): scancode = 0x70762
487.500062: event type EV_MSC(0x04): scancode = 0x70762
487.500062: event type EV_SYN(0x00).
488.010095: lirc protocol(necx): scancode = 0x70761
488.010141: event type EV_MSC(0x04): scancode = 0x70761
488.010141: event type EV_SYN(0x00).
488.120031: lirc protocol(necx): scancode = 0x70761
488.120060: event type EV_MSC(0x04): scancode = 0x70761
488.120060: event type EV_SYN(0x00).
488.230041: lirc protocol(necx): scancode = 0x70761
488.230073: event type EV_MSC(0x04): scancode = 0x70761
488.230073: event type EV_SYN(0x00).

Thing is, this was working before. Any way to get the IR receiver ignore CEC input or map to a correct keycode?.

Disabling eventlircd disables completely both remotes, native and CEC from TV, this means CEC is not working at all? Double checked CEC config and restored to defaults. CEC works correctly on Android.


#216

Yes, you are right.
Since moving to the new server, python2.7 isn’t installed, which is needed for the releases.py script to create the json file.
It will be fixed after the next nightly.


#217

Try M8SPro+ from here: https://www.dropbox.com/sh/w60gx2c66rpmb4e/AAAVeDersy7MJFCESRCAEGcVa?dl=0
Maybe that is good for all Mecool devices with IR.
General dtb is good for Meccol unless there is a separate dtb. I had 3 mecool devices and I used general dtb for each of them and everything was fine.


#218

We added more keymaps in the general supported config.
You should really just setup a remote.cfg with your mecool config.

You can also disable IR completely, try to blacklist meson_ir.


#219

I’m guessing you are using Odroid C2?

We changed to a unified S905 build. Just manually update, then the next update using release.json will work.
Remember to use the tar not the img.gz to update!!!


#220

Hello,
I have Odroid C2 and CE nightly_20181127 and I can´t acces to Coreelec nightly Add-ons repository… failed to connect to the repository