Nightly builds

Hi! Autoupdate it’s working? Because I have installed manually the latest nightlies, I don’t have updates notifications and if I go to update manually from the menu, it doesn’t find anything.

Auto updates are currently disabled.
Just copy the newest tar file to your /storage/.update/ folder and reboot to manually update.


Ok, just like I am doing till now.

Sorry, I haven’t seen that autoupdate was disabled.


The 20190710 nightly files are only in the archive subdir present {but no older files). In is only the changelog visible.

All old nightlys including 20190710 can be found here

Updated from nightly 20190706 to 20190710 and had a safe mode reboot crash.
Logs linked below. Using NexboxA1 S912 without too many fancy changes other than some skins and a few addons for weather and Kayo/InputstreamAdaptive.

EDIT: Rebooting (using reboot option) did not take me back to the old install. Neither did poweroff. I can see the .kodi.FAILED in storage though. Aside from just deleting .kodi contents and moving data from .kodi.FAILED back to .kodi, any suggestions which may help you guys?

Updated from nightly 20190706 to 20190710 and noticed that there was no Bluetooth option available in Kodi audio settings.

Bluetooth is present in CE and I am able to connect there.



I took a look at the logs and the only diffrence at boot time is the presence of this section in 20190706 that is missing in 20190710

2019-07-11 01:12:05.319 T:4065325872 NOTICE: Enumerated PULSE devices:
2019-07-11 01:12:05.319 T:4065325872 NOTICE: Device 1
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_deviceName : Default
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_displayName : Default
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_displayNameExtra: Bluetooth Audio (PULSEAUDIO)
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_deviceType : AE_DEVTYPE_PCM
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_channels : FL, FR
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_sampleRates : 5512,8000,11025,16000,22050,32000,44100,48000,64000,88200,96000,176400,192000,384000
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_dataFormats : AE_FMT_U8,AE_FMT_S16NE,AE_FMT_S24NE3,AE_FMT_S24NE4,AE_FMT_S32NE,AE_FMT_FLOAT
2019-07-11 01:12:05.319 T:4065325872 NOTICE: m_streamTypes : No passthrough capabilities

Box is an S912 R-TV Box S10

The WiFi/BT module is an FN-Link 8223A-SR

1 Like


10-07-19 build with TVHeadend 4.3 has stopped working, so i went back to build 06-07-19.

How can I solve this?

Because I can’t go back to TVH 4.2, the channel list doesn’t match.

Best regards…

1 Like

I had an issue with my PVR guide after this update. Re-building the guide fixed it.

[in Kodi] Settings->TV->Guide->Clear Data

Nightlies have changed to a new branch so I will look into this, thanks.

1 Like

Thank you.

TVH 4.3 does not work in overnight versions.Can editing for TVH 4.3 work be done?
My box WP2
Tvheadent Version_4.3-1774

1 Like

It does work for me and I’ve been using it since early march and have tried almost all nightlies.

Warning: Keep in mind that tvheadend4.2 and tvheadend4.3 should not be running simultaneously.

You can’t run 2 separate versions of the TVH server at the same time (as far as I am aware).

Just remember to turn off auto update or you will get reverted back to 4.2

Yes I know.I am already running TVH 4.3 single.I never use TVH 4.2.TVH 4.3 does not work.I use TVH 4.3 for the oscam powervu feature.Some features of the oscam do not work in TVH 4.2.

Update from 9.0.3 stable to CoreELEC-Amlogic.arm-9.1-nightly_20190716.tar caused Safe Mode reboot after update. NexboxA1 S912 using dtb.img gxm_q200_2g as per normal.
Crash log
Kodi log

You need to update vfs.sftp addon from 9.2 nightly addons repository. It should fix your crash

1 Like

Totally lost now. Was on 9.0.2 with working mce usb ir receiver, updated to 9.0.3 it stopped working. Read about others in the same boat so I updated to nightly 20190706 to get it working. The thing autoupdated to 20190616 and now it doesn’t work again. Reverted to 20190706 and it works again but it keeps downloading an update even though i set it to manual update.

Can someone please tell me what I am supposed to be doing going forward? I want to disable the onboard IR as its range is poor and it gives me double presses, so i created a custom rc_maps.cfg as below. I have also enabled DVB drivers from the latest kernel and disabled TBS. All seems a bit messy now and I can’t get it working in the later versions

*		rc-rc6-mce	rc6_mce
#meson-ir	*		libreelec_multi

Same. I’ve tried on 3 different s905 / s905x boxes, and all have the same behaviour.
9.0.2 - mce usb works with crazycat
9.0.3 - mce usb doesn’t work
20190706 nightly - works with crazycat or media build drivers
20190716 nightly - doesn’t work.
I’m going to stick with 9.0.2 and the last nightly that works for now.

What I can’t understand is why the hell anyone would want to use an mce remote with the internal sensor in the first place. It makes no sense at all to me - if you have the remote you also have the sensor (or why buy it?), the usb sensor will generally be superior and if you’re already using an mce elsewhere it cocks that up. Hey-ho.