Nightly builds

On a new try with another usb wifi network card plugged i got this : https://pastebin.com/gi0jm6xA
May be it can help

Cheers

And since now you can use official Confluence skin to access CoreELEC settings :slight_smile:

4 Likes

HI @smp,
Please find 2 posts above associated dmesg with your build.
(same output with last nightly).
Or let me know how to integrate drivers, i know how to build coreelec from source but don’t know how to integrate drivers…
Thanks in advance,
Cheers

HI @smp
I found this https://github.com/whitebatman2/rtl8821CU.git
and this https://www.raspberrypi.org/forums/viewtopic.php?t=230499
but i can’t figure how to build…

I can see that there’s a nightly for 10/9 but my boxes are stuck on 6/9. Usually I get the message " An update is available" but not today. Is this what is intended for future nightlies or is this a hiccup?

Confirming I’ve still got 6th September on my Vim3 Pro. Just checked nightlies 11/9 available.
I toggled CE updates from Auto to Manual and back to Auto.
Nothing coming down. We’ll get back with some details.

Same behaviour here. I upgraded manually by downloading tar file.

This has been fixed now, thanks for reporting.

Cause: image names have been changed in the last nightly.

1 Like

Much appreciated. Thank you to the CoreELEC team for all that you do for us mere mortals.

Hi @smp,

I found a working driver for my debian machine : 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3 (2019-09-02) x86_64 GNU/Linux


Could you please make an image replacing existing RTL8821CU module by this one ?
Thank a lot !

It doesn’t compile in CE build system. No idea how to fix:

CC [M] /home/a/CoreELEC/build.CoreELEC-Amlogic-ng.arm-9.1-devel/RTL8821CU-78b396d627b1a8a69cddb0b9e1091c2ff26aae1d/core/rtw_mp.o
/home/a/CoreELEC/build.CoreELEC-Amlogic-ng.arm-9.1-devel/RTL8821CU-78b396d627b1a8a69cddb0b9e1091c2ff26aae1d/core/rtw_mp.c: In function ‘rtfloor’:
/home/a/CoreELEC/build.CoreELEC-Amlogic-ng.arm-9.1-devel/RTL8821CU-78b396d627b1a8a69cddb0b9e1091c2ff26aae1d/core/rtw_mp.c:36:5: error: ‘-mgeneral-regs-only’ is incompatible with floating-point argument
int rtfloor(float x)
^~~~~~~
make[2]: *** [scripts/Makefile.build:335: /home/a/CoreELEC/build.CoreELEC-Amlogic-ng.arm-9.1-devel/RTL8821CU-78b396d627b1a8a69cddb0b9e1091c2ff26aae1d/core/rtw_mp.o] Error 1
make[1]: *** [Makefile:1628: module/home/a/CoreELEC/build.CoreELEC-Amlogic-ng.arm-9.1-devel/RTL8821CU-78b396d627b1a8a69cddb0b9e1091c2ff26aae1d] Error 2
make[1]: Leaving directory ‘/home/a/CoreELEC/build.CoreELEC-Amlogic-ng.arm-9.1-devel/linux-9c838e69048638e8d351e9cca0cd7ca8ba836dfc’
make: *** [Makefile:1923: modules] Error 2

Thank you for trying,
I’ve successfully cross compiled it, but don’t know how to integrate it. I’ll send you a link with compiled files.

Finally, I’ve found how to add drivers by myself :relaxed:, so it’s ok, building image right now, I’ll let you know.

Did you’ve change Makefile to match arm64 ?

CONFIG_PLATFORM_I386_PC = n
CONFIG_PLATFORM_ARM_RPI = n CONFIG_PLATFORM_ARM_RPI = n
CONFIG_PLATFORM_ARM_RPI3 = n CONFIG_PLATFORM_ARM_RPI3 = y

Edit :

[ 400.993380@3] amlogic-new-usb2-v2 ffe09000.usb2phy: —Set port(0) tuning for host cf(xhci_hub_control)–
[ 401.053158@3] usb 1-1: new high-speed USB device number 3 using xhci-hcd
[ 401.193469@3] usb 1-1: New USB device found, idVendor=0bda, idProduct=c811
[ 401.193478@3] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 401.193481@3] usb 1-1: Product: 802.11ac NIC
[ 401.193484@3] usb 1-1: Manufacturer: Realtek
[ 401.193488@3] usb 1-1: SerialNumber: 123456
[ 401.195037@3] usb 1-1: Unsupported device
[ 401.403130@3] usbcore: registered new interface driver rtl8821cu
[ 402.117980@2] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Not working, trying others drivers…

Tried many drivers, some detect and load my rtl8811cu, interface appears on ifconfig, tried to connect to my SSID with wpa_supplicant but : No suitable network found.
I’m tired with that device… :woozy_face:

Edit final :stuck_out_tongue:

Received a RTL8812AU this morning working flawlessly…

20190911 build won’t boot on LePotato. Stuck at splash screen. I guess I have to re-format and start from scratch to get it back up?

You can copy SYSTEM and KERNEL from a tar of an older nightly to the SD card manually.

I was fine when updated to the 11/09 yesterday.
Today i got the auto update to 12/09 and i got the stuck on CE splash screen.
Khadas Vim3 Pro.

Fixed using above method and it booted.

12/9 nightly sticks on boot logo for me too on N2. I think you may have a problem. Got it back to 11/9 by pulling the power twice and rebooting.

Pulling the plug does not help ?

I have my N2 sometimes stuck at boot logo, but pulling the plug always brigs it back to life.

Same here on a TR99 X2 (S905X2) box. The update does not apply in the end.

Same here with BeeLink GT King. I managed coping again KERNEL/SYSTEM files from 20190912 tar file. So, same version. It booted.