No audio on media file played on Ugoos AM6 Plus (sometimes)

Hi, sorry for my bad english.
I have Ugoos AM6 Plus.
On Coreelec 9.2.x and on 19.x Matrix sometimes there is no audio on first playback of video; it happens about 1 in every 3 times, it’s just random. If, immediately after of this issue, i play another video, the audio of new video play and if after i play the first video then the audio plays and the issue is resolved. This issue is via HDMI to TV. The audio via spdif to AVR with passthrough work fine.
Moreover when i use Kodi with Android OS also audio via HDMI to TV work fine. The random issue of no audio via HDMI is only on Coreelec.
Thanks for help!

This user have same issue:

When the audio doesn’t play immediately if you check the audio settings for the file, what codec does it say its using?

Secondly just to rule out the basics check the firmware of your TV is on the latest version and have a read through this guide

1 Like

Thanks for help.
As soon as i can, i will check the audio settings for the file and what codec it say its using.
Meanwhile, i read the useful guide.
Very Thanks!

Hi, i read the HDMI guide, but I don’t think the problem is the HDMI cable because when i use Kodi with Android OS the audio via HDMI to TV always works fine.
On Coreelec 9.2.x and on 19.x Matrix sometimes there is no audio on first playback of media files with all this audio setting:
ALSA:AML-AUGE SOUND, HDMI
ALSA:default (AML-AUGE SOUND analog), PCM
ALSA:AML-AUGE SOUND, PCM
ALSA:AML-AUGE SOUND, HDMI multi Ch PCM
The media files that i am playing have AC-3 2 channels codec (Format : AC-3; Format/Info : Audio Coding 3; Codec ID : A_AC3; Bit rate mode : Constant).
In the meantime i found that one weird way for start the desired audio is to shift all audio track until you return to the desired audio. Then in this way the audio work!
Thanks for help.

Yeah, AC3 is Dolby Digital plus had problems with that myself and its version specific. I never really found a solution, I just found that if I had the passthrough enabled to the spdif in my soundbar and the audio didn’t play then if I turned the passthrough off in the video audio options it started playing. Though I do have the Kodi settings for the audio device set to auto.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice