No ethernet coreelec 9.0.1 Mecool M8S PRO+ S905x 2gb/16gb

Hi guys, i’m not getting any ethernet on my box, this chip is near the ethernet port:


Not sure if this post is relevant or not:

Ironically i need the ethernet to work in order to SSH in to the box to be able to get my remote working, wifi doesn’t work as it is the S9082C chip, though wifi works on libreelec

P.S yes i’m using the correct gxl_p212_2g dtb file renamed.

Here is a photo of my board:

Why are you using S905X DTB on a S912 Chip ???

I have an S905X chip not an S912.

Please name your Chip and Ethernet speed NEXT TIME.

We hate chasing Chinese Branded Boxes on Google to try and work out your hardware because you didn’t bother to disclose it.

You sure you don’t have a


That has an S905W Chip in it

It is defintely an S905X Mecool M8S Pro+. I don’t think they make this box anymore, now they use S905W, it is around 1.5yrs old, it came with android 7.1. Here is more info:

Wait for Devs Reply. I’m out of ideas.
Outside of you inserting a USB WiFi adapter to get logs.

Edit: Have you ever had this working with any CE Image ???

One of my boxes is a Mecool M8spro+.
Running without any problems.
Its one of those with a defective emmc chip. As long as u do not try to change the FW on emmc every CE and LE version from SD worked for me

Hi I have a couple of these boxes and I must confess I thought they had the S905W chip in them. One thing I did find when I upgraded to 9.01, was that after the upgrade in the Coreelec settings, wifi had been turned on and wireless had been turned off hence no ethernet connection, just changed the settings and ethernet worked again.

@spaceship9876 might be lucky with that easy basic settings fix .


UPDATE: my ethernet cable had become faulty for some reason, my mistake, sorry for the trouble. Ethernet is now working.

I installed latest coreelec in the same box, ethernet working fine, however my surprise was that the wifi don´t work and like you just said I remember that was working fine with Libreelec.

Any solution? It’s not possible to adapt the driver from Libreelec?

Leave your problem here, there is a topic for your request.

@Pavlicic it’s not possible, your device probably uses the xs9082 chip and there was never a driver released for this, the reason it worked in the older LE releases is because they used the prebuilt driver from the Android releases, this is not something that we are willing to do.

Hi , thanks for the answer, but my box uses the S905X chip.


He was talking about the WiFi chip inside the box, not the CPU.

1 Like