No signal with resolution.ini in place (9.2.5)

I just got my Odroid N2+, set everything up and then noticed I forgot to replace the DTB file (as is tradition for my initial CoreELEC setup) in the boot partition.

Surprised that it even booted I went ahead and replaced the default img.dtb that is on the image with the correct “g12b_s922x_odroid_n2plus.dtb”.

Problem is, the Odroid won’t boot with that DTB. I nailed it down to the presence of the resolution.ini with the following content:


If I delete the file the n2plus DTB will boot just fine until I touch the Disable GUI scaling option in Kodi again.
It boots fine with that resolution.ini when using the default DTB though.

Is that a bug with CoreELEC or am I supposed to use the DTB that ships with the image? The default dtb.img works perfectly fine from what I tested so far, no errors except the usual Kodi quirks.

It’s an older thread but I believe it’s still valid:

I think that only applies if the display/receiver is not ready yet when CoreELEC boots but my receiver and projector were on all the time.

After a short blip the Odroid is completely dead. Heartbeat LED is still blinking though.

edit: Should probably also note, the resolution.ini is not placed by me but by CoreELEC when resolution settings are changed.

You have an Odroid so it is probably different, but on my AmLogic boxes I was able to force display resolution by adding a line to config.ini when booting from SD Card. Unsure if that’s useful information in your case.

I would recommend using the DTB that comes with the CoreELEC image you downloaded.

If you can, logs are encouraged.

1 Like

Unsure if that’s useful information in your case.

Probably not, I’m not trying to force any resolution or try to turn on CoreELEC while the display is not active. Just using the normal CoreELEC UI to configure a UI resolution causes this issue.

I would recommend using the DTB that comes with the CoreELEC image you downloaded.

I’m doing that right now but I’m unsure if that’s the correct one and if it causes issues down the line. Maybe one of the devs can chime in on which one to use. The download page states that I should use “g12b_s922x_odroid_n2plus.dtb”, which doesn’t work for me.

I checked the checksum of both and they are different.

If you can, logs are encouraged.

I used pastekodi instead of the UI option but I assume they produce the same log.

I also found out that it is indeed a display issue on boot, if I replug the HDMI after boot everything is fine again.

It’s a bit of a read but it sounds very much like the issue you are experiencing:

In -NG we allowed GUI to run at native resolution, but it introduced issues with some devices. So now the default is like it was in the past, and the user can opt into running the GUI without scaling, depending on the hardware they have and how it handles it.

From: Gui at 3840 x 2160

To test if it is the display resolution causing the issue, you could try this:

SSH into the box as root
vi /flash/config.ini
find HDMI custom mode and remove the hashtag from modeline=...
save file and exit [ESC] :wq
reboot now

1 Like

Couldn’t really find anyone in that thread that has exactly the same issue but you are definitely right that it is a resolution issue.

I checked again and hdmimode=2160p30hz works on the stock dtb.img but produces a blackscreen on “g12b_s922x_odroid_n2plus.dtb”

hdmimode=2160p60hz works on both dtbs. Not sure if the hardware is strong enough to run the UI at native 2160p with 60fps but so far it seems to work.

So I’m just going to leave it at that for now, I’m now running the correct n2plus dtb at 2160p which is all I ever tried to accomplish.
Thanks for the help!

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.