ODROD N2, TBS5520SE driver issues (solved)

I’ve just bought an ODROID/CoreELEC bundle from Hardkernel (latest CoreELEC version installed) and I’m trying to get it to work with the TBS 5520 SE DVB tuner.

I’ve tried all the DVB driver options. The “CoreELEC default” and “drivers from latest kernel (media build)” options have this in the dmesg log:

[    8.237482@2] usb 1-1.3: New USB device found, idVendor=734c, idProduct=5521
[    8.237488@2] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    8.237804@2] usb 1-1.3: Unsupported device

When I select “TBS cards with crazycat additions”, I can see the tuners in the tvheadend server, but “force scan” doesn’t seem to work fully. It might scan one or two channels then stop.

After a while, the box became very unstable and started crashing.

I removed all peripherals except a bluetooth dongle and the DVB device. I also used external power for the DVB tuner, but the crashes and random reboots continued.

Changing back to the non-crazycat drivers solved the crashing problem, but I can’t use the tuner at all then.

What can I do? Is there a way to get this tuner working? Thanks!

PS I made an edited version of the first errors appearing in dmesg which is here

Hi which USB port are you connected to? I am running the same setup with version 9.2.0 and am running both the DVB-S and DVB-T connections without issue. I am currently connected to the front OTG port on the N2 and externally power the tuner. I think I had to backdate my drivers when I first upgraded to this version.

I’m plugged into one of the USB3 ports on the back.

Until you asked the question, I didn’t even realise that there was a port in the front. I guess it must be a USB2 OTG since USB3 OTG has a different shape. That might fix it for me. I’ll give it a try. Thanks! I’ll report back when I have a chance.

Please report back, as you say. It’s important to the forum to have the solution/experience in the various issues that can affect all the community. Manu users solve their problems just by searching in the forum. Thank you.

Here I use this method.
usb cable y I cut the black usb end and cut only the red wire.

I will try to summarize, I plugged the red end of the usb cable straight into a 5v 2a source.
I cut the red wire from the black usb end, to pass only data to the box. (Red wire cut with no power return to box)

In short, with this method your TBS5520SE will work with an independent external power source.
Any questions I can help better!

Black Male USB Tip (Cut Red Wire) Boxed, transfer data only.
Red tip male USB connected to power supply (TBS power only)
Your problem and lack of energy.

And you can use this method.
The method mentioned above is what I’m using, much better.
In order not to modify the tbs cable use a female + male usb extension and cut the red wire from it.

Yes, I think it’s working!

Using an adapter, I plugged the device’s black plug (power/data) into the USB OTG socket on the front of the board and attached the red (power) USB plug to a separate USB power supply (phone charger)

I selected the crazycat DVB driver option and rebooted. I wasn’t watching the screen while the board was booting, but I saw LED activity showing a second reboot. I think that just means that CE has a two-stage process (including the second reboot) to reflash with the selected drivers. Nothing to worry about, I think.

There was no instability at all after that, so I think that the problem might have been a USB3 issue. Previously, if I repeatedly hit the “Force Scan” button in tvheadend it would soon crash the board, but now it survives.

I don’t have any satellite/tv feeds connected right now so the scan didn’t find any channels. I’ll have to wait a few days until I can test that, but I think that this solved the problem for me. Thanks very much @alexbudd!

1 Like

I don’t think that it’s necessary to cut the power wire in the black plug, especially if you are plugging both into the same USB hub. Everything will share a common ground that way, won’t it?

You’re probably right that it’s a good idea to power the box externally, though. It eliminates a lot of headaches or possible problems if you know that the box has enough juice.

Method To connect to the external usb hub you need not touch anything!

More for the connection using the method, the red usb cable connected to a 5V 2A external usb source, the black boxed usb cable and need to quote the red wire. For here it gave return of energy.
When the box was off the light was not red, it was always with the blue light on.
After quoting the red wire of the black usb cable everything was perfect.
I connect the red cable to this source of my iphone.

I see. I think we’re talking about the same thing.

If you use a phone charger to power the box, you needed to stop current flowing back into the USB port on your computer. In that case, it’s necessary to cut the power line on the black cable (but you can still get floating voltage problems, I think).

However, if you connect everything to a powered USB hub, everything should work without a problem, and you won’t need to cut the red wire.

Although, I have to say that I have come across many powered USB hubs that don’t really solve the problem of excessive power draw, especially if you try to use them with something like a Raspberry Pi :frowning:

Fortunately for me, it appears that the ODROID N2 doesn’t have a problem with back-supply of power on the OTG USB port, so I probably won’t have to modify any cables.

Safety is never too much. In order not to modify the tbs cable use a female + male usb extension and cut the red wire from it.
the idea and help if you managed to solve your perfect problem.:+1:
@electrive Change the topic to resolved.:100:

Sorry to say that after further testing, my issue is not solved.

I modified a cable as suggested by @erbas and used a USB2 hub connected to the N2’s OTG port. I still get random crashes at start-up or if I connect/disconnect the TBS5520SE device. Logs also indicate that it has something to do with the tuner device. They are similar to the ones I already posted.

If the board doesn’t crash at bootup, the kernel modules do load and I can see the device in tvheadend, so I know that the cable trick worked OK.

I wonder, @alexbudd, is your setup like mine? You mentioned something about backdating drivers. I probably shouldn’t need to do that, should I? The version of CE that came with my board seems to be the most recent.

Any other suggestions for things I can try? Thanks.

Hi drop me a private message with your email address and I’ll send you the drivers I am using.
I have made no modification to the power supply as suggested but run through a powered hub that is not connected to the N2. I’ll send some pictures of my setup when I send you the file.