Odroid C2 - DVD menu blank, cursor is there

Bug report


Describe the bug


Here is a clear and concise description of what the problem is:

I have a lot of my DVD’s ripped to ISO, and put them on my NAS which is mounted through SMB. Most of them are series, in this example I use That 70’s show Season 2 disc 3. What happens is that the initial trailer / promo runs fine. When that ends it goes to the menu. The screen then stays blank, but the cursor / selector is there. The music plays. If I just enter the dvd starts playing. If I then go back to menu it works fine.
When I restart the DVD and am on the blank menu, when I just let it there, I guess at the point the music restarts everything practically locks up. 100% CPU load on all 4 cores and even SSH takes about a minute for each command to recognise, let alone reproduce it.

I came from LibreElec 9.0.2, where the menu’s work fine but there I have MP2 audio issues, which work fine under CoreElec. I have tried some development builds from LibreElec on kernel 5.x, which also have that DVD menu issue.
It’s similar to https://forum.kodi.tv/showthread.php?tid=335979 and https://forum.libreelec.tv/thread/9105-dvd-title-menus-rarely-appear/, and there are more to be found.

To Reproduce


Steps to reproduce the behaviour:

  1. Play a DVD with menus in ISO format

Debuglog


The debuglog can be found here:
The CoreElec log, so the one that is NOT working properly:

https://1drv.ms/u/s!As_wCUgs-pjPgj4fHldtEbpAKjS4?e=5bw8ca

During the trailer I press UP to skip to the menu. The following line indicates that:

2019-11-01 16:04:25.083 T:4093931536 DEBUG: HandleKey: up (0xf080) pressed, action is ChapterOrBigStepForward

So from there on, the menu should be build up or shown.

For reference, I also have the LibreElec log, which does not have that issue. Not sure if that helps.

https://1drv.ms/u/s!As_wCUgs-pjPgj0X3WlHagskQHK6?e=lAORtz

Same, I pressed up and from here the menu starts:

2019-11-01 15:38:58.093 T:4087463952 DEBUG: HandleKey: up (0xf080) pressed, action is ChapterOrBigStepForward

Screenshots / Video


Here is a video or screenshots to help explain the problem:

When the menu comes up after starting the DVD:
https://1drv.ms/u/s!As_wCUgs-pjPgkDbqpac92gnZKgF?e=osz9SI

Then I press enter once, which does enter the episodes menu:

https://1drv.ms/u/s!As_wCUgs-pjPgkJ8wt6byt3fnDLl?e=ysxu5N

Then I enter again and the episodes start playing. If I go back the menu then it shows up fine:

https://1drv.ms/u/s!As_wCUgs-pjPgkEoHESsQsgoQqi8?e=35sjjJ

CoreELEC version and device


CoreELEC version: 9.2.0
Device: Odroid C2
Device Tree:

Other information, sample media (if appropriate)


Here is some additional information or sample media that might help:

If you want me to I can upload a DVD iso somewhere which shows the issue. It would be a private link / upload though as I of course can’t just share copyrighted material. However, so far every ISO I tested has this issue.

Have you tried Kodi on Windows to see if this can be reproduced, if your having issues in LE mainline builds then this suggests an issue with Kodi itself.

For some reason I don’t get notification at all from this forum, not even in my spam. However, I’ve just tried Kodi (18.5) on Windows and that works perfectly fine with the same DVDs. As said, Kodi 18 on LibreElec works fine as well.

You won’t get notifications unless you explicitly turn them on.

Now you said

I came from LibreElec 9.0.2, where the menu’s work fine

but there is no LE 9.0.2 release for Amlogic, so I’m not sure what build you was using?

and then you said

I have tried some development builds from LibreElec on kernel 5.x, which also have that DVD menu issue.

Our nightly builds contain Kodi 18.5 so can you try that.

Ah, I’ve enabled notifications now, that works. Usually they are enabled by default.

Anyway, there sure is a 9.0.2 LibreElec for C2: https://libreelec.tv/downloads_new/odroid_c2/ has a 9.0.2 build, which works fine. That could have another Kodi version though, I’d have to look that up. The LE development builds which use mainline kernel and Lima has serious bugs though for now, but while dvd itself plays fine it also has the menu bug. I cannot verify though if that’s Kodi itself (they also use Kodi 19 now) or Lima or something else.
I know the older coreelec builds worked fine. I’ll try the Coreelec nightly and report. Do the logs show anything useful? I’ve not compared them. Can there be any other logs or something else I can provide?

I’ve tried CoreELEC-Amlogic.arm-9.2-nightly_20191124-Odroid_C2.img, i.e. the november 24th nighly, but the same issue is there.
What can or should I provide besides the logs I have already provided, in order to help fixing this issue?

9.2.1 didn’t fix this. Issue still there, and same question still; what can I do to help fixing this?