Odroid N2 & OpenVFD

Sure, please tell me your address. Do you need a battery holder as well? They just didn’t arrive yet.

Great! But it seems I can’t send you a private message. Guess it is because I am too new to this board?!

Just setting one of these up.

Is this the correct switch.



Looks like it’s the correct one, yes.

Bugger, that means I’ve done summit wrong then.


Reread everything tonight.


Could someone explain what I’ve got to do with the config.ini / boot.ini

Reguarding the red text in the guide.



@TheCoolest, OLED doesn’t light when N2 back from suspending,is this on your todo list?

On my N2-9.0.3 also. Tried it with alternative “service.odroidn2.oled.0.1.3” and it does not work after Suspend (install on eMMC)

Can you post dmesg | paste output after resuming?
It’s supposed to work, but I never tested it.
I guess that what could be happening is that the OLED controller needs to be reinitialized after suspend.
When you type systemctl restart openvfd, does the OLED display start working again?

here is the dmesg

yes, after run systemctl restart openvfd, the OLED display working again

Ok. I think that I know what the problem is. When the device goes into standby, power to the OLED is cut and when the device resumes, the display needs to be reinitialized.
Do you have a github account? It would be great if you could open an issue on this on the openvfd driver repo: https://github.com/arthur-liberman/linux_openvfd

I have no GitHub account

Ok, no problem. I’ll open it.

This is now fixed, today’s nightly should have the fix.

I downloaded two 20190710 build ,one is earlier,another is later, with the earlier build, resume from suspend, oled works OK, but with the later build, not OK.see the picture below, only the ":"and “mins” displays,

then after I played a media, the oled works normaly again.

You need the build that was uploaded tonight.
I’ve tested it several times with several displays. I’m not sure what is wrong exactly.
Will investigate further. The old 0710 build, doesn’t have any fixes, so I’m not sure why it worked.

Would you remove your fix and give it try? Because from late 0710 to today’s night build, the oled resume form suspend has the same issue.

If you leave it like that, when the hour changes, does the display fully update?
I think I know what the problem is, and I will try to correct it.

Yes, it is.

Ok, I think I’ll have a solution today or tomorrow. Thanks