Odroid N2 test builds

Does that then mean we cannot have any other device linked to our TV while using a N2? Seems a bit of a harsh workarround no?

For me I got my Set-top box connected and a N2 to my TV directly on different HDMI ports.
When I go from my settop box to my N2 it sometimes picks up on it but most of the time it shows the N2 but the command is actually still going to my settop box. Switching sources a couple more times or disable/enable CEC on my TV itself wakes up the N2

No, it doesn’t mean that.
Disconnect other devices help you to narrow down your problem.
If you are troubleshooting better to eliminate all other possible trouble sources.
For example, most of the older amlogic boxes have a bug in their uboot which blocks the CEC functions completely even if they turned off.
CEC implementation on different manufacturer’s different devices are all differs so hard to tell how it will work together in different combination of devices.

First of all let me thank you for spending hours into the support of this device and make many people happy :slight_smile:

I’ve just spun up my new N2 with the latest ce nightly and everything is working pretty well except hyperion. I’ve seen there were a lot of discussions some months ago but it’s pretty quiet since then. Is there any known issues with the addon? I can’t get it running for HW accelerated videos (H265, PVR), but it works smooth on H264 (like netflix.inputstream). Anyone facing the same?
I’m using the hyperion not hyperion-ng addon. The ng-build seems not to support my udp device :frowning:

Hyperion.ng work fine for me in my N2 with all content

i have some problems with the latest updates (nightlies). is there anything known that the installation of those files does not start? i have to reboot (removing the power cable) of my n2 two times so it boots without installing the .tar.gz - otherwise i just see the coreelec welcome screen, then it “freezes”, but the heartbeat led is still blinking as regular, but no lan, no text on the TV that it updates anything etc.

Read this and it’ll explain.

thanks, that fixed it!

I tried to update the hyperion.ng to the latest version, but I came across this error:

"[hyperiond MAIN] Set user data path to '/storage/.hyperion’
QSqlDatabase: QSQLITE driver not loaded "

Any idea how to fix it? Current version have many issues with multiple instances

hi @ all
today i tried to use my Minix Neo A2 Lite for shutdown/wakeup my odroid n2
shutdown works great but wakeup does not work:
i was collecting the code like this:

CoreELEC:~ # ir-keytable -u
Protocols changed to irmp
Waiting for IRMP decode event. Please, press CTRL-C to abort.
Received IRMP code: remotewakeup=‘0xe718fe01’, decode_type=‘0x0’, remotewakeupmask=‘0xffffffff’

this is my config.ini:

# IR setup Setup a custom keycode to wake the N2 from suspend or poweroff You can stop kodi and eventlircd
#   and use "ir-keytable -u" to obtain a compatible u-boot IR keycode


#   decode_type can be one of the following: NEC='0x0', DUOKAN='0x1', TOSHIBA='0x2', RCA='0x3', RC5='0x4',
#   RC6A='0x5', NEC_TOSHIBA_2IN1='0x6', NEC_RCA_2IN1='0x7', RCMM='0x8', NEC_RC5_2IN1='0x9',
#   NEC_RC5_2IN1='0xa', RC6='0xb'

decode_type='0x0' # NEC

#   remote power key mask: Some IR protocols implement a toggle bit, this can be ignored by the "and" mask:
#   RC5='0x37ff', RC6='0x1effff', RC6A='0xffff7fff'



I am not sure now, try decode_type='0' in config.ini

thank you for your quick reply but still no bootup.

You try to wake up N2 or the Minix?

I have the same remote been needing to figure out how to get this going.

i try to wake up the N2 with the minix remote.
edit: i found the problem!
i was using petitboot (switch to SPI) - when switch set to EMMC it works!
Is it possible to get this to work when using petitboot? do you need logs?

Do u use the GPIOs ?

No. I have an ambilight Chinese kit connected only by usb to the tv.

since 2 days or so i am unable to watch iptv
the error i get is:

2019-10-10 21:03:02.159 T:3670016896  NOTICE: AddOnLog: PVR IPTV Simple Client: LoadEPG     EPG Loaded - 35023 (ms)
2019-10-10 21:03:16.269 T:4059882064  NOTICE: VideoPlayer::OpenFile: pvr://channels/tv/All channels/pvr.iptvsimple_696549987.pvr
2019-10-10 21:03:16.279 T:3820635008  NOTICE: Creating InputStream
2019-10-10 21:03:16.280 T:3820635008  NOTICE: Creating Demuxer
2019-10-10 21:03:46.316 T:3820635008   ERROR: OpenDemuxStream - Error creating demuxer
2019-10-10 21:03:46.316 T:3820635008  NOTICE: CVideoPlayer::OnExit()
2019-10-10 21:03:46.345 T:4059882064  NOTICE: CVideoPlayer::CloseFile()
2019-10-10 21:03:46.349 T:4059882064  NOTICE: VideoPlayer: waiting for threads to exit
2019-10-10 21:03:46.349 T:4059882064  NOTICE: VideoPlayer: finished waiting
2019-10-10 21:03:56.896 T:4059882064  NOTICE: VideoPlayer::OpenFile: pvr://channels/tv/All channels/pvr.iptvsimple_1476471239.pvr
2019-10-10 21:03:56.898 T:3896468352  NOTICE: Creating InputStream
2019-10-10 21:03:56.898 T:3896468352  NOTICE: Creating Demuxer
2019-10-10 21:04:26.934 T:3896468352   ERROR: OpenDemuxStream - Error creating demuxer
2019-10-10 21:04:26.934 T:3896468352  NOTICE: CVideoPlayer::OnExit()
2019-10-10 21:04:26.964 T:4059882064  NOTICE: CVideoPlayer::CloseFile()
2019-10-10 21:04:26.964 T:4059882064  NOTICE: VideoPlayer: waiting for threads to exit
2019-10-10 21:04:26.964 T:4059882064  NOTICE: VideoPlayer: finished waiting

anyone an idea how to fix that? i found that: https://forum.kodi.tv/showthread.php?tid=231042
could it be a regression?

is there some kind of archive for old builds? the current ones are not usable for me (iptv does not work because of the above error). so i would like to to back about 2 or 3 weeks. but i only find the last 2 days nightlys.

That thread on Kodi forum is 4 years old, so very unlikely. We did not change Kodi versions since 9.2 was released.
Enable PVR debug log and post a full log.

This is our nightly archive: http://coreelec.pokey.de/

seems like a problem with init7 iptv / my router. i am also unable to watch tv on my pc. thanks for the archive link.