Odroid N2 test builds

It probably limits color space to 8-bits or something like that.
Glad to hear it’s fixed.

On LG TV’s labeling the input as “PC” is the same as turning on game mode and I think allows 4:4:4 chroma, the same as DeepColor mode.

@roidy I have no idea, the manual for the TV doesn’t seem to explain what it does. I can’t even think where I read to set the label as that in the first place! It does mean that if you have are running everything via an amp, so single cable to the TV everything then has to be on the same setting. If I ever get round to it I may move my PC straight to the TV and use eARC for the audio to the amp.

Only the 2019 models support eARC, the C8 is an 2018 model, and doesn’t support eARC.

@TheCoolest it does support eARC, I think it was added in an update later on. edit* or maybe not, it’s not often I’ve used it so can’t say whether I’ve actually noticed what’s fed to the amp.

OK, new issue I’ve noticed with 4k rips is every so often, like maybe 4-5 times throughout the film there will be a random patch of “broken” pixels that last a split second. I didn’t see this issue before so not sure what else has changed.

Would old HDMI cables manifest this kind of problem as I’ve never seen it before until I changed that TV label setting on my LG Oled TV.

Is it worth enabling the 422 chroma setting under the coreelec settings?

Try it and see :slight_smile:

4:2:2 chroma uses less bandwidth than 4:4:4 and thus is much more forgiving of poorer quality HDMI cables. I have old HDMI cables that play 4K HDR content perfectly fine at 4:2:2 chroma but fail with pixelation and signal drop out when used at 4:4:4 chroma

In actuality all main stream movie and tv show content is mastered at 4:2:0 chroma, even UHD Blu-Ray disks, so even set to 4:2:2 chroma you wont see any loss of picture quality.

@roidy I think I’ve seen it at 4:2:2 as well, it’s weird. It’s only a few times and literally only for a split second.

As I saw talking about chroma … I have on my ATV 4k Chroma 444 and the picture looks sharper and better on my tv than 422 on ATV 4k. So one question. On N2 if I don’t active in CoreElec settings 422 is the normal status 444 or 420 for Chroma with CE on N2?!

thanks and #staysafe

@SSC_Jarod The standard CoreELEC output is 4:4:4

1 Like

Thank You! :raised_hands:

This is still the case on 9.2.2 (at least for my VIM3L).
Any idea when this will be fixed? Thanks!

It’s only the new b9/c9 that support earc,I have the b8 and there is no chance of the 2018 models getting it

Hi, can I ask how you did this as I am getting the same double input on my Flirc gen2.

The only mention about it I found here, so just following up:

When running CoreELEC (official): 19.1-Matrix (Amlogic-ng.arm) (GT-King rev. A), I am getting the exactly same spam, when I changed config.ini by setting:


however, after the first boot it gets changed to:


so after the second reboot, the spam is gone, though I am not sure if I really disabled CEC or not.

Was this the fix you were talking about?

I am currently facing an issue that GT-King is entering stand-by (or something), which makes it inoperable, and I am trying to figure out what is it which puts it into this condition. I already disabled stand-by when TV is off in libCEC config, but apparently it did not help.

I have an old Panasonic plasma and it seems it could be a trouble over CEC.

Modify the config.ini in Matrix is obsolete. Just enable/disable it in libCEC settings.

Would the correct approach be then to set enabled flag to "0" in .kodi/userdata/peripheral_data/cec_CEC_Adapter.xml:

    <setting id="activate_source" value="1" />
    <setting id="button_release_delay_ms" value="0" />
    <setting id="button_repeat_rate_ms" value="0" />
    <setting id="cec_standby_screensaver" value="0" />
    <setting id="cec_standby_screensaver_paused" value="0" />
    <setting id="cec_wake_screensaver" value="1" />
    <setting id="device_name" value="CoreELEC" />
    <setting id="device_type" value="1" />
    <setting id="double_tap_timeout_ms" value="300" />
    <setting id="enabled" value="0" />
    <setting id="pause_or_stop_playback_on_deactivate" value="36045" />
    <setting id="pause_playback_on_deactivate" value="0" />
    <setting id="physical_address" value="0" />
    <setting id="power_avr_on_as" value="0" />
    <setting id="screensaver_delay_standby" value="0" />
    <setting id="send_inactive_source" value="1" />
    <setting id="standby_devices" value="36037" />
    <setting id="standby_devices_advanced" value="" />
    <setting id="standby_pc_on_tv_standby" value="13011" />
    <setting id="standby_tv_on_pc_standby" value="1" />
    <setting id="tv_vendor" value="0" />
    <setting id="use_tv_menu_language" value="0" />
    <setting id="wake_devices" value="36037" />
    <setting id="wake_devices_advanced" value="" />
    <setting id="wakeup_cec_active_route" value="1" />
    <setting id="wakeup_cec_auto_power" value="1" />
    <setting id="wakeup_cec_streaming" value="1" />

Or should I set some others as well? Unfortunately, I can only remote into the box and do the changes in the config files.