Odroid N2 test builds

It’s for users who have DVB adapters connected via GPIO.

OK thanks for information.

Hmmm… i seems to be moved to a stable build 9.2.1, and stopped receiving nightlies. Was this your work?

Edit: never mind. Found the thread about the new kernel. I think I’ll stick to this version until things are a bit more mature.

This is still a problem. I hope it’ll be adressed someday as referenced here: Chapter skip on 4k Remux causes Kodi crash

So, my N2 just reboot loops.
Latest nightly.

Any advice?
No hdmi output, can hear external hardrive cycle up/down.

Edit:

Well, regarding my boot loop. I downloaded the CoreELEC-Amlogic-ng.arm-9.2-nightly_20200116-Odroid_N2.img flashed it to a microsd, and it boots.

How do I get that image to the emmc?

Thanks!

(brainfart thoughts; Would it be possible to add a counter of sorts.
That counts fast unsuccessful boots, and when it hits a limit, it decides to flash the latest successful image?)

ps. sorry for crosspost ds.

You can run installtoemmc and follow the instructions

I get:
"Starting CoreELEC eMMC installation tool v0.1…

System is not supported: g12b_s922x_odroid_n2!"

So, there is no possibility of mounting and putting the image in the upgrade folder?
As one does when switching to the nightly?

What should i mount in /dev/ ?

Thanks.

Did you do all these steps:

  1. Boot from SD with emmc not installed.
  2. Run installtoemmc and answer yes to reboot with the 30 sec delay.
  3. Reboot and during the 30 sec delay install the emmc.
  4. Run your command.
  5. Run installtoemmc to restart the transfer process.

Provided you have the latest version of the petitboot
From CoreELEC-Amlogic-ng.arm-9.2-nightly_20200116-Odroid_N2.img.gz extract kernel and system.
N2 in usb mass storage mode - # ums /dev/mmcblk0
Copy files and exit this mode - # ums.
Restart :grinning:

1 Like

Now, this sounds more like a civilized manor of going about things.

How does one know, if one has the latest version of petitboot?

Oh, nevermind. Reading now, there is a new hope. soundtrack
So, seems I can install petitboot and bob is seem to be my uncle.

Top left is the versionpetitboot

1 Like

So, I removed my emmc .

Then I installed both the latest Testing version : 20200118 & the stable petitboot (20191127).

Neither do turn on my screen (Pioneer PDP-507xa) in SPI mode, which got me worried enough to use:
petitboot Recovery Image (20190417) (see the first sentence in this post).

Which fixed things, and then I installed the stable latest petitboot again.
Once more I could run the latest CE nightly from a uSD, although still blind as a bat in SPI mode.

I started to look for a solution for the “flying blind” situation and stumbled upon this.

I installed my emmc, booted CE from my uSD, enabled ssh, and proceeded by coping the latest CE nightly with winSCP to the ‘/var/media/STORAGE/.update’.

Behold, it apparently flashed the emmc, since I have my old system again with the latest nightly CE.

Have not yet found any solution to the bats bashing into the plasma tv situation, sweeping up those buggers is a chore, which would be nice to have fixed. The mentioned usb mass storage mode could very well save my precious N2, although unlikely, if the need would arise.

Although, it mentions to alter the: kernel parameter ‘disable_uhs=<true|false>’? How does one unlock this achievement, being blind?

This is for those who may have trouble loading an OS of a particular type of card.
You can try to set a resolution.

  1. Do “Exit to shell”
  2. Run these commands to set the display resolution and save.
    #spimmc.sh
    #fw_setenv hdmimode 720p60hz
  3. Press “Ctrl-Alt-Del” to reboot
    If you still have a problem write in the topic of petitboot.

Hey, can anyone help me work out how to make 4k rips look correct? I’m connected to an LG C8 via a Sony STR-DN1080 ( Home Theatre AV Receiver). I get a picture no problem but I see banding in the picture that I don’t get when playing back directly on the TV (either via USB or via something like Emby).

If I try and echo 420 into the attr file I just get a loss of signal when I try and play back any files.

Is this an HDMI cable issue? Do I need newer better cables?

You may need to configure the AVR and make sure the input/output is set to HDMI 2.0 or Deep Color.
Also, don’t use attr, you can set everything that the system supports through the CE settings.

@allanp81, have a look at Setting HDMI signal formats (HDMI Signal Format) and https://www.sony.co.uk/electronics/support/audio-components-receivers-amplifiers/str-dn1080/articles/00171719 :+1:

@TheCoolest Yes I’ve made sure that the HDMI is set to “Enhanced” instead of standard and makes no difference. After I posted last night I tried connecting the N2 directly to the TV, bypassing the amp and same issue. I have HDMI on the TV set to deep colour or whatever the term is but it’s the same. By the way, I realised I posted into the wrong thread as I’m using current stable branch. Is this something that has been fixed/changed in subsequent nightly releases?

Give the nightlies a try as it only takes a few minutes to switch. You can revert back any time.

This must be something my TV is doing, I have a Windows 10 machine that produces the same banding effect that I’m seeing on coreelec, suggesting it’s an HDMI setting on the TV or something that is introducing this problem.

OK, so I think I’ve solved it…for some reason on the LG TVs, if you label an HDMI input as “PC” it changes something, not sure what. I changed this to something else and it has solved the issue!

About | FAQ | Terms of Service | Privacy Policy | Legal Notice