Odroid N2Plus CoreELEC 19.5 rc2 freezes

Hey folks, since a while (I don’t remember when to be honest) my N2+ freezes randomly. It doesn’t matter if it’s 720p or 2160p with HDR. The video starts to stutter and freezes completely a bit after. I’m able to ping the box, but I can’t ssh into it. The only method to get it back is a power cycle, maybe it would recover after a while, but I never waited more than 2-3 minutes. I haven’t done a clean install, need to check if I can find another SD card… The only two addons I’m using are PlexKodiConnect and Trakt.

The logs are full with errors and you can find the complete log here

2022-10-21 19:10:35.303 T:3555 ERROR : CAESinkALSA - snd_pcm_writei(-32) Broken pipe - trying to recover
2022-10-21 19:10:35.706 T:4677 WARNING : OutputPicture - timeout waiting for buffer

Any idea what could be the issue?

Thanks!

For testing purposes you can boot from USB Flash Drive using PetitBoot (set switch to SPI).

See my similar issues here

I noticed that the freezes are more or less frequent depending on which skin I use. With default skin Estuary the freezes are less frequent. With Estuary MOD v2 it freezes all the time just while navigating the GUI.

I also booted from SDCard after some intial problems, see here Can't install from SD card to EMMC on Odroid N2+ but no change, still some freezes.

Could you please try downgrade to 19.3 and see if the issue remains?

For testing purposes you can boot from USB Flash Drive using PetitBoot (set switch to SPI).

thanks, I’ll give it a try on the weekend, USB flash drives are more common in my household…

I noticed that the freezes are more or less frequent depending on which skin I use

That’s interesting, I think I used a different skin at the beginning and then switched to the default again and never went back.

Could you please try downgrade to 19.3 and see if the issue remains?

Sure, I’ll downgrade later and will see if it helps.

Any update?

Unfortunately the 19.3 downgrade didn’t help and I still have the same issue. I just installed CE on a USB flash drive and will see how it goes

Edit: same problem with USB…

Which firmware (petitboot/SPI) do you have installed?

Installed “20220317” yesterday to get the USB boot working.

1 Like