(Overclocking N2, SOLVED, results inside) Cannot locate boot.ini

#1

This may be a noob question, but I am stumped.

I am having trouble locating the boot.ini file. There is no such a file in the “Configfiles” folder in the odroid directory. Im on windows 10 and accessing my N2 over my local network.

I also attempted to SSH into the device via putty and search around each directory to no avail.

I have the march 25 coreelec test build on the Odroid N2.

Any help would be appreciated!

Thanks !

#2

It’s on /flash/boot.ini (or the root of the SD card if you put it in the PC)

#3

I will try this thx!

#4

Keep in mind that boot.ini will be overwritten so if you change it then it will be lost.
You can write your custom settings in your config.ini at the same folder.

#5

when you say overwritten do you mean each time i boot it will go back to default?

I am trying to change boot.ini to set max frequency

seen here: https://wiki.odroid.com/odroid-n2/application_note/software/set_cpu_freq#setting_bootini

Youre saying I can add this to config.ini as well? what would be the benefit of doing so over boot.ini?

Thanks again

#6

We have a section in the config.ini for this, if you open it in your favourite editor then all will become clear :slight_smile:

boot.ini is only overwriten when you install a new CE update, add changes to config.ini as others have recommended.

#7

Thank You adamg!

#8

I am having trouble. When I put my micro sd into my pc, it asks me to format it. How can I actually access config.ini? Is this file invisible to samba? Do I have to create it if it doesnt exist?

Thank you again!

#9

There are two partitions on your card. Windows wants to format the second one because don’t recognize ext4. Just cancel the format warning and check the first partition. You can find your config.ini there at the root folder. Also you can acces config.ini on your N2, you can find it in /flash folder.
If you want to modify it you should remount it.
mount -o remount,rw /flash

#10

How can I check the first partition? Windows cannot by default access the drive at all. If I cancel the format request there is an error indicating the drive cannot be then read. Why isnt the file visible via smb?

#11

I sshd into the box and now see the config.ini file. Additionally, I can see the boot partition “COREELEC” 512MB in windows disk management. I am sure this is the partition you are referring to. Only issue is,“Open” or “Explore” are both greyed out. I cant seem to access this drive/partition. How is it that I can access this partition in Windows?

Thank you again for your help!

#12

nvm! figured it out. stupid mistake, had to assign a drive letter.

#13

So i edited the config.ini file, adding these lines to the bottom of the entire file (which is all commented out).

setenv max_freq_a73 “1908” # 1.908 GHz (overclock)
setenv max_freq_a53 “1992” # 1.992 GHz (overclock)

I remounted /flash as you hd recomended after making the change.

Upon booting into the device, the clocks remain default (as discovered through commands:

a53

cat /sys/devices/system/cpu/cpufreq/policy0/scaling_available_frequencies

a73

/sys/devices/system/cpu/cpufreq/policy2/scaling_available_frequencies

What could be going on? Am i inputting the command improperly? Any help would be appreciated

Thanks

#14

You have to remount /flash before you making your change.

#15

With micro sd in n2 ,

First : run remount command given by you earlier in this thread

Second : remove microsd from n2, place in windows pc, open coreelec partition (assign drive letter in windows disk management to access)

Third : access /flash/config.ini

Fourth : add two lines above (setenv) at bottom of all comments (in notepad++). Save.

Fifth : safeley remove micro sd from windows 10 pc , place in n2.

Sixth : boot the n2 - All set.


Is this all correct? If not am I missing anything? Do I need to remount again?

Thank you!

#16

No.
If you change it in windows then you don’t need to remount on N2 so you can skip the first step.
But instead you can power off your N2 before remove sd card.

#17

Thats where im stumped…

I did that and the frequencies are reporting default. When I take the sd out and put it in the pc, and access the config file, it does in fact have the two setenv lines at the bottom.

Is opening / saving the file in notepad++ the issue? What could be going on?

#18

Could be. Notepad++ never failed me, but read report that others had problem with it.
You can check your config.ini on the N2 with
cat /flash/config.ini
or
nano /flash/config.ini

#19

Here is what shows…

Is it not processing?

#20

I guess you don’t need setenv before the speed settings