Passthrough digital audio not working - non obvious fix

So my old libreeelec on my odroid c2 was having issues (which turned out to be a corrupted database, but that’s another story). As part of the troubleshooting I took the opportunity to move to coreelec instead.

Was using the same box, to the same HDMI cable, to the same amp. But for the life of me I could not get digital audio passthrough to work. No matter what audio settings I tried in Kodi the amp just kept saying pcm signal.

I was sure all the audio settings were identical to my old libreeelec where it was working fine. I searched these forums and found a few instances of similar problems but they all just ended with silence, or a “nevermind it’s working now” with no explanation of how.

So then I stumbled upon something in the VIDEO settings, not the audio settings. “synch playback to display”. If you highlight it it mentions in the help text at the bottom of the screen “audio passthrough will be disabled if this is selected”. Which it was by default on my fresh install. Unticked it and passthrough came back in all its digital glory.

Posting this to hopefully help the next person (or future me on a fresh install when I forget and come searching)

3 Likes

Moving this to HowTo’s as I’m sure it may prove useful for some people.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice