Please add the dtb for using s905L2B&3B soc's tvbox,such as mgv2000、zte b860av2.1a\m\t、e900v21e etc,thank you guys verymuch!

i am a chinese guy,there are so many s905L2B&3B TVbox users in china ,but there is no dtb for these devices,that is a big problem,i hope you can help us to solve it.
in my opinion,the dtb for it is gxl_p211 or gxl_p261.
i really want your help,please!

some pics for these devices!

Without any UART debug log any support is useless.
Do none of the provided DTB work? As it’s GXL please only use CoreELEC 19 Matrix RC2 for the tests.

thanks for replay,there is a forum discussed the same question,here it is.

And there is the dtb file extracted from Android firmware,but the vision of the ANDRIOD is 4.4.2.0,i don’t know that if it is useful.

Yes, minimum Android should be 7.1.
At least the bootloader should be updated.
CE-19 does not work well on bootloader Android < 7.1

how to upload files,here is the dtb file extracted from andriod 4.4.

so the problem is andriod’s,not the dtb’s?

But there are so many tvbox that used s905l and the andriod version is 4.4.0 could be used normal,why?

Because in the bootloader are closed source blobs included from Amlogic. Bl30, BL31, BL32,…
And these need to be compatible with Amlogic 4.9 kernel. Our experience shows clear since Android 7.1 the blobs do match with this kernel version.

Project 9.2 with kernel 3.14 is not active development anymore and will be EOL on end of this year.

So what the problem is?
if the tvbox with s905l2b&3b soc need Android 7.1 to be compatible with Amlogic 4.9 kernel,why these boxes can be running old Android 4.0 ?
how can i slove the problem?

i need the way, what is the first thing i should do?

You have several options:

  1. Update your device to Android 7.1
  2. Install CoreELEC 9.2.8 (Amlogic, not Amlogic-ng), which is Leia (Kodi v18) based. But it’s EOL, and will not have future updates.
  3. Get supported devices.

thank you for reply!
i installed the CoreELEC 9.2.8 or CE-19 , but it dosen’t worked, it is stoped the frist screen.

i tried all the dtb files, but they are no use.

Then you need to at least provide a UART debug log, as Portisch suggested.

how can i get the UART debug log?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice