Problem with T95Z Plus + CoreELEC 8.95.4.3 + Booting


#1

At first, sorry for my bad english.
Problem:
When my box is booting and the receiver or tv is in standby or off, the video resolution is wrong, and the tv switch from “Just Scan” (LG TV) to 16:9.
When the tv or the receiver is on and i restart the box, i can use Just Scan at the tv and everything is fine.
How can i solve the problem?

I forgot, Box have 3GB DDR4 Ram and 32GB Rom.


#2

This is the expected behavior.
CoreELEC tries to identify the modes your TV/AVR combination is able to display using the EDID information.
This is only sent by your equipment, when everything is already switched on, of course.
If no EDID information is given, the resolution/refresh rate is falling back to a failsafe configuration.


#3

Understood.
Is there a way to disable that function in the software?
It’s only needed for the first start of coreelec and someone should implement that for a next version of coreelec.


#4

You could add something like the following to your advancedsettings.xml:

<videoscreen>
<screenmode>00192001080060.00000pstd</screenmode>
</videoscreen>

Keep in mind to use a resolution/refresh rate that can be displayed on your TV/AVR combination, or you end up with a black screen after booting.


#5

Hmm, that don’t work.Box is booting as always.
Can you tell me the correct path to save the file?
I saved the file in /storage/.kodi/userdata
Do i make an new file or just modify the one that exist in /usr/share/kodi/system and save it there in the other path?


#6

Would it be of any benefit to have the ‘failsafe’ value changed to the current value after booting the OS?
In that way would the correct value be present on subsequent boots, even if the EDID info was late?

Just a thought …


#7

This is the right path, but if you didn’t have an advancedsettings.xml before, you need to wrap an <advancedsettings> tag around your settings.
So it should look like this:

<advancedsettings>
  <videoscreen>
    <screenmode>00192001080060.00000pstd</screenmode>
  </videoscreen>
</advancedsettings>

@JohnBoyz:
This wouldn’t help, if you switch your box to another TV with less resolutions and bad EDID information.
You would end up with a black screen again.


#8

What do you mean?
I make an advancedsettings.xml.
I copy your text in it, with textpad.
I save the file in /storage/.kodi/userdata,
That’s all i think, or not?
I have tested now again, no success.
Box is booting as alwas with wrong video solution.


#9

advancedsettings.xml (125 Bytes)


#10

Is the same like my.
I tested it, no success, box is booting as always.
It seems the box (coreelec) ignore that file.


#11

Did you just copy the text from @TheCoolest file into yours or did you copy the whole file to your box?
Text files created in Windows won’t work correctly in linux.

I can guarantee, that CoreELEC doesn’t ignore the file.
But I’m not sure, if the failsafe mechanism has a higher priority than the entries in this file.

Are you the infinity4 user at Kodinerds?


#12

I have copy the whole file.
Yes i am infinity4. :slight_smile:


#13

Okay, now I have a better picture of your setup. :wink:

At Kodinerds you are writing, that your whole hardware (TV/AVR/AML Box) is being switched on/off automatically using your remote controlled power adapter.
That’s probably not the best idea, because your T95Z box boots a lot faster than your TV or AVR.

You should really consider to at least keep the T95Z powered on.
The power usage is not very high, and you won’t loose the configured resolution/refresh rate anymore.

EDIT:
Regarding the advancedsettings.xml, take a look at this thread at Kodinerds - it was also mentioned in the “Nerdsletter” and was proven to work. But in the end, these are the same settings in the advancedsettings.xml, you’ve already tried. At least it’s written a bit more detailed here:


#14

There is something happen.
When i start the box with the advancedsettings file, there is only one resolution in the system settings, 720x480p and i can’t change it. :confused:
Is there no help for my problem? :frowning:


#15

Update to 8.95.5.


#16

And that helps with my boot problem?


#17

If you read the release notes, you’ll see that we reverted the kernel back to the one used in 8.95.3, which didn’t have any resolution/refresh rate issues.


#18

Hmm, my box say at start, there is an update, but how can i start the update?
Automatic Updates = Auto
And more important, is the network problem also fixed with this release?
I have such an box with no speed at wired network adapter with the old releases.That was fixed with the 8.95.4.3 release.


#19

The Ethernet problem wasn’t addressed in this release. We did what we could with it, but if it’s still not working for you, then I suggest you get a USB to Gigabit Ethernet adapter.
If you have updates set to auto, then rebooting the box should initiate the update.


#20

With the 8.95.4.3 release my Ethernet worked fine.