PVR Manager refusing to start after 9.03 update

Hi, after I did the update to CoreElec 9.03, TVH refuses to start.
Any idea? I did disable and enable vor TVH service, but still no working…
On TV I have the message “PVR Manager is starting up” but nothing happens.

Here is the log:
2019-07-04 22:39:18.630 T:3652109104 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to
2019-07-04 22:42:06.705 T:3910136624 ERROR: Previous line repeats 16 times.
2019-07-04 22:42:08.638 T:3652109104 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to
2019-07-04 22:47:11.388 T:3516920624 ERROR: Previous line repeats 30 times.

I was messing about with a new build of 9.03 yesterday and came across something similar.

I didn’t analyse it much though and installed this version of the TVH service, which worked fine.

As soon as I reverted back, it all stopped working.

I reinstalled TVH service and client, but still same problem…
Everytime, after reboot, I have this error message.
“Failed to start Load Kernel Modules”

I did a fresh install of CoreElec 9.03, from USB stick, no addon installed, but same error after booting.
“failed to start Load Kernel modules”.

Here is the log after this command :“systemctl restart systemd-modules-load”

Active: failed (Result: exit-code) since Fri 2019-07-05 09:45:02 EEST; 22s ago
Docs: man:systemd-modules-load.service(8)
Process: 5386 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 5386 (code=exited, status=1/FAILURE)

Jul 05 09:45:02 CoreELEC systemd[1]: Starting Load Kernel Modules…
Jul 05 09:45:02 CoreELEC systemd-modules-load[5386]: Failed to insert ‘amlvideodri’: Exec format error
Jul 05 09:45:02 CoreELEC systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Jul 05 09:45:02 CoreELEC systemd[1]: systemd-modules-load.service: Failed with result ‘exit-code’.
Jul 05 09:45:02 CoreELEC systemd[1]: Failed to start Load Kernel Modules.

Could be a corrupted img download. Try re-download and install it.

@Gabriel which file did you download so I can try this myself.

1 Like

This one
Taken from here:

Before wasting time with this. please tell me exactly what to do after I burned this image with Rufus.
I just entered the usb stick, keeping pressed button until CoreElec logo appears.
After that, it starts a new version of Kodi, which asks me for addons, and anything else, like a new and fresh install.
But, if I take out the usb stick and boot, same old installs appears, so I need to know how to install directly to box storage,

Did you copy the correct dtb to the root folder and rename it?

1 Like

I took this file from usb stick, in the folder device trees : gxm_q200_k3_pro.dtb
I renamed it dtb.img

With new stick inside box it’s booting good version, no errors…
But when I take stick outside, old version with errors comes true…dtb

Not sure I understand this, can you explain better?

1 Like

After I burned an usb stick with Rufus, using new image 9.03 of CoreElec, I put it inside box, on booting port.
The box starts perfect, (with stick inside) without errors, and a new kodi, without my settings(addons, etc.)
If I take out the usb stick and reboot, the old version (with errors, and all my settings, starts again).

I mean : Installing to internal, sorry I forgot terms…
How to install to internal, this is my question.

Later edit:
I finally managed to do, I did a search here and I found the command installtointernall, from putty.

Well, after 30 minutes of waiting, it seems that “installtointernal” is not working, or something like that, I thought it shoul restart box after finishing the job, but no reboot happened.
I need to find a way to check if this command still working.

Maybe that’s because you have to type yes like the instructions on screen tell you and not just the letter y.

1 Like

How dare you put in quotes how exactly it is suppose to be typed out :stuck_out_tongue: In fairness I done the same thing typing just “y” about a week ago installing coreelec on an old s905x box i had

Also note that this will overwrite your current install, it will be a clean install again.

Well, as usual, you let me without words…
I did type “yes” and now it;s backing up things…

Same situation here. Coreelec 9.0.3 broke my PVR. It worked before, it just got break after the automatic update. My device is a Mecool K1 plus.

It is no good saying to us something doesn’t work without providing a debug log at the very minimum as we can’t help you or others without it.

So far I have 9.0.3 only on TVH-client environment, and all seems to work fine so far. Sadly cant test server yet ( TVH-Server environment’s have unfortunatelly also Pi clients apart from Win and Odroid’s, so I am waiting for LE to be able bump to Kodi 18.3 on all clients at once).

On-screen information while booting:


log-2019-05-01-20.05.00.zip (138.6 KB)

Error from TVH-server while trying to play a channel from my laptop using VLC:

After reinstallation from zero, I managed to make it work again, but with few minor problems…
One is very annoying, after reboot it takes almost 1-2 minutes to start playing a tv channel.
Second, could be related, I tried to install an addon from a repository, but it says no network available…
But the network works, I have a weather addon that is updating…