PVR Manager refusing to start after 9.03 update

This log you have provided is for a LibreELEC 9.0.1 release and not CoreELEC.

I’ve got full debugging enabled, and those are the logfiles which are located in ‘logfiles’ folder.

Anyway, used the automatic upload tool from CE settings:
(second option, with kodi crash logs fails).

Second way: I did a cat /storage/.kodi/temp/kodi.log | paste

I can’t find any system log or related. I can provide any specific log that you need if you can tell me where to find them.

dmesg.txt (61.8 KB)

systemctl status system-modules-load.service
systemd-modules.txt (1.0 KB)

journalctl -xe
journalctl.txt (83.0 KB)

Ok, I understand the importance of a log, the source is very important, but, please, can someone direct me in the right direction, regarding my question?
It’s really annoying to wait 2 minutes every time I start the system…
Could be problems with DHCP? Or with the network? Who can tell?

It looks like you have had a bad flash, I have just tried a clean version of 9.0.3 on S905X and have tried rebooting with no dvb drivers enabled, tbs enabled and latest enabled and can not reproduce this bug.

Was you installed on interneral or sd card? Can you try to just dump the update image in your update folder and reboot and see if it fixes the issue.

I have it installed in the internal NAND. Tried the update but didn’t solve the issue. Same situation.

I think I will try a fresh clean installation from sdcard…

Yes, I did the same thing and it’s working now.
With the exception that after reboot, it stays almost 2 minutes for a tv channel to start…
I am just waiting for you to install from sdcard and confirm…

@Gabriel, please attach logs to check the reason of this 2 minutes delay…

Flashed a clean image in my sdcard.

First thing that I’ve tried was to restore a backup from my old configuration using the CE backup tool. But just after have restored it, same error showed up.

Soft reset (settings by default) solved the issue. So I’ve started configuration from scratch, but just copied my old tvh server addon data and oscam addon data just by copying the folders. And it is working right now. I don’t know what caused the issue but I guess that we will never know.

Thank you very much for your support.

PS: @Gabriel I don’t have such a delay. I can watch any tv channel just after boot up just with a couple of seconds of delay.

You are right. Here is my log, exactly after reboot…
log.txt (26.2 KB)

In case this helps, I noticed that whenever I try to install a repo, I have this message : “couldn’t retrieve directory information. this could be due to the network not being connected.”
But if I write the link on a computer browser, it;s working…

After 2 days, and after uploading the log, as requested, it seems my problem is unsolvable…
I am very enthusiastic about CoreElec, and tvheadend and Kodi…
But, if this issue is unsolvable, I will let it so…

Devs also have weekends sometimes :wink:
I don’t see nothing related in logs.
It looks like network issue. Try to set 10 seconds “wait for network” in CE settings and check if it solves your issue.
If no, you can try to enable debug logs for video and for A/V sync, reboot and upload both kodi and dmesg logs

Sorry, I did’nt want to sound like this…
Anyway, I enabled in the Coreelec addon setings the wait for network setting and put 10 seconds, but the delay after reboot was still 3 minutes.
Unfortunately, I don’t know where the file is located, I could try to modify from ftp connection, rapidly…

Debugging via Settings->system->logging
Logs - via ssh
dmesg | paste
cat /storage/.kodi/temp/kodi.log | paste
And send links from commands above


Dmesg log is absent. Please upload it also.
In kodi log still 2 minutes gap… Still looks like dns or network issue. But I don’t see reasons

Sorry for delay, here is dmesg log.

Don’t see any reasons for issues in log
you can try to reinstall again on different sd card with minimal addons configuration(only what you need to test issue). If still issue, than update to latest nightlies. There were some update in nightlies for AVL6862, may be it somehow related issue.
If still not solved than try to clean install latest nightlies on this SD card

I am afraid to to that because I will lose all my settings… like it happen last time.
Is there any way to backup my actual settings?

You can find backup menu in coreelec settings
Also some guides for tvheadend.

And as I said you can try to do it on different sd card for tests

Thank you very much for your help, which is more than complete.
I will try your howto and keep you informed.