PVR Manager refusing to start after 9.03 update

It’s not my howto, but I hope it still works :slight_smile:

After a lot o research, I found a way to create a backup and restore all the settings (except shortcuts for video addons on Kodi interface).
Unfortunately, the delay of 2 minutes it’s still there, so I have to start again from zero, to do all the manual installation for addons and anything else…

Here is what I did to backup all
After connecting with Putty to SSH, I wrote this command (tar cpf storage/backup/$(date +%d-%m-%Y_%H:%M).tar storage) and after a while a, 2.6 gb file was created in the backup folder
I copy it to another usb stick, and did a fresh install from usb stick created with new CoreElec image.
Then, I copy the tar file, back to internal, in the backup folder and antered the restore command (tar xpf storage/backup/20190715120240.tar)

After that, all my tv channels, addons, and anything else where in their places, exepting interface setting, and shortcuts from kodi frontpage.

Now, I am looking for another CoreElec image, beta, to test if the delay still exist.
I am not sure which one to choose from nightly builds… which one should be for Kiii Pro?

In kodi debug try to enable other components like curl, ffmpeg and maybe something else to get more detailed picture what is happening on a system.

CoreELEC-Amlogic.arm-9.1-nightly_2019xxxx-Generic.img.gz for clean install
CoreELEC-Amlogic.arm-9.1-nightly_2019xxxx.tar for update

I installed a nightly built (CoreELEC-Amlogic.arm-9.1-nightly_20190713-Generic.img.gz) image.
All is going fine, except old problem (3 minutes delay after reboot).
During this delay, I have message from HTSP Client "No free adapter available:.

I enabled other componentes in kodi debug, but it’s far away for me to interpret what is written there…
How to make it visible for others ?

After reading the log, it seems that my problem is not exactly described…
here are the lines, and if notice the time, it takes 2 minutes to open a channel.
Can someone direct me where to find the clue?

2019-07-17 22:59:52.000 T:4094383280 NOTICE: VideoPlayer::OpenFile: pvr://channels/tv/All channels/pvr.hts_1582530859.pvr
2019-07-17 22:59:52.001 T:3813667632 NOTICE: Creating InputStream
2019-07-17 22:59:52.003 T:3813667632 NOTICE: Creating Demuxer
2019-07-17 23:01:53.354 T:3813667632 NOTICE: Opening stream: 1001 source: 256
2019-07-17 23:01:53.354 T:3813667632 WARNING: OpenStream - Unsupported stream 1001. Stream disabled.
2019-07-17 23:01:53.354 T:3813667632 NOTICE: Opening stream: 1002 source: 256
2019-07-17 23:01:53.354 T:3813667632 NOTICE: Finding audio codec for: 86016
2019-07-17 23:01:53.362 T:3813667632 NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder mp2
2019-07-17 23:01:53.363 T:3813667632 NOTICE: Creating audio thread
2019-07-17 23:01:53.363 T:3581547312 NOTICE: running thread: CVideoPlayerAudio::Process()

In Kodi debug enable few other components like ffmpeg, curl, … to get more detailed picture.

Yes, I already did that, but I cannot understand it, yet…

You shouldn’t posted here?

I wasn’t sure that the command above work also for this log ( dmesg | paste and cat /storage/.kodi/temp/kodi.log | paste
Here is the content of libcURL, ffmpeg, Audio component, Video component, audio/video timing and PVR:

The log is taken just after reboot and after 2 minutes delay, when the channel starts to play.
during the 2 minutes, in tvheadend status is testing…

No chance for me?
All I have to do is to wait 2 minutes after reboot…
No problem I don’t reboot often… I understand when some errors cannot be resolved…
Intriguing is that all this appeared after I updated to 9.03…

Kodi still doesn’t have any more DEBUG informations. So it is hard to speculate what is going on if no one saw such problem before.
Do you have ssh terminal at hand? Can you restart Kodi to see if same problem occur in this case?
systemctl restart kodi

Yes, I did the restart via SSH , and happyly I can affirm that image came after 10 seconds…
So, the problem is not here…
(I did this 2 times, to be sure).

So it happens only after boot.
Go into Kodi settings, enable Debug log and select curl component. Then reboot the system, wait until you get channel playing and post kodi log again. First look inside and check if you see CURL messages.

You mean libcURL library (HTTP(S), DAV logging? (sorry, but I don’t know what exactly is this CURL)…
Here is the output after reboot and channel start with dmesg | paste:


Log still doesn’t tell anything useful.

Maybe this pause of 121 seconds…

[ 21.526217@3] amlogic-dvb dvb.51: DVB: adapter 0 frontend 0 frequency 0 out of range (950000…862000000)
[ 143.740239@2] vfm_map_store:rm default

Maybe @afl1 would know?

Cant comment vfm map, but the DVB message is quite common when DVB Tuner inicializes (at least I seen it during boot of my router with my dvb tuner)

[   73.560279] usb 4-1: DVB: adapter 0 frontend 0 frequency 0 out of range (174000000..862000000)
[   74.143477] mn88473 9-0018: firmware already running
[   74.310813] usb 4-1: DVB: adapter 0 frontend 1 frequency 0 out of range (42000000..1002000000)

Sorry for being so insistent, but this 2 minutes delay are becoming very annoying…
Anyway, I enabled another debug component option (PVR) and here is the result:
As much I can understand, here must be the problem:
2019-07-23 14:18:04.134 T:3590042416 NOTICE: Creating Demuxer
2019-07-23 14:20:54.674 T:4092256272 WARNING: Skin has invalid include: contentpanelslide
2019-07-23 14:20:54.676 T:4092256272 ERROR: Control 101 in window 13001 has been asked to focus, but it can’t
2019-07-23 14:22:04.656 T:3590042416 NOTICE: Opening stream: 1001 source: 256
2019-07-23 14:22:04.656 T:3590042416 WARNING: OpenStream - Unsupported stream 1001. Stream disabled.

I mean, when creating demuxer and opening stream 1001…