Reboot loop on VIM2 update to 9.20

I have been using CoreELEC 9.0.2 I believe, on a Khadas VIM2 Pro in the EMMC for about 6 months. It has been working perfectly.

The other day I noticed it updated Coreelec to 9.2.0 and after this it keeps rebooting. The Khadas logo will pop up for a bit, followed by the new CoreELEC logo with the version number displayed in text in the upper left corner. It will stay on this screen for about 20 seconds then reboots again. I cannot SSH into it nor seem to halt this process.

I wondered if it might be a problem trying to upgrade while running in the EMMC.

Anyone have any ideas?

Same here.
Almost at least : latest android image in emmc (05/19).
CoreElecon sd card.
1st boot: usual partitioning then reboot.
Reboot. Display version number on the upper left corner.
Then reboot.
Used dtb :kivm2 (not vtv). It’s a vim2pro max.

Just to confirm the problem is with 9.2.0.
I just flashed 9.0.2 on the same SD card. Used same dtb.
CE works : intialized, rebooted fine. Populated my movies from a samba share. Played one.All successfull.
So the problem is with 9.2.0.

End of test : CE dd’d the update. I left the auto update and rebooted. Just to test.
And it worked…?!
I’m now in CE 9.2.

This is a problem quite a few people encountered when upgrading to 9.2
The problem was created because the branch of kodi changed and it rendered some Addons incompatible. The solution is to disable all of your addons before upgrading and then renebling them one by one until you identify the problem addons.
A clean fresh install with clean fresh install of all of your addons is the other solution.


Sorry but that answer (which reappears at each kodi version bump) does not explain anything.
I was on a clean install.
Virgin /storage from the start.
There’s something else in the air…

Its what worked for me when I encountered these issues upon upgrading to 9.2, and I am running a VIM2. It was the first time I had serious issues with an upgrade and a fresh install was the solution for me. However your experience maybe different because I note that you skipped a few stable upgrades on your way to 9.2 which often complicates matters - it probably was a bootloader bump which caused the problem for you.

If you read back through the 9.2 discussion thread you will see this issue been discussed and the solutions proposed.


Thks 4 the explanation! Although the ins and outs still escape my understanding.
The bootloader bump seems to be a sensitive tip.
My Khadas was sleeping for months and I did not follow the threads regarding CE.

Btw, could you pinpoint a thread regarding the kahdas remote? Any way touse it with CE?

I only have the VTV remote, but as far as i am aware both Khadas remotes are supported out of the box - they just need enabling by issuing a single command. I will see if I can find the command later.


Very kind of you!
I will further explore the matter.
Thanks for starters!

This Thread : Remote does not work on KVIM 2.
But my remote’s batteries are dead! Said my khadas was sleeping for months…

Yes you found it.


Actually, I did not.
What indeed worked :
Fully operational now!!
Have a nice week-end!

Where can I find CoreElec for KVIm2 ?

I am not able to find the dtb in the latest images.
Maybe I am downloading the wrong image ?

Please advice.


You have it here: Release CoreELEC 9.2.8 · CoreELEC/CoreELEC · GitHub

Just use the non ng image and the kvim2 dtbs will be there.

1 Like

Thanks, trying this but sad to know the its EOL for S905/912 :frowning:

No more updates or security fixes and also it will stop working it add-ons in near future when add-on moves to newer python.

It is not able to play H265 - 8bit audio :frowning: sometime it works and sometimes it just stops outputting the audio after few mins of playback.

Anyone have this issue ? Also Vim2 does not have Fan control as newer version of vim2 have fan header which is controlled by gpio similar like GS King X

NO Audio output at all on any of the movie files. Tried almost everything to see what is wrong, I will enable debugging to see whats going on in the background and dump it somewhere so someone can look into it.