Report about Amlogic S905X4 HK1 RBOX X4

Based on my Android dtb it uses something called rgmii which I speculate might not be available in this kernel. However I am more concerned that meson6 not meson8 is being called.

A person on freak tab, acknowledge that his gigabit Ethernet on his box was working also under CoreELEC.

That’s rather vague. Can we have a link to that post please.

Joined to report, otherwise Clark would tell my parents.

Installed CoreELEC on June 2nd using that same day nightly (I think later it was updated to June 3rd release), no issues but still didn’t shutdown properly using the file at post #40, seconds later it restart just like on Android.The above happens whether HDMI-CEC is enabled or disabled. On that note, if there’s a proper option on CoreELEC that disables HDMI-CEC, the tv turns off when I power off the box. LED and ethernet works properly. At 3840x2160 CoreELEC seems to run only @ 23.98, 24, 25, 29.97, and 30Hz, it doesn’t work between the 50s-60Hz. Android runs fine by default at 3840x2160 60Hz. At 4096x2160, it will only work at 23.98 & 24Hz. Cannot comment on the remote, I use a keyboard, but Clark did mentioned that it worked.

Thanks you devs and contributors.

Could one of of you copy your Android /dev/dtb file so I can compare with my h/w? I feel it is a timing issue for rgmii since occassionally I do have the Ethernet lights stay on and the IP shows as 169. class.

I extracted this earlier from the firmware of HK1 RBOX X4 since my box hasn’t delivered yet.

1 Like

I tried eariler and got a black screen but the freaktab firmware is newer than the one on my box, from December I have the RQ3A.210805.001.AT.eng.user.20211221.232716release-keys<211221_2324>

I did compile that file which is in the CoreElec build system for linux and it doesn’t work either.

Tell me how to get the dev/dtb file from Android. I think years ago, there was an app that extracted all of that data, but I forgot.

Thank you, Retro. I won’t tell your mother now. :slight_smile:

1 Like

The easiest way on the HK1 is probably Extracting .dtb file from a running Android OS - #2 by Sholander

The dtb file from that location has “0” bites. HUMMMMM…

I have the same firmware.

Extracting a Device Tree

1 Like

Our device is running Android 11. Does these instructions still work?? It says Android 9 and lower…

Here is the device tree using the method that Betatester showed…
dtb.img.gz (19.2 KB)

dtb.img (256 KB)

Dtb from transpeed s905x4 4g 64g, Factory Android from emmc
I hope help it
dtb.img.gz (19.1 KB)

Thanks. It generates the same sc2_s905x4_ah212.dts source so I think the devices must be similar.

You could have copied the 0 byte file once you get SU access things would have changed.


@Titomane yours is different it is an sc2_s905x4_ah224 just as shown on freaktab

1 Like

Will load coreelec If I put extracted DTB at sdcard root renamed as dtb.img?

Unlikely, that is for Android running a different kernel.

1 Like