Report about Amlogic S905X4 HK1 RBOX X4

Android kernel is same as your tvbox 5.4.125 if can help.
My Tvos build (fw) not
RQ3A.210805.001.A1.eng.user.202111227.232310
release-keys
I found specs at deviceinfohw
http://www.deviceinfohw.ru/devices/item.php?item=563181

That is the Android kernel. CE nightly is targeting a different kernel 4.9.269

If I flash the transpeed with the HK1 firmware on Freaktab will that change the kernel to 4.9 from 5.1?
If so is it worth doing or am I better to wait for the Nexus build with 5.1 kernal support ?

Updated with the OTA file a few weeks ago using the Updater App included in the HK1 RBOX X4, and just compared the dtb file with Clark’s it’s the same.

@Portisch
My box finnally delivered and I soldered UART (baudrate is 921600 in case anyone else want to do this), the u-boot log, default env, dmesg and partition layout are too long so I have to paste it on my blog instead

I noticed the SoC do more things before u-boot is even loaded than previous SoCs (I only have S905 and S905L for comparasion, but both those two get into u-boot after less than 20 lines of Amlogic proprietary codes)

There’s no module broken according to dmesg

Nothing too special in the default envs

The partition table is the most fragmented one I’ve ever seen. 29 in total. After dumping, I find all _b partitions (vendor_boot_b, dtbo_b, odm_ext_b, oem_b, boot_b, vbmeta_b, vbmeta_system_b) have no actual content (all 0x00 from beginning to end). I can send part dumps if you need them.

A wierd behaviour is that 4 frambuffer devices were created (/dev/fb0, /dev/fb1, /dev/fb2, /dev/fb3) instead of 2 I saw on old devices (hdmi + cvbs). I’m guessing this is because the box is basically a slightly modified ah212 reference board and on that board there would be LVDS and eDP outputs and these were not cut on actual products.

Seems your device supports Android seamless updates then :slight_smile:

Can’t believe these no-brand products would support seemlingless update when even OTA updates are practically non-exist after they were dropped into market. Guess the vendor just keeps most of Amlogic’s source un-touched.

No, we need nothing for now. A generic DTB should be included in next tomorrow nightly. A fix for VC1 playback on SC2 platform as well.

3 Likes

A fix for the VC-1 codec would be awesome. thanks

Edit: adding the power option to reboot to Emmc would be perfect.

I rebuilt from git and used the generic image with the new dtb that gets created and I still see the light on the Ethernet port go off while CE boots. I wonder what my box is missing?

Your device is “to new” for 4.9 kernel, maybe.
It says it’s sc2_s905x4_ah224. The newest in 4.9 kernel sc2_s905x4_ah219.
So maybe it works or maybe not.

1 Like

The 06-08 CE19 nightly already includes the sc1_s905x4_1gbit dtb so you don’t need to build by yourself.

About the ethernet port, does it work OK on Android? If so, does it not work after you reboot to CoreELEC from Android with everything not touched?

It is maybe needed to split 2g/4g for sc2 so here are two new dtb for CE:

It is based on sc2_s905x4_ah212, please have a try and test.

Tested on my box after already configured and up and running with sc2_s905x4_1gbit.dtb, I’ll try to do clean install tests with these two dtbs later:

  1. sc2_s905x4_4g_1gbit.dtb:
    works just like sc2_s905x4_1gbit.dtb, no new problem is introduced
  2. sc2_s905x4_2g_1gbit.dtb:
    It boots. free and /proc/meminfo and system information in kodi both reports the box has 2G ram now

There’s also a wierd not-that-important issue existing. The kmesg is outputed to framebuffer and both it and stdout of init now always blink and disappear. I’m guessing this is because all kmesg are printed to fb0 during init and you have a temporary fix that’ll clear it once in a while thus it is blinking.

Edit: appending quiet to kernel command line does not help either. The kmesg is always there during init and can’t be turned off until fbcon is unloaded after init

Tried 0608 generic sc2_905x4_1gbit.dtb blackscreen

I’ll wait until ah224 is released

Thanks

I tried both of those new dtb files and still no Ethernet on my HK1 eth0. The same scenario as before the light stays on on the switch during the boot, during the update today to the nightly and after it scrolls through the text behind the CoreElec boot screen, I see the switch light turn off and then the Kodi home screen shows. I then connect eth1 and ssh.

2GB dmesg [ 0.000000@0]d Booting Linux on physical CPU 0x0[ 0.000000@0]d Linux ver - Pastebin.com
4GB dmesg 4GB dtb - Pastebin.com

When I use the 2GB version memory is reduced.

In Android iperf3 in Termux performs well on a 1Gb network with the internal port, better then my hub.

Maybe your box is actually using another board instead of the one others are using? This always happen on these on-brand boxes since you can’t even guarantee it’s made by one manufacturer

Mine has a green board, with a RTL 8211E ethernet PHY and a TFS5009 band pass filter

Maybe yours has a different PHY?

The box is very easy to take apart but be careful not to rip the WiFi antenna off the board

Here is my board. Imgur: The magic of the Internet

The ethernet PHY is the little black square between the white label ‘X4…’ below it and the long black chip above it with logo near the cylindrical capacitor. It’s too small and I’m afraid you can’t shoot it so you have to check the words on it with your own eyes

Also, the label on my board says ‘X4 4+32G+5235F E0117’. I think the last part ia the manufacturer period and yours is different from mine so there might be some components-swapping

@emveepee
The Eth PHY is JL2101 (https://www.jlsemi.com/support.html), but without drivers not supported.
Also your box has refurbished DDR3 ICs from 2013/2014. On pcb topside 2GB (4ICs), maybe on bottomside another 2GB…

Looks like the X96 nightmare continues :frowning: