Rewind and skip method don't work for many SD (not HD) video files

while forward, seek cursor go to -6 hours back
see pic (info about codec)

8.90.4 Amlogic 912 X92 device.

Try Settings, Player, Videos, under actions you can add or remove skip steps

there are all step enable. This is not what I mean.
Sorry for my english.
trouble with only few codec SD format (xvid, divx and others). All HD format works fine.
Now i back to 8.90.2 - all work fine!
I think in new version it was some broke for “old” SD codecs and formats…

Fact is, fwd and particularly rewind has never worked smooth in any Kodi version as long as I can remember.

There has been some attempts at smoothing it out when a user mentioned it,but mostly users are pointed at the skip method (which most devs use).

I personally have the opinion that ffwd/rwd serve a different purpose than skipping, but I have learned to live with skipping and had almost forgotten about ffwd and rwd until you mentioned it again :wink:



The same trouble with skip method

Really? Ow, that might be a bug of another sort.

I checked - the problem appeared in version 8.90.3

The trouble is happened with many SD (not HD) video files from torrents…
For example, please, check this file (~300Mb)

IMO, the problem is with the video container.
I tried playing it on my main install using Kodi and it had problems.

So I tried playing it there with VLC and it also had problems.

I changed the container format to MKV and the problems disappeared.

I play this example file via VLC 3.0.3 (win 10) - without any problem

Then maybe it is a problem with it on Linux. (my main install is Linux)
I also use VLC 3.0.3 Vetinari.

BTW, I only changed the container and not the video format for testing - took a few seconds.

Yea, I do it too (converted video).
Do it one, two, more times…It’s not difcult for me, but…
8.90.2 - no problem, 8.90.3 (and 4) - bug…

It is not only a CE bug is the point of my post because it happens on my main Linux install also, using the .avi file, but not using the .mkv file.

I understand you, thanks!
There are was new kernel base in 8.90.3 (OSMC Amlogic 3.14 kernel base *). maybe trouble in this item…

Maybe …

Hopefully someone else will be able to try it also to confirm what I find here.
I am using kernel 4.17.6

The bug is actual…

In English?

adamg, what do you mean?

what does “The bug is actual…” mean?

it is still not working
it is working

it is still not working