S905 - dvb-t2 AVL6762TA not detected

Hello, I have a box that feets pertect to dtb file: gxbb_p200_1G_100M_RealtekWiFi.dtb , except that it has a dvb-T2 with chip AVL6762TA, which is not detected. I have also tried gxbb_p200_k1_plus.dtb, and can’t find the dvb-t2. which dtb file do I need to put?
thanks.

P.D. I don’t mind losing the wifi capability

Perhaps the tuner could be recognized by CoreELEC if you prepare a dtb.img from the Android firmware of your device. Here in this forum I have seen the steps to do this but it has never worked for me. For this you will need to boot CoreELEC from a micro SD or USB flash memory and have Android installed in the internal memory.

Maybe someone from this forum knows more and explains it to us.

With Amlogic Tools 5.5.0 even dts text files can be viewed and edited of device Android image files.

Thanks cubimol, but the tv box don’t have Android installed yet, I did a ‘installtointernal’ two days ago

So you didn’t try it when booting via SD Card.

Are you 100% sure the chip in this mystery box of yours is not an S905D

Now you need to read an old post

The CE team memember who posted hasn’t been around for a while .

Hi kostaman, I have tread the old post and tried the gxl_p231_1g_sr2402_i2c_c.dtb archive; it doesn’t boot.

also, I have tried the DTD gxbb_p200_1G_ariva.dtb, from this post: ARIVA 4K COMBO SAT+TDT dtb.img help , and the dmesg | paste is:

http://ix.io/2ugp

I don’t know what is wrong.
thanks!

P.D. the box is this one:
image

I see the important part of your log.
Unfortunately your hardware being gxbb it is in the low priority list of fixes.

We have worked very hard to get the K1 Pro tuner to work with 4.9 Kernel and that took weeks of testing in eventually making it work.
More importantly i have the K1 Pro which makes it possible to test with multiple test builds in eventually making it work.
I currently have an old S905D 1gb/8gb Android 6.01 with a non working internal tuner using 3.14 Kernel.
No priority for the tuner to be fixed with 3.14 as development using NG crashes using 4.9 Kernel…
This issue takes priority.

Sorry but that’s how it goes with older hardware.
Especially if no Team CE member has the hardware to test.

48.811366@1] IR LIRC bridge handler initialized
[ 49.059496@0] dvb_meson dvb.50: Checking for Availink AVL6762 DVB-T2/C demod …
[ 49.479595@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.479609@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.479660@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.479665@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.479714@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.479719@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.479725@0] i2c i2c-1: dvb_meson: i2c wr failed=-11 len=3
[ 49.479775@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.479780@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.479831@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.479836@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.479889@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.479894@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.479899@0] i2c i2c-1: dvb_meson: i2c rd failed=-11 len=4
[ 49.479952@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.479958@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480010@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480014@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480067@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480072@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480076@0] i2c i2c-1: dvb_meson: i2c wr failed=-11 len=3
[ 49.480128@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480133@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480186@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480190@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480241@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480246@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480250@0] i2c i2c-1: dvb_meson: i2c rd failed=-11 len=4
[ 49.480255@0] i2c i2c-1: dvb_meson: attach failed reading id
[ 49.480262@0] dvb_meson dvb.50: Failed to find AVL6762 demod!
[ 49.480267@0] dvb_meson dvb.50: Checking for Montage M88RS6060 DVB-S2 demod …
[ 49.480329@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480338@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480396@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480401@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480453@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480458@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480466@0] m88rs6060_readreg: reg = 0x0 (error = -11)
[ 49.480522@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480531@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480584@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480593@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480645@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480653@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480657@0] m88rs6060_readreg: reg = 0x1 (error = -11)
[ 49.480710@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480715@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480768@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480773@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480827@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480837@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480840@0] m88rs6060_readreg: reg = 0x2 (error = -11)
[ 49.480844@0] RS6060 chip, demod id = fffffff5, version = fffffff5.
[ 49.480900@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480905@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.480958@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.480963@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.481013@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481021@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 49.481026@0] m88rs6060_writereg: writereg error(err == -11, reg == 0x03, value == 0x11)
[ 49.481080@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481086@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x2c
[ 49.481145@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481151@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x2c
[ 49.481207@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481217@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x2c
[ 49.481221@0] m88rs6060_tuner_readreg: reg = 0x1(error = -11)
[ 49.481224@0] RS6060 chip, tuner id = fffffff5.
[ 49.481228@0] Unable to find Montage RS6060.
[ 49.481238@0] dvb_meson dvb.50: Failed to find M88RS6060 demod!
[ 49.481246@0] dvb_meson dvb.50: DVB demod detection for i2c-1 (aml_i2c_adap1)…wetek-dvb
[ 49.481250@0] dvb_meson dvb.50: Checking for AVL6211 DVB-S/S2 demod …
[ 49.481308@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481313@0] i2c i2c-1: token 1, master_no(1) 300K addr 0xc
[ 49.481367@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481372@0] i2c i2c-1: token 1, master_no(1) 300K addr 0xc
[ 49.481423@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481428@0] i2c i2c-1: token 1, master_no(1) 300K addr 0xc
[ 49.481433@0] i2c i2c-1: i2c wr failed=-11
[ 49.481441@0] i2c i2c-1: avl6211_attach: failed=-121
[ 49.481445@0] dvb_meson dvb.50: Failed to find AVL6211 demod!
[ 49.481450@0] dvb_meson dvb.50: Checking for Panasonic MN88436 ATSC demod …
[ 49.481502@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481507@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x18
[ 49.481556@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481561@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x18
[ 49.481611@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481615@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x18
[ 49.481620@0] i2c i2c-1: i2c wr failed=-11 reg=10
[ 49.481625@0] dvb_meson dvb.50: Checking for Sony CXD2841ER DVB-C/T/T2 demod …
[ 49.481632@0] i2c i2c-1: cxd2841er_attach(): I2C adapter ffffffc02680b8e0 SLVX addr 6e SLVT addr 6c
[ 49.481683@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481688@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x6c
[ 49.481737@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481742@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x6c
[ 49.481790@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481795@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x6c
[ 49.481801@0] i2c i2c-1: dvb_meson: i2c wr failed=-11 addr=6c reg=00 len=1
[ 49.481850@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481855@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x6e
[ 49.481904@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481908@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x6e
[ 49.481958@0] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 49.481963@0] i2c i2c-1: token 1, master_no(1) 300K addr 0x6e
[ 49.481968@0] i2c i2c-1: dvb_meson: i2c wr failed=-11 addr=6e reg=00 len=1
[ 49.481973@0] i2c i2c-1: cxd2841er_attach(): invalid chip ID 0x00
[ 49.481978@0] dvb_meson dvb.50: Total DVB modules found: 0
[ 49.484578@0] dvbdev: DVB: registering new adapter (dvb_meson)
[ 49.485121@0] DMX: dmx0 irq:55
[ 49.485628@0] DMX: dmx1 irq:37
[ 49.486276@0] DMX: ts0 irq:51
[ 49.486346@0] DMX: ts1 irq:57
[ 49.486403@0] Meson DVB frontend(s) registered successfully.

Ok, I understand, if it helps, I attach the photo of the turner… perhaps there is a dtb just developed for a similar one.
Thanks!

MVIMG_20200814_111342|281x500

So, no other dtb file with this tuner to try?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice