S905X3 HDMI CEC Problem

hello. I installed many H96 MAX X3´s before without this problem. Now I got a box where android was reinstlalled to Android TV.
I just installed Coreelec ( tried both last Matrix stable and 9.2.6 Legacy) as always. But HDMI CEC is not working. Some people here in forum says that problem could be with android where hdmi cec should be enabled before changing OS to CE.
Maybe in this “Android TV” HDMI CEC was not enabled by default. Is there now some way hot to enable it? Only via reflash to Android or is is possible to edit something in bootloader to enable HDMI CEC? Is there some way hot to check on CE if HDMI CEC is working via commandline or so?
Thank you.

On Matrix set to enabled in Kodi input settings. Only a debug log from Kodi with libCEC component shows what happen.

Hello. All was enabled as in previous working boxes. Here is log:
http://ix.io/2SsL

Check your hardware, TV, cable and device:

2021-03-11 15:32:39.116 T:4878    DEBUG <general>: CecLogMessage - << Broadcast (F) -> TV (0): POLL
2021-03-11 15:32:39.116 T:4878    DEBUG <general>: CecLogMessage - << f0
2021-03-11 15:32:39.145 T:4878  WARNING <general>: CecLogMessage - Write: write failed
2021-03-11 15:32:39.145 T:4878    DEBUG <general>: CecLogMessage - << f0
2021-03-11 15:32:39.184 T:4878  WARNING <general>: CecLogMessage - Write: write failed
2021-03-11 15:32:39.185 T:4878    DEBUG <general>: CecLogMessage - >> POLL not sent
2021-03-11 15:32:39.185 T:4878    DEBUG <general>: CecLogMessage - TV (0): device status changed into 'not present'

Looks like no CEC connection at all!

Same issue was here:


Tried to log libcec in the same box on CE 9.2.6 from emmc. Tha same result.
Changed HDMI cable - still problem
Plugged older box - CEC working imediatelly

Seems like there is not problem in cable nor TV. Seems like this is problem of the box. Maybe as I wrote - something with Android TV installed before flashing to CE. Maybe Android TV changed something in firmware…?

I had a very similar problem with an X96 Max S905X2 box. HDMI-CEC worked with 9.2.5 but did not with 9.2.6 or Matrix 19.0.

The only way I could fix it was by upgrading the version of Android on the X96 Max to the latest version. I have no experience of Android TV. If OTA update is not available on the box then you’ll have to google for the latest firmware for your box and use something like the Amlogic USB Burning Tool or Amlogic Burn Card Maker to install the firmware.

I did not have to enable HDMI-CEC in Android, but I see no harm in doing it before running CoreELEC.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.