S905X3 + Linux + Server = drama. Inputs, ideas, please?

I feel a bit dirty to ask this question since you guys have worked so hard to get Kodi running so well on these boxes, but please, stick with me, it’ll make sense.

I have two boxes an S905X (X96) and an S905X3 (X96Max+) the X96 was my main box but I turned it into a Pi-hole when I was given a used Nvidia Shield. As I’ve been happy with it, I decided to get myself the X96Max+ to use it as a Plex server since I’ve been travelling a lot and need to access media when I’m away.

As of this writing, and as far as I know, CoreELEC seems to be the ONLY Linux distro that fully supports the X96Max+'s gigabit ethernet and USB 3.0. (Please someone correct me if I’m wrong about that) I’ve been coming here for a couple of weeks now, reading a lot and trying a lot of suggestions but I can’t seem to get it to do what I need, without bumping into issues.

The box just suddenly stopped accepting SSH connections at all. An error “ssh_exchange_identification: read: Connection reset by peer” kept coming up, regardless of where I tried to connect from or how many times I rebooted it. As Kodi had been disabled to free up resources I had to re-install CE from scratch. Again!

Can I get it to default to a terminal shell if I disable Kodi?
If not, why could possibly the SSH server simply stop refusing connections? Any way to avoid this from happening again?
Is there any other way I can access the box without Kodi and SSH?


TL;DR: Trying to use an S905X3 as a media server. CE is the only distro that supports this box’s hardware. Disabled Kodi to free up resources but SSH server stopped accepting connections and had to reinstall CE. Twice now.

I don’t have any knowledge to help you, but there are funhouse builds for S905X boxes you could try maybe

If you want to run a Plex server on the box why don’t you I install docker and then Plex server? I run this way on N2 and have on S905. Search the forum for chat about this. I’m assuming that docker is available for S905x3 CoreELEC when I say this because I don’t own a box with this chip.

1 Like

I do, that’s exactly what I do. I’ve had Plex running on a docker container for a while. That part is covered. The problem is that when I disable Kodi to free up resources the only way to manage the box is via SSH, but the SSH server twice now has completely stopped accepting connections, which left me locked out of the box and forced me to reinstall CoreELEC from scratch.

Apparently the S905X3’s SoC is only supported by >=5.5 kernels. Only the 9.2 nightlies seem to work.

Not really the subject to put here but why don’t you try a headless version of Armbian? If you ask in the forum there someone can probably recommend.

yep, I’m actually using Armbian on the X96, and my original plan was to use it again with the X96Max+, but as I say in my OP, CoreELEC (as far as I know) is the only Linux distro that supports this box’s components. So yeah, I could get Armbian on it but I’d have to sacrifice gigabit ethernet which is crucial since my internet connection itself is faster than 100M.

Besides, I haven’t properly tested it, but I’ve a feeling it doesn’t even support the USB 3.0 port. Technically I could get USB 3.0 gigabit ethernet adapter but then I’d lose that port which is meant for the external hard drive.

We are off topic here so have a search on the Armbian forums it would surprise me if there is not a working solution. Try it on an SD card and run some tests on the ethernet and USB connections speeds. If CoreELEC has it working I’m sure someone has moved it over to Armbian as there will be a lot of resource sharing between the 2.

No, I don’t think we are completely off topic here. I think the fact that I am using CoreELEC to try and get this server up and running when it’s clearly not the proper tool for the job is the main issue, but then again, I’ve been dealing with this issue for a few weeks now. I’ve read so many posts on both Armbian and this forum, and I’ve tried asking questions, but there doesn’t seem to be a solution other than sit and wait for someone there to decide to support this SoC.

Also, I wrote three posts asking on the Armbian forum about why CoreELEC has a DTB file that works for this machine and how one would go about porting it to Armbian and the posts simply vanished moments after they were posted without any warning or explanation.

As far as I can see it there are only two options: either I stick with Armbian and a crippled system or I stick with CE and have to jump through a lot of hoops to get it to work.

Right now, if I can get a shell on CoreELEC I can just type in commands with a keyboard without relying on SSH then I’m super happy.

SSH doesn’t just randomly stop working. It’s possible that your box is crashing.

Agree. I went through every suggestion I found online to the problem and not only none of them worked but nobody seems to know where the problem comes from. I think it is only with the SSH server since the Plex container was unaffected.

I think adding a shell to CoreELEC would not only make sense in a situation like mine but it could also be a great tool in case one has problems with Kodi and the SSH server went down for some reason.

What is the reason that the dtb file from coreelec wont work in armbian? Iam having the same problem with my x96 air, no GB support and wifi in armbian. In coreelec everything works, but its crippled by design, no package manager.

I want to install homeassistant supervised, but that’s not possible in coreelec, only the docker version of homeassistant (with no addons) works.

I think you’re barking up the wrong tree. Better to ask the Armbian devs why the hardware isn’t fully supported there.

You are correct, but i would like to use coreelec as OS for domotica…
I am only using armbian because it has a package manager. Coreleec is perfect and stable, i am only missing home assistant supervised for my Media / domotics server.

Iam not the only one.

I totally understand you.
Maybe the guys in the other thread are able to help you - looking at the posts they seem to be nearly ready.