[S905X3] X96Air_P2/P3 4/32GB 1Gbit Lan (How to config)

Yes, most recent but you can always google it…

I´m using SLIMBOX

1 Like

Thanks @Rootz, seems like I have been living under a rock so far, because I actually had no idea about all the stuff going on around Android TV.

So SLIMBOX is available as ATV and ASOP version. Which one do you use and why?

Just curious, because ASOP seems to be the way to go, since I am not interested in using any Google services. The plan is to use CoreELEC for any media stuff, but have Android available to possibly be able to use Zoom on that box together with a USB web cam.

I’m using ATV because IPTV app.
I think ATV its more intuitive and easy access for TV using. You can disable google services
Didn’t test ASOP version.

1 Like

Same here, on my boxes and N2 I prefer ATV version (with disabled GS) interface for my IPTV services, for looks and for general use. It’s much more intuitive in my opinion.
Not to mention ridiculous popup after every startup “Your Tablet is staring” on all other versions.

1 Like

I have just received my two X96 Air P3 4G/64GB boxes and I think I have bricked one of them. :frowning:

I have checked the stock firmware first to confirm it’s P3. The plan was to first replace the stock firmware with SLIMBOX before installing CoreELEC for dual boot, but this is what happened now:

I have burned the correct SLIMBOX AOSP onto a micrSD card and tried to install it, but every time I plugged in the power while pressing the reset button I just ended up in the stock recovery. I have tried several times, then I rebooted the box to the bootloader by accident, the “X96 Air” picture showed up on the TV but nothing else happened. I left it several minutes without anything going on, then I have disconnected the power and now the box is just dead. When I plug in the power, nothing happens, the front display stays dark and the TV only shows “No Signal”. When I try to plug in the power while the reset button is pressed (with or without inserted microSD Card), it’s the same, nothing happens, the display and TV stay dark.

Is that box dead now or can it be saved?

Is it maybe stuck at the bootloader now and if yes how to get out of it (though shouldn’t it display something in the front display and on TV when booting to the bootloader)?

I really don’t know what happened, because the update to SLIMBOX just worked fine on the second X96 Air box with the same (unchanged) microSD card.

BTW I do not have an OTG cable available, which is why I went the microSD card way.

Oh, and can someone please tell what the difference is between the CoreELEC-Amlogic-ng.arm- and the latest nightly?

Is anyone here using the latest nightly instead of the stable version?

You need to prepare a uSD card with Amlogic burn card maker with your vendor image.
Open the device and shorten the eMMC. You need to google about your hardware what exactly you need to do to unbrick it. Every Amlogic box can be unbricked! Good luck!

1 Like

The diffference between the two are essentially that the first is considered a stable build and the nightlies contain new features and bug fixes but may potentially results in some errors.

Nightlies are an opportunity to be at the cutting edge and report back issues to developers so that fixes can be applied until such time as another stable build can be released with great confidence for all users.

The differences are highlighted in the changelog at every new nighty release.

You can look through all the changelogs here but unless you are highly technically proficient then some will make no sense to the average user.
Just remember that if you choose nightlies then you must expect potential issues and should report them.

You can try a nightly and then revert back to stable if desired (and the same in reverse).

1 Like

@Rootz, obviously that Yandex Disk is not up-to-date after all:

Any idea where to really find the latest stock firmware for download?

So yesterday I have successfully installed the current stable version of CE on my new X96 Air P3 4/64GB. Everything seems to be fine, except the following:

I have downloaded the Big Buck Bunny short film from the Blender Foundation YoutTube channel to test 4K@30Hz and 4K@60Hz:

The 4K@30Hz version works as expected, but the 4K@60Hz is stuttering badly, clearly visible from the vertical pan within the first 15 seconds of that video. Both version use the h264 codec.

The equipment should be well capable of 4K@60Hz, so what am I missing here?

4k H264 60Hz is not supported, see amlogic specification


I just purchased my second X96 Air 4/32.
I cant get it to boot up using microsd card. I have try all of the s905X3 DTB images.
Get this error
*** Error in mount_storage: mount_common: Could not mount LABEL=COREELEC ***

Same card inserted in usb card reader works and coreelec boots normally.
I have tray to install coreelec on USB pen and that works too.
But i want to have installed on microsd.
My first X96 Air normally works with coreelec installed on micro sd.
Any solution?

p.s. English is not my native…

Try to burn the image with Echer.
Wich Coreelec image do you use ?
Generic or Ng-Generic?

Is “sync playback to display” working for anyone on this device ?

I think that it’s disabled on all devices.

Same result with Etcher.
Image is CoreELEC-Amlogic-ng.arm-9.2.5-Generic.img
DTB is sm1_s905x3_4g_1gbit.dtb
With brand new microsd card is the same result.
Coreelec working only on USB pen drive with this new box.

That is ofc a shame…

Guys what temperature do you have with this device?
How you fix this high temperature?

Mines currently running for 6h and I have 72 Degree.
I’m buyed it new and I think to give it back and choose maybe a Tanix Tx3 instead.
I heard it should work cooler.

There is an extensive thread on cooling this box

This version is avaialble to download here: https://chinagadgetsreviews.com/download-android-pie-9-0-firmware-for-x96-air-tv-box-5.html


Hi everybody,

I got a X96 Air P3 in the 4GB / 64GB version and installed Coreelec 9.25 and everything works fine. Now I decided to flash Coreelec to the internal emmc by booting a working installation from a 32GB µSD and using the ceemmc command with the option 3.

This works fine, but with one flaw: ceemmc only detects 32GB of the internal flash, while the ( now removed ) Android version reported 64GB of emmc. I am using this device tree: sm1_s905x3_4g_1gbit.dtb

Any ideas or hints ?