[S905X3] X96Air_P2/P3 4/32GB 1Gbit Lan (How to config)

Resize the partition.
Or do it again with 64GB µSD… :rofl:

The mystery is solved: I have been cheated. The box has been sold as 4GB RAM and 64GB ROM version. It has a label on the bottom which claims 4GB and 64GB. And as I wrote, the original Android reports 64GB ROM. Nevertheless, on the inside is another label which claims “4 + 32”. And on the backside of the PCB I found one flash chip of the type “KLMBG2JETD-B041”. This is a Samsung flash chip with 32GB capazity. The compatible type with 64GB would have been the “KLMCG4JETD-B041”.

So the manufactorer used a 32GB chip and then patched the Android image to falsely report a capacity of 64GB. Nevertheless I will keep the device because the 4GB / 32 GB version is only a few bucks cheaper.

Will make no difference in use unless you intend to store your 10 movies on it.


First seen with Beelink. They cheated their users with the same trick. I would like to blame chinese companies but there are also fair players. I would mostly blame consumers greed to get cheaper and cheaper.

Just an addition to my previous post: I managed to flash the eMMC back to a stock android version for this device using a µSD card prepared with Burn_Card_Maker 2.02 and this file: X96Air_P3_20200831-1753.img ( can be found with google )

And it was not a surprise that this Android version now reports the correct eMMC size of 32GB. The image which the box came with at delivery was dated September 2020, while the image I flashed now is dated August 2020. Seems to me that the producer took the X96Air_P3_20200831-1753.img and manipulated it to falsely report 64GB eMMC and a newer production date.

It took me a while to find a usable µSD card which was recognized by the box. I first tried a 2GB Verbatim and a 8GB Intenso and according to dmesg both cards where not correctly detected. Then I took the 32GB Sandisk which I used at first to boot Corelec from µSD, and this card was recognized immediately . I was able to boot into recovery mode by pressing the hidden button during the startup. The box instantly started to flash the Android image, which after a reboot reports the correct eMMC size of 32GB.

Since the recover of Android was only for test purposes, I just finished to flash Coreelec to the eMMC again, and everything works fine. The main advantage is that the eMMC is much faster than the µSD card: About 225 MB/s writing and 158MB/s reading. The next thing will be a speed test using a 2,5" SSD in an USB 3.0 enclosure. :slight_smile:


Followed this guide and now managed to dual-boot Android and CoreELEC on the eMMC.

Working fine on this device which is great using ceemmc -x

I just received my X96 Air. How can I check the current temp of the SoC while playing a movie without having to enter the menu? Or how do I see afterwards if the system has been throttled to reduce the temp?

For example:

  1. CLI
    SSH to the box and execute a script like:
cpu_temperature=$(cat /sys/class/thermal/thermal_zone0/temp)
echo $((cpu_temperature/1000))°C
  1. Map this to a button on the remote

If you are willing to enhance your skin, you can use $INFO[System.CPUTemperature()] for that information. For example, on Confluence skin you would modify this file DialogPlayerProcessInfo.xml

The temp itself will not tell you if you are throttling, you need to monitor the CPU speed in real time as well. Even then you can only do it if you have your governor set to Performance. In performance your CPU is locked to its maximum speed and it is the dropping off from that max speed which indicates throttling. Anything else is simply inference.


And how can I monitor the CPU speed (if the temp does not get me anywhere)?

The easiest way is to use the CE information screen. This has the advantage of placing extra stress on the CPU.
If you
-set governor to performance (there is a CE setting for that)
-play a movie and open the information panel you can observe the temp and CPU clock in real time.
If it sticks at 1.9ghz then you do not have throttling issues, you should also observe that the thermal controller and throttling kicks in at the trigger temp of 70C (or close to), but these on chip tempo sensors are not that reliable.

You only need to see this for a few minuites to confirm if you have an issue with overheating. Setting the governor back to ondemand might then be all you need to do to avoid throttling - but there is no real way of checking this.


1 Like

Just popped in to say thanks to the OP. Finally got a X96 Air 32GB version and CE is very good on this box. Easy to install to internal as well.

1 Like


Have any of you tried the latest CE version on this hardware?
Is it possible to do a “painless” update from version 9.2.7 to the newest?
If everything has to be done from scratch, what does the case of the pilot / bl301 / VFD look like under the CE19.x?

Thanks for any feedback.

If you just let it do the auto update from the CE settings, it will be painless. Bear in mind, this will still leave you on the Leia Version. (legacy)
Did this on my X96 Max+ same specs as your. VFD still works, I don’t use bl301.

I then did an update from Leia to Matrix on a separate sd card. I can’t remember exactly how I did this. My MQ8 skin doesn’t work, my skin went to Estuary, a couple of addons don’t work, Onmute being one. I get a message saying VFD doesn’t work, display comes on, but stuck.

Thanks for reply!

So I guess that CE19.x is not a good idea right now ?


A fresh install will be needed. Anything less will have retained settings which will mess up your functionality.


Hi awesome community! Firstly, thanks for all the tips & suggestions I’ve been able to scrape off this thread and many others. As a new user I thought I may contribute by reporting on my newly arrived box from AliExpress
It is advertised as 4gb+64gb+1000m and comes up with new version ‘X96Air_100_20201125-2051’.
The boot screen was just stuck on the X96 Air screen forever on trying 4gb_1gbit & 2gb_1gbit dtbs. I finally got it to boot by using sm1_s905x3_4g (not 1gbit) dtb! On testing lan speed within coreelec I get 200+mbps on 5g wifi but ~90mpbs using lan. Therefore, I think the X96Air_100 new variant is 4gb+64gb+100m!
Other observations: 5g wifi works, bluetooth works, atmos etc everything works just fine.


1 Like

A few months ago I bought my second X96Air 4/64GB device on Aliexpress and I had many doubts because many vendors offered more modern devices but only with 100Mbps ethernet which I did not want. In the end it seems that I found an honest seller like the first time I bought this and I have two X96Air 4/64GB 1000Mbps.

In summary, we must be very careful when we buy online, check the age of the store, the volume of sales, the comments of other users. Aliexpress works fine, I’ve only had a problem with a fake seller (unfortunately this is more and more frequent) and my money was refunded to me by Aliexpress.

1 Like

Hi everyone,

I have an air96 air box p3 4ghz ram véion running coreelec 2.9.7 everything ok
But when i play dolby atmos movie, it always decode to dolby trueHD, how can i fix this?
My AVR is denon x4300H and It can decode dolby atmos
Thank you all.