S905Y2 hardware acceleration not working

Hello,

I have a MagentaTV Stick and the hardware acceleration doesn’t work there. I’ve tried different codecs/sources.

When I play a video, the picture is black and the sound works at times. Sometimes Kodi also hangs a bit when playing.

With H.264 comes in the log files when playing:

CoreELEC kernel: 0: timeout_process decoder timeout, DPB_STATUS_REG 0xf0
CoreELEC kernel: 0: vh264_work_implement, decode timeout flush dpb

Here are the logs where I reproduce the error with H.264:
http://ix.io/4lF6

The hardware of the Magenta Stick is comparable to the Radxa Zero.

Processor S905Y2 4x 1.8 GHz ARM Cortex-A53
GPU ARM Mali-G31 MP2
RAM 2GB

I have the problem with Coreelec 19 Generic and 20 Generic and the g12a_s905y2_2g.dtb
But I’ve already tested the image for the Radxa Zero and there the same error.

I would like to use hardware acceleration. Can someone tell me why it doesn’t work and maybe even how I can solve it.

Thank you very much

dile

You will need another Android firmware as the hardware decoder lock (what we don’t have for such SoC) is active. There was something similar not long ago here in forum with same issue. Anther firmware solved it.