[S922X] Bee-link GT King

Yes it’s like 60% (6 out of 10 boxes we got) are broken. No idea what is going on. I have contacted Beelink last week but till now no real help. Sounds a bit weird. But if you hit the problem you will be limited to 100M.
Nothing really we can do about it. Although even Android with Ethernet is bad on those.

We were trying to get Wifi to work before releasing a testbuild. And HEVC was broken because it supports 8K :smiley:
But now everything is coming together and I hope some of the conspiracy theories that we hate Beelink users will stop.

You all will have a good experience with your devices. Just consider that you might as well face the ethernet issue (most likely hardware defect).


Worth adding that wifi performance on this box is one of the best I have seen with over 100mbit/s if you have a AC wave2 router.


S922X revB and the A311X/D chips support 8K hw decoding of HEVC, VP9 and AVS.
This means that both the GT-King and the KVIM3 will support 8K decoding.
I don’t know if they actually support HDMI 2.1, so 8K output may not be available on them, but the test videos we tried seem to be working rather well with only 25% CPU load, which is VERY impressive.

On the other hand, the Ethernet issues are discouraging. My unit doesn’t work at 1Gbit neither in CE or Android. Making it quite useless (for me) for high bit-rate video playback.

We still need to fix the DTB, because audio passthrough doesn’t work right now.

I am having issues with getting Wifi/BT to work, but Adam is the one working on this part, so hopefully we’ll have that going very soon.


Devs are doing an amazing work! It will be a great Coreelec experience!

1 Like

Great news !

This is the GT-King playing a 8K 30FPS video directly from YouTube

8K 30FPS is the max this chip can handle. At 8K 60FPS it bugged out, and I had to reboot the box for playback to return to normal.

1 Like

I think it can only do 8K at 30fps

Here’s the first test build based on the latest code we have
Use nightly.

Installation procedure is just like any Android TV box. Burn SD/USB, place the beelink DTB from the device_trees folder into root and rename it to dtb.img. Put the SD/USB in the box, press and hold the reset button (it’s on the bottom, need something really small, like a SIM ejector), turn the box on, and hold for ~10 seconds.

Things that work:

  • PCM audio
  • 4K HW decoded H264, HEVC, VP9
  • 8K HW decoded HEVC, VP9 - could potentially be buggy.
  • WiFi
  • Bluetooth

Things that don’t work:

  • Audio passthrough
  • This build doesn’t include DVB drivers.
  • Ethernet can have issues at 1Gbit speed.
    In case of Ethernet problems, you can set it to 100Mbps manually. Run the following commands in SSH:
echo "ethtool -s eth0 speed 100 duplex full" >> /storage/.config/autostart.sh
ethtool -s eth0 speed 100 duplex full

wow nice info thx for sharing

Just been doing some quick testing. I have the newer revision GT King with serial number starting B922. This one has a default CPU speed of 2.2ghz instead of 1.8ghz.

I have not seen any issues with my Ethernet and no buffering even on large 4k files.
wifi appears to be very slow when connecting to my NAS with SMB but not tried NFS yet. Wifi basically unusable for me.
I get screen corruption with 4k HEVC HDR files. The file still plays but has lines over this image and corruption along the bottom. You can still see what is playing.
standard h264 files appear to be ok.

I would say this is great progress so far for a first test build. Thanks for supporting this device.

Please run dmesg | paste and dispinfo in SSH while playing the problematic files and post the URLs.

Here is the info you requested.


The screen overlay does not work either when there is corruption.

Stop the video. Put this in SSH:
echo 444,10bit > /sys/devices/virtual/amhdmitx/amhdmitx0/attr
Then play the video again, see if there’s any difference. If that doesn’t help, try with
echo 422,10bit > /sys/devices/virtual/amhdmitx/amhdmitx0/attr
echo 420,10bit > /sys/devices/virtual/amhdmitx/amhdmitx0/attr

Reboot to go back to “normal”.

None of the changes made any difference and with the last change I get a blank screen.

I have now tested the box on 2 tv’s that are both 4k 10bit panels and still get the same corruption. It appears to be the OSD overlay as once the file is playing I cannot get back to any of the menus or bring up the settings until the file is stopped.

I am using this dubai sample file to test - https://www.demolandia.net/downloads.html?id=60876578

HEVC 10-bit 23.976fps

Interesting. I’ve only used it with my old Toshiba LCD TV. I’ll be hooking it up to my LG soon to do some more tests.

Great to see the first public beta ! thanks you all for your work !

I’m testing it.

No ethernet problem for me.

I can’t display kodi in 3840x2160p, the image is stuck and weird.
It works fine in 1920x1080p.

Do you mean GUI or video playback?

GUI, didn’t test playback yet.

Please explain what you mean by “stuck and weird”. Are you using a clean install or did you restore an old backup?