[S922X] Bee-link GT King

Ethernet isn’t working for me in Android too. It’s not an issue with CoreELEC. It’s a hardware problem with the device I have.

thanks a lot!!

on my gt king beelink, my ethernet functions coreelec but it doesn’t work when I go to Android.

It’s something we’re aware of, and looking into.

Greetings and thanks for your great work. I have a problem with passthrough audio AC3, DTS via optical SPDIF. Sometimes Audio starts correctly when starting a video (mostly mkv), sometimes Audio sets in after the video started (1 or 2 minutes or longer). From then on it keeps playing for that video even if I forward or jump around. Sometimes Audio never starts. Is this a known issue? I only play files locally from USB Harddrive. My files only contain core AC3 or DTS, no DD+ or other HD Audio. Latest nightly (811).
Funny thing is that this problem occurred gradually after installing Codeelec. I tested several videos and for the first half hour or so audio worked flawlessly. Then slowly the issue appeared and grew worse over time. Now audio almost never starts… Reboot does not help.
Sorry if there is already an answer and I overlooked it, and sorry for my english.

Hello . fixed ethernet problem
Credit aquagenptz https://4pda.ru/forum/index.php?showtopic=948258&view=findpost&p=87947976
You need to replace (short circuit) this resistor with a jumper

The LAN port is active and it works as usual Android/CoreELEC .


Guessing from image, pity, that this needs reapply thermal pasta and thermal sink, but great find!! Maybe worth mention also to the vendor.

Thanks for letting us know. (I used translator for the original russian summary)

Nice! I tried it, but I accidentally lifted the top pad. So now I have no Ethernet at all.
I’ll try shorting these contacts using conductive ink later, hopefully it will work.

Why didn’t you just add a wire across the resistor, for easy removal if it doesn’t work for you ?

These are 0201 smd components, they are very tiny, it’s tricky to solder them.
The resistor came off as soon as I touched it with the soldering iron. Since this is a dev box, I don’t care too much about it, but I will give fixing this screw up a shot anyway.

1 Like

Is that 0,6 x 0,3 mm size ? No wonder then :slight_smile:

Yep :slight_smile:

Interesting finding :+1:
This series resistor is on the RX-CLK line, and is usually placed there for impedance matching to the trace.
So obviously they have an issue with their Highspeed-design and/or the timing (skew Clock/Data)

Or just put the wrong resistor into that batch accidentally…

I have RX problem on box, so I will try this hack next week and will try to not kill the box :grinning:

… agree, could also be a bad batch with wrong resistor placed. In this case a Q-problem :wink:

After that fix can you get stable 1Gbps speed?

I managed to somehow bridge the two contacts, and got ethernet working again.
But 1Gbps is still a no-go for my GT-K, it was able to acquire an IP address this time, which it never did before, but still couldn’t get any traffic through.
It’s possible that that board is damaged, and this is degrading the signal, but whatever the reason is, I give up on this for now. 100Mbps works, it’ll have to be good enough for now.

@hungphutho Just out of curiosity, what tools are you using? That jumper wire and overall solder job is very clean.

Does this affect all GT LInk revision A & B ? My router Asus RT-N18U is showing me
1000M Full but in Samba<->GT Link file is transferred only with cca 22-23 Mbit/s.

How can i check if my box has this problem or not?