[S922X] Bee-link GT King

I know how these chinese manufacturer works. Do not believe they go through any accurate testing, most probably for them it is enough that the link goes up and there is some traffic through it

1 Like

I don’t know if this helps but I had similar problem with my pc and router. Although both supports gigabit, they were working in 100mbps mode.
I used cat5, cat6 and cat7 cables but the result was same.
Then I read that in order to get gigabit speed, I needed to use Cat5e cable.
Before that, I was assuming that Cat6 or Cat7 is superior and they should have worked fine with gigabit.
Only Cat5e cable worked fine.
With cat6 and cat7, I had to switch “Auto Negotiation” to “1.0 Gbps Full Duplex”
Have you guys tried that?

It negotiates 1Gbps fine, but in my case there’s no traffic, and in my case I can’t even get an IP address from DHCP.

So the problem is on the RGMII connection between PHY and MAC. I have always suspected issue with track rounting and clock screw, but the experiments made by boot2k3 did not came at any good result.
I had a similar problem with my S912 box, T95zmax plus, where in Android gigabit connection worked and failed in linux. The solution was to remove the setting of cali_val (now committed in CE 3.9 kernel).
And this is strange, because unless they run some special kernel, this value should be applied in Android…

Ethernet isn’t working for me in Android too. It’s not an issue with CoreELEC. It’s a hardware problem with the device I have.

thanks a lot!!

on my gt king beelink, my ethernet functions coreelec but it doesn’t work when I go to Android.

It’s something we’re aware of, and looking into.

Greetings and thanks for your great work. I have a problem with passthrough audio AC3, DTS via optical SPDIF. Sometimes Audio starts correctly when starting a video (mostly mkv), sometimes Audio sets in after the video started (1 or 2 minutes or longer). From then on it keeps playing for that video even if I forward or jump around. Sometimes Audio never starts. Is this a known issue? I only play files locally from USB Harddrive. My files only contain core AC3 or DTS, no DD+ or other HD Audio. Latest nightly (811).
Funny thing is that this problem occurred gradually after installing Codeelec. I tested several videos and for the first half hour or so audio worked flawlessly. Then slowly the issue appeared and grew worse over time. Now audio almost never starts… Reboot does not help.
Sorry if there is already an answer and I overlooked it, and sorry for my english.

Hello . fixed ethernet problem
Credit aquagenptz https://4pda.ru/forum/index.php?showtopic=948258&view=findpost&p=87947976
You need to replace (short circuit) this resistor with a jumper

The LAN port is active and it works as usual Android/CoreELEC .


Guessing from image, pity, that this needs reapply thermal pasta and thermal sink, but great find!! Maybe worth mention also to the vendor.

Thanks for letting us know. (I used translator for the original russian summary)

Nice! I tried it, but I accidentally lifted the top pad. So now I have no Ethernet at all.
I’ll try shorting these contacts using conductive ink later, hopefully it will work.

Why didn’t you just add a wire across the resistor, for easy removal if it doesn’t work for you ?

These are 0201 smd components, they are very tiny, it’s tricky to solder them.
The resistor came off as soon as I touched it with the soldering iron. Since this is a dev box, I don’t care too much about it, but I will give fixing this screw up a shot anyway.

1 Like

Is that 0,6 x 0,3 mm size ? No wonder then :slight_smile:

Yep :slight_smile:

Interesting finding :+1:
This series resistor is on the RX-CLK line, and is usually placed there for impedance matching to the trace.
So obviously they have an issue with their Highspeed-design and/or the timing (skew Clock/Data)

Or just put the wrong resistor into that batch accidentally…

I have RX problem on box, so I will try this hack next week and will try to not kill the box :grinning:

… agree, could also be a bad batch with wrong resistor placed. In this case a Q-problem :wink: