[S922X] Bee-link GT King

Serial: 290b

1 Like

If it’s revB with the correct dtb you will have 2.2 Ghz. In CoreELEC.

Don’t look at the CPU speed displayed in Kodi, it always shows 1800 MHz for both rev. A and rev. B because it is showing the frequency of A53 cores and not the A73.


What do I need to do to check the 8K decoding on the rev. A? I’ve simply tried to play 8K using the latest nightly and all I got was a black screen but I don’t know if it is supposed to work this way on the rev. B.

Use inputstream addon, set decoder to max resolution, try some 8K youtube video.

1 Like

8k could work on rev. b only

Surely Rev B is 2.2 GHz ?
Rev A is 1.8 GHz ?

A53 cores are clocked 1.8GHz in both revisions.
A73 cores are 2.2GHz on rev B and 1.7GHz on rev A.

1 Like

So my rev b playing without problem 8k from youtube addon

Regarding the 8K decoding not possible on the rev. A… would it be possible due to e.g. missing nodes in the device tree or different configuration of the decoder done in the bootloader or is this the proof that it is actually a different hardware?

As Beelink still claims the hardware is the same and that they can release a firmware that will basically “restore” the rev. A to the rev. B.

It’s a hardware limitation.

Am I the only one to use the “CE on eemmc only” solution here ?

No. I have mine on emmc.


whats the cheapest USB DVB-S Tuner that will work in CE 9.2.1 ?

Its not exactly answering your question but I use one of these as a headless TVHeadend server. That box is on 24/7 and does all my tv recordings and serves my other two boxes in the house.


I installed CE to the internal emmc of my rev.A GT-KING using the new ceemmc tool. I used the dual boot option leaving Android intact. CE now loads a few seconds slower than it did from my Samsung EVO 64GB card. Is this normal?

Also, the instructions for ceemmc says this:
Android is still bootable and can be entered by the CoreELEC shut down menu item:
Reboot from eMMC/NAND

But on my shut down menu there’s no such option. How would I add this option?

What skin are you using ??

I’m using Confluence. I’ve been using it for years and it’s the only skin I really like.

1 Like

there are some possibilities. You can search the forum for answers. And you can start in this topic:

Thanks for the info. I ended up modifying my Confluence skin’s shutdown menu and changed the Shutdown Timer option (which I never use) to Reboot to Android. It works perfectly.