[S922X] Bee-link GT King


Sry for stupid question but I need little help …
I made new installation with rufus for my GTking. After reboot procedure GTking stuck on beelink black boot logo and CE dont want to make initial installation from SD card.
I presume that problem is dtb.img witch I cant replace because I do not have “g12b_s922x_beelink_gt_king” file in devicetree folder.

Which image have you downloaded?

Firstly i tryed with CE official rev.b, then rev.a and nightly version after all …
In all these images I do not have “g12b_s922x_beelink_gt_king” file in devicetree folder.

Hmm, I’m looking at “device_trees” folder of CE 9.2.1 and both “g12b_s922x_beelink_gt_king” and “g12b_s922x_beelink_gt_king_rev_a” files are in there…
Are you sure you downloaded the proper image for your box that is an -ng version ?

Btw, use Etcher for image burning, much easier and with image verification after it’s written on the media…

1 Like

Found problem …

My micro SD is dead :face_with_monocle::pleading_face::sob:
Before making image for GTking I had CE of my old nexbox a95x on that SDcard, but for some reason card become unwritable.
although Rufus showing writing process for GTking CE image, on card stays Nexbox CE with old devicetree folder :grin:

anyway … Thanks for try to help guys :clap::clap::+1::ok_hand::facepunch:

I am booting from SD card and I can only see the SD storage in Kodi file manager.
I have lots of music on the internal android eMMC storage and I would like CoreElec/Kodi to be able to see it so I can play it from CoreElec.
I almost don’t use Android anymore and I would like to use the internal ~64GB storage space.
How can I do that?
I see people using LibreElec mounting a /dev/data partition but I don’t see it when I execute blkid

don’t you think that it might be worth a try to migrate to CE only on emmc ?

Well… perhaps someday but I’ve read that if something goes wrong it can brick the box.
Having the Android system available can also be a good option in case we need to use some App: Netflix, Flud or so…

Can someone elaborate a little bit on the GPU specification inconsistency of S922X and A311D?

Is it G52 MP4 or G52 MP6? I’ve seen both. Or is there a different GPU in S922X and A311D?

I don’t know about Flud, but Netflix add-on is working great and in fHD with CE

New GTKing owner here. I am following the recommended installation procedure but keep getting the error message after reboot: "Could not mount LABEL=CE_Flash "

I have tried:

  • 2 different micro SD cards
  • write images on windows and Mac (Etcher, Rufus, etc)
  • Rev A hardware - used correct GTKing Rev A dtb
  • tried stable and nightly versions of CoreElec (9.2.1)

On the GTKing Android has been updated to latest OTA version and it is working well. The CoreElec boot process stops every single time when using the SD card. From an USB drive the system does not boot at all. I would appreciate any suggestions to make it work.

You have a old bootloader environment. Just insert the CE media and push and hold the reset button on boot. Or use the method you used for the first time you started CE on your box.

1 Like

After every OTA Android update to start CE you have to use the method which you used for first CE installation, that @Portisch above mentioned.


Hello KOPRajs
I have also GT King Pro , but I cannot boot to CoreELEC. I tried both versions in device trees, but I can boot still only to Android. Also tried with long-press the reset hole and connect the power cord. But then I get only to Andoid Recovery menu. Can you help with this problem ? Many thanks.

Great advice, worked 100%. Thank you.

This is great advice, should be in the FAQ. Everything’s working fine now.

Replaced SD Card and CE is fully working.

I’m running CoreELEC (official): 9.2.1 (Amlogic-ng.arm) on GT-King and I can’t shutdown or reboot properly.
The box disconnects the ssh session, the screen turns black but it stays with the green leds and never really turns off or reboots.
To turn it on again I have to disconnect the power and connect again. The remote doesn’t work either.
This happens if I shutdown or reboot on Kodi UI or using a ssh terminal command.
The Suspend option on Kodi does work, however (the led turns red), and I can resume pressing the remote power button.

– Any idea why the shutdown doesn’t work?
I’m booting from SD card and I have a mounted partition to eMMC. Can this be related?

I’ve installed the CoreELEC BL301 Wake-Up feature [inject_bl301] but it didn’t change anything.

My config.ini is
decode_type=‘0x0’ # NEC

Upload a link on your logs

1 Like

Thank you.

Here are the logs:
From Kodi: http://ix.io/24mK
From ssh dmesg | paste : http://ix.io/24mL

I collected them after I tried to turn off using both the remote and Kodi (that doesn’t wok properly like I mentioned). Then I had to turn off the power and turn it on again on the electric cord since powering on from the remote doesn’t work either.