[S922X] X88 King

Followed instructions from here
Made keymap, success :grinning: thanks

@amirul could you upload the files for the x88 king remote?

Here you go
x88king_keymap (485 Bytes)

@amirul is it the purpose to put the file in the config folder then use the inject_bl301 feature? And it’s working.

I don’t know what I’m doing wrong but I can’t handle this pilot and I’m probably making a mistake but I don’t know where. I pasted these files into my place and it looks like this

someone looking at what I’m doing wrong

Shouldn’t the filename be “rc_maps.cfg”?
Anyhow, looks like you are mixing meson-IR & amlremote operation…
Follow this guide:

tries all day according to this guide

metodą meson-ir . unfortunately the remote still doesn’t work :frowning:

Delete your files & start from scratch, as decribed in the Guide.
As you go with meson-IR, skip the amlremote section

  • stop services by SSH
  • Download the table from amirul & store it under /storage/.config/rc_keymaps/x88king_keymap (file without extension!)
  • Create file /storage/.config/rc_maps.cfg with content meson-ir * x88king_keymap
  • start services by SSH
    Skip the ir-keytable step, as you already have the file from amirul.
    Good luck!

I do not know why I could not before but at the moment I was able to run the original remote control but half the success because the volume keys still do not work. I had the same effect without uploading x88king_keymap on the purchased remote control.

made a remote.conf for the x88 king: remote.conf (2.1 KB)

Do I just not have the + - volume keys working? After turning off the X88 king, USB does not work, so you cannot turn it on with an additional remote control :frowning:

the volume keys look a bit like they’re on both sides of the remote. Usb does work with 9.2.2. Here’s the repo for the remote.conf.

The volume buttons on the right hand side of the remote, are for learning key presses from your tv.

ok thank you, i had a bad remote conf


I enjoyed only 5 min. The buttons work until I enter any submenu from that moment they do not work and I have no idea where the error lies

maybe remove the remotesample file from /configfiles , or update your ce version.

unfortunately no result

empty batteries?

what batteries After all, the remote control works and only the volume control does not work

@artpaw seems you were right about the x88 king and the remote not working. It seems when you press the ‘back’ button (0x00) once it goes into another remote mode and that causes the rest of the buttons to stop working. If you press the ‘back’ button for a second time, it starts working again. It’s switching between remote mode and normal mode for some reason.remote.conf (4.4 KB)

The error wasn’t there before the update of the meson package.

@ mark1978 agrees that the problem you are describing is occurring but is not bothersome. The volume keys are still not working. For now, I have programmed the additional keys in the original remote controls that control the TV, but this is a worse solution

1 Like